PhpStorm 2018.2 Help

TODO Tool Window

View | Tool Windows | TODO
Alt+6


PhpStorm constantly scans your project for comments in the source code that match specific TODO patterns and displays them in the TODO tool window.

The TODO tool window consists of the following tabs:

  • Project: Shows TODO items for the whole project.
  • Current File: Shows TODO items for the currently open file in the editor.
  • Scope Based: Shows TODO items for a certain scope, selected from the drop-down list.
  • Current Changelist: Shows TODO items in the active changelist (available only if version control integration is enabled).

Toolbar Buttons

IconTooltip and shortcutDescription
Previous TODO Previous TODO
Ctrl+Alt+Up
Select the previous TODO item in the list.
Next TODO Next TODO
Ctrl+Alt+Down
Select the next TODO item in the list.
Filter TODO ItemsFilter TODO Items Select a filter or open the TODO dialog to edit the list of TODO patterns and filters as necessary.
View OptionsView Options Select how to group TODO items in the list. Not available for the Current File tab.
Preview SourcePreview SourceShow a preview pane with the source code of the selected file and the corresponding TODO item highlighted.

Title bar

IconTooltip and shortcutDescription
Expand All Expand All
Ctrl+NumPad Plus
Expand all nodes in the list.
Collapse All Collapse All
Ctrl+NumPad -
Collapse all nodes in the list.
Show Options MenuShow Options MenuOpen the options menu for the TODO tool window.
HideHideHide the TODO tool window.

Context menu

ItemDescription
Jump to Source Jump to the location of the relevant comment in the source code. Available only when you right-click a TODO item or a file.
Local History

Show the Local History submenu:

  • Show History: Open the Local History window for the relevant file.
  • Put Label: Add a label to the Local History.
Last modified: 27 July 2018