RubyMine 2016.3 Help

Configuring Available Ruby Interpreters

In this section:

Overview

The list of Ruby SDKs, available for the various projects, can include interpreters installed locally or remotely .

Viewing the list of available interpreters

To view the list of available interpreters

  • Open the page Ruby SDK and Gems (Settings/Preferences dialog - Languages and Frameworks).
    /help/img/idea/2016.3/rm_available_interpreters.png

Configuring the list of available interpreters

To configure the list of available interpreters, follow these general steps

  1. Open the Settings dialog box, and click Ruby SDK and Gems page.
  2. Click /help/img/idea/2016.3/new.png.
  3. From the drop-down list, select whether you want to add an interpreter from your local computer, or the one located remotely.
  4. The next step depends on the selected interpreter location.

    When an interpreter is added, it is included in the list of available interpreters.

  5. Apply changes.

Removing interpreters from the list

To remove an interpreter from the list of available interpreters

  1. In the list of available interpreters, select the one to be deleted.
  2. Click /help/img/idea/2016.3/delete.png.

See Also

Concepts:

Last modified: 30 November 2016