This inspection reports any instances of the Java 5.0 for statement syntax. Such for statements are not supported under Java 1.4 or earlier JVMs.