RubyMine 7.1.3 Help

Ruby

Prerequisite

Ruby SDK should be downloaded and installed on your computer.
For the Windows platform, use the Ruby Installer and Development Kit.

Important notes

  • RubyMine supports the following range of Ruby SDK versions:
    • 1.8.x
    • 1.9.x, with the lambda syntax, local variables semantics, new method parameters declarations, etc.
    • 2.0, with named arguments, Ruby 2.0 debugger, %i/%I syntax parsing, prepend support.
  • Depending on your platform, you can use IronRuby, MacRuby, Rubinius, MRI Ruby, or JRuby.
  • RubyMine supports cygwin as the Ruby interpreter platform.

Ruby and Ruby-on-Rails specific procedures

The following sections contain procedures that pertain to both pure Ruby and Ruby-on-Rails programming.

See Also

Last modified: 27 June 2015