Aqua Help

Data editor and viewer

Overview

The data editor and viewer, or data editor, provides a user interface for working with data. In the data editor, you can sort, filter, add, edit, and remove the data as well as perform other associated tasks.

In Aqua, the data editor and viewer lets you work with database object data, query results sets, and also DSV files data.

Data editor tab
  1. Toolbar.

  2. Filtering and sorting queries pane.

  3. The database object data in a Table view.

For more information about Database tool window, refer to Database tool window.

Data editor in a Result tab
  1. Toolbar.

  2. The query result set in a Table view.

For more information about a Result tab of a Services tool window, refer to Result tabs.

Data editor in the in-editor results
  1. Toolbar.

  2. The query result set in a Table view.

For more information about In-Editor Results, refer to In-Editor Results.

Data editor tab in a delimiter-separated values file editor
  1. Toolbar.

  2. The DSV file data.

For more information about viewing and editing files with delimiter-separated values, refer to Edit DSV files as tables.

The default view mode is Table. In this mode, you can filter and sort data, edit value of the cells directly, and work with rows of the data table.

Open database object data

To open database object data in data editor, in the Database tool window, do one of the following:

  • Double-click a database object.

  • Select a database object and press F4.

  • Select a database object and click the Edit Data button (the Edit Data icon) on the toolbar.

  • Right-click an object and select Edit Data.

View query results set

To view a query results set in data editor, in a query console, do one of the following:

  • Run an SQL query. The data editor opens in a Result tab of the Services tool window.

  • Click the In-Editor Results button () on the toolbar and run a query. The data editor opens in the query console in-editor results pane.

For more information about a Result tab of a Services tool window, refer to Result tabs.

For more information about In-Editor Results, refer to In-Editor Results.

View DSV files data as a table

  1. Right-click inside a delimited text file and then click Edit as Table. Alternatively, you can click the Edit as Table icon in the editor.

  2. In the Configure CSV Format for <file_name> dialog that opens, specify format settings and click OK.

    The dialog has three predefined formats (CSV, TSV, and Pipe-separated) and lets you create a custom format. For example, you may require comma-separated values with semicolons as row separators.

    Once you confirm the format settings, the Data tab will present data in a table format correspondingly. If you want to use different format settings, repeat the previous procedure and open the data editor again.

Close data editor

  • To close data editor, click the Close icon Close next to the corresponding tab title.

Work with data

View data

You can browse and edit data in three modes: Table, Tree, Text, and Transpose. In the Table mode, you can also transpose the view. Use the value editor to view and edit contents of a separate cell.

For full information on data view modes and other features, refer to View data.

The transposed table viewing mode

Compare data

Compare the data of two database objects. For comparison, you can define how many columns should differ to consider two columns equal. You can also select to ignore the extra column in either one of the objects.

For full information, refer to Compare the data of database objects.

Compare table data tolerance equals to one

Sort data

You can sort data by clicking a column's header, or by entering a sorting query into the corresponding field. By default, each time you sort data, Aqua sends a new ORDER BY query to the database. You can also change the setting and sort data on the client side.

For full information, refer to Sort data.

Filter data

Use one of the following ways to filter data:

  • Specify filtering conditions.

  • Run a search on the table.

  • Enter a filtering query into the corresponding field.

For full information, refer to Filter data.

WHERE and ORDER BY fields for sorting

Export data

Aqua uses data extractors to export data in various formats to a file or the clipboard. Each time you export or copy data, the copied data format is defined by the selected data extractor.

Data extractor list on the data editor toolbar

You can use a built-in data extractor, configure a custom extractor that is based on CSV or DSV format, and create a custom data extractor using a provided API.

The last selected extractor becomes the default one for newly opened editor tabs. For MongoDB, the default extractor is always JSON.

For more information about exporting data in Aqua, refer to Export data.

Rows

Manipulate the rows by adding, deleting, cloning them, and so on. You can also navigate between related rows, between subsets of rows, or go to a specified row.

For full information on these and other features, refer to Rows.

Reference

Most of the available functions are accessed by means of controls on the toolbar, context menu commands for the data cells, and associated keyboard shortcuts.

Toolbar controls

Icon

Action and shortcut

Description

First page

Previous page

the Change page size button

Next page

Last page

First Page

Previous Page Ctrl+Alt+Up

Change page size

Next Page Ctrl+Alt+Down

Last Page

Use navigation icons and corresponding commands for switching between pages that show the table data and change the page size.

A number of rows that you see on the toolbar are referred to as a result set page. If this number is less than the number of rows in the table, only a subset of all the rows is shown at a time. If all the rows are currently shown, navigation icons and the corresponding commands are inactive. You can see the limit between the navigation buttons. You can change it here by clicking and selecting the necessary limit or in settings.

  • First page: jump to the first page of results.

  • Previous page: go to the previous page of results.

  • Next page: go to the next page of results.

  • Last page: jump to the last page of results.

To change the size of a result set page, click the Change page size button and select the size. Alternatively, open settings (Ctrl+Alt+S) and navigate to Tools | Database | Data Editor and Viewer. In the Limit page size to field, type a new size of a result set page. Alternatively, to disable the page size restriction, clear the Limit page size to checkbox.

the Reload Page icon

Reload Page

Ctrl+F5

Reload data for the table view to synchronize the data that you see in the editor with the contents of the database. Also, use the Reload Page button when you want to apply a new page size limit setting after its change.

the Update Interval icon

Update Interval

Select, pause, or disable update interval for the current table. You can also set a custom one.

the Cancel Running Statements icon

Cancel Running Statements

Ctrl+F2

Terminate execution of the current statement or statements.

the Add Row icon

Add Row

Alt+Insert

Add a row to the table.

To save a new row, click Submit button (the Submit button).

For more information about working with rows, refer to Tables.

the Delete Row icon

Delete Row

Ctrl+Y

Delete the selected row or rows.

To select multiple rows, click numbers in the gutter. Also, you can press Ctrl and click the necessary rows.

the Revert Selected button

Revert Selected

Ctrl+Alt+Z

Revert changes that you made to a cell value. You can select a scope of different cells and revert values in this scope.

For more information about reverting changes, refer to Submit changes to a database.

the Preview Pending Changes icon

Preview Pending Changes

Preview DML of changes that you made to the table.

the Submit button

Submit

Ctrl+Enter

Submit local changes to the database server. For more information about submitting and reverting changes, refer to Submit changes to a database.

Transaction mode

Transaction Mode

and

Transaction Isolation

Select the isolation level for database transactions and the way the transactions are committed.

  • Auto: the current transaction is committed automatically when you submit your local changes to the database server.

  • Manual: the changes submitted to the database server are accumulated in a transaction that can either be committed or rolled back explicitly by means of the Submit and Commit (the Submit and Commit icon) or Roll Back (the Roll Back button) buttons on the toolbar.

For more information about database transaction modes and isolation, refer to Submit changes to a database.

the Submit and Commit icon

Submit and CommitCtrl+Alt+Shift+Enter

(For the Manual transaction mode.) Submit and commit the current transaction. This button is available only for the manual transaction mode. See also, transaction mode and isolation.

the Roll Back icon

Roll Back

(For the Manual transaction mode.) Roll back changes. This button is available only for the manual transaction mode. See also, transaction modes and isolation.

Go to DDL

Go to DDL

Open DDL of the object in the editor.

the Find on Current Page button

Find on Current Page

Ctrl+F

Opens a search field for the current page of results.

the Show Chart icon

Show Chart

Opens data visualization.

For more information about about charts, refer to Visualize data.

Data Extractor

Data Extractors

Select an output format for your data. For the list of available formats and full information about data extractors, refer to the Data extractors topic.

Also, you can configure the following options:

  • Skip Computed Columns: do not include virtual columns that are not physically stored in the table (for example, the identity column).

  • Skip Generated Columns: for INSERT and UPDATE statements, do not include auto-increment fields when copying or saving data.

  • Configure CSV Formats: open the CSV Formats dialog where you can manage your delimiter-separated values formats (for example, CSV, TSV).

  • Go To Scripts Directory: open a directory with scripts that convert table data into different output formats.

For more information about data extractors, refer to the Data extractors topic.

the Export Data icon

Export Data

Export the table data to the clipboard or save to a file.

the Copy to Database icon

Copy to Database

Copy the data to another table, schema or database. Select the target schema (a new table will be created) or table (the data will be added to the selected table). In the dialog that opens, specify the data mapping info and the settings for the target table.

the Compare Data icon

Compare Data

Compare the current table with a table from the list.

For more information about comparing tables, refer to Compare table data.

the View as icon

View as

Select the mode for browsing and editing table data.

  • Transpose: viewing mode in which rows and columns are interchanged. You can combine this checkbox with other viewing modes.

    To make this mode a default for tables and views, open settings by pressing Ctrl+Alt+S and navigate to Tools | Database | Data Editor and Viewer. . From the Automatically transpose tables list, select Always. When this option is enabled, query results are not transposed.

  • Table: the default viewing mode of table data. Data in a table is stored in a cell that is an intersection of a vertical column and horizontal row.

  • Tree: viewing mode in which data is displayed in the key-value table with the possibility to expand the key cell if it contains children nodes. Data from the expanded children node is distributed between key and value columns. You might consider using this mode to work with JSON and array data.

  • Text: viewing mode in which data is displayed as a text.

For more information about viewing data, refer to View data.

the Show Options Menu icon

Show Options Menu

The Show Options Menu list includes the following options:

  • Show Geo Viewer: enable a graphic viewer to explore geospatial data in your database.

    For more information about the Geo viewer, refer to Using Geo viewer for geographical data in PostgreSQL.

  • Show Value Editor: open a separate editor where you can edit data that is stored in the cell.

    For more information about the editor, refer to Value editor.

  • Show Aggregate View: open the aggregate view where you can select values of multiple cells and get a single summary value.

    For more information about the view, refer to Aggregate view.

  • Sort via ORDER BY: sort data on the database side by sending a new ORDER BY query to the database. The client-side sorting does not run any new queries and sorts only the current page.

    You can define which sorting method to use as the default for tables. To do that, open settings by pressing Ctrl+Alt+S and navigate to Tools | Database | Data Editor and Viewer. . In the Data Sorting section, select or clear the Sort via ORDER BY checkbox.

    For more information about sorting data, refer to Sort data.

  • Show Filter: show or hide the filter box.

  • Paste Format: select how you want to treat the text from the clipboard on paste.

  • Reset View: restore the initial table view if you customized the table view before (for example, hidden columns or sorted data).

  • View Query: view the query that generated the table.

  • Copy Query to Console: copy the query that generated the table to query console.

  • Open Data View Settings...: open the Data Editor and Viewer section in settings, where you can define how table data are shown and modified in your query consoles and data editors.

    For more information about the Data Editor and Viewer settings section, refer to Data editor and viewer.

Context menu

You can find all basic actions for working with cells under the context menu. To call the context menu, right-click the cell that you want to modify. The following table lists all the actions.

Context menu of a cell in data editor

Action

Shortcut

Description

Edit

Enter

Edit a value in the selected cell or cells. Alternatively, you can double-click the cell and start typing a value. The Edit command is unavailable for read-only values.

  • To open the auto-completion list, press Ctrl+Space.

  • To confirm your changes, press Enter.

  • To cancel editing, press Escape.

For more information about editing cells, refer to Cells.

the Open in Value Editor icon Open in Value Editor

Shift+Enter

Open in a separate value editor where you can edit data that is stored in the cell.

For more information about the editor, refer to Value editor.

the Show Aggregate View icon Show Aggregate View

Open the aggregate view where you can select values of multiple cells and get a single summary value.

the Revert Selected button Revert Selected

Ctrl+Alt+Z

Revert changes that you made to a cell value. You can select a scope of different cells and revert values in this scope.

For more information about reverting changes, refer to Submit changes to a database.

Set Highlighting Language

Select a language that the IDE should use to highlight data in a cell.

Change Display Type

Select how the IDE should display binary data in the column. 16-byte data is displayed as UUID by default.

Set DEFAULT

Ctrl+Alt+D

Set the current cell value to the default value or the value that you specified for the column.

For more information about viewing or set a default value, refer to Manage default and NULL values for a cell.

Set NULL

Ctrl+Alt+N

Set the current cell value to NULL.

For more information about allowing a NULL value, refer to Manage default and NULL values for a cell.

Generate UUID

Generates the UUID for the selected cell.

Load File

Load a file into the field.

Save LOB

For the cells that contain a binary large object (LOB). Save content of a cell into a file.

the Copy icon Copy

Ctrl+C

Copy selection to the clipboard.

the Copy Aggregation Result (SUM) icon Copy Aggregation Result (SUM)

Copy a summary value for a range of cells. By default, Aqua copies the SUM aggregation result. To change the default, right-click the status bar and ensure that the Aggregator option is selected. Click the aggregator widget on the status bar and select the aggregator to use as default.

the Paste icon Paste

Ctrl+V

Paste the contents of clipboard into the table.

Add Row

Add a row to the end of a table.

Delete Row

Alt+Delete

Delete selected rows.

Clone Row

Create a duplicate of the selected row and adds the duplicate to the end of a table.

Go To

Navigation Bar

Jump to a navigation bar.

Database

Open the selected object in the Database tool window.

Related Symbol

Navigate to one of the related objects.

DDL

Open an object definition (DDL).

Row...

Ctrl+G

Jump to a specified row.

In the Go to Row dialog, specify the column and row number (use the column:row pattern).

All Related Rows

F4

Jump to a related record.

The command options are a combination of those for Go To | Referenced Data and Go To | Referencing Data. Read more about related data in Navigate between related data.

The command is not available if there are no related records.

Referenced Data

Ctrl+B

Switch to a record that the current record references. If more than one record is referenced, select the target record in the popup that appears.

Read more about related data in Navigate between related data.

The command is not available if there are no referenced records.

Referencing Data

Alt+F7

Use this command or shortcut to see the records that reference the current record. Read more about related data in Navigate between related data. In the popup that appears there are two categories for the target records:

  • First Referencing Row: all the rows in the corresponding table are shown, and the first of the rows that references the current row is selected.

  • Referencing Rows Only: only the rows that reference the current row are shown.

The command is not available if there are no records that reference the current one.

Filter by

Select a filter that you want to a column.

Full-Text Search

Ctrl+Alt+Shift+F

Open a search window where you can search for data in your database or a group of databases. For more information about full-text search, refer to Full-text search in databases.

Export Table to Clipboard

Copy the whole table to the clipboard. This action does not depend on Limit page size to setting.

Switch Session (your_current_session_name)

Open a window to select another session or create a new one. For more information about sessions, refer to Sessions.

Quick Documentation

Ctrl+Q

Show information about selected objects. For different database objects, Quick Documentation shows corresponding information. For example, for a group of cells, you will see a summary for the selection. You can preview it in a regular or in a transposed view and also see the related records by their foreign keys.

Last modified: 20 May 2024