Hub 2019.1 Help

Supported Environments

This page describes the hardware and software requirements for the JetBrains Hub service.

Hardware Requirements

A Hub service does not have a specific set of hardware requirements. These requirements vary based on the size of your database and the average number of transactions that are processed on a regular basis.

Our own Hub installation runs in an Amazon EC2 environment on an M3 General Purpose Large instance. To run the service, we allocate 9 GB to the Java heap. Our Hub installation manages more than:

  • 165,000 user accounts

  • 337 groups

  • 232 projects

  • 30 connected services

You can use this information for comparison to determine how much storage, processing power, and memory you need to run your installation.

Java Version

Hub is a web application that requires Java support. Hub is compatible with JRE versions 1.7 and later. A compatible version of the JRE is bundled with the installation package.

You do not need to install Java on client machines that access the application through the web interface.

Operating Systems

We do our best to ensure the stability of Hub installations on platforms that are commonly used for public servers on the internet. However, we cannot guarantee that the application is compatible with all possible environments.

Hub is supported on 64-bit versions of Windows and macOS as well as most popular distributions of Linux and other *nix environments. We do not support installations on versions of operating systems that have reached the end of their support lifecycle.

Web Browsers

Hub runs in a standard web browser. With the speed at which browsers are updated, it is not always possible to pre-certify every browser. We resolve functional issues in new releases of supported browsers as they arise.

We encourage you to update your browser to the latest version. You benefit from the latest security and stability fixes.

Hub is supported in the two latest stable versions of the following web browsers.

  • Chrome

  • Firefox

  • Safari

  • Edge

  • Opera

From version 2019.1, Hub no longer supports Internet Explorer.

Last modified: 4 July 2019