IntelliJ IDEA 2016.2 Help

Tiles 3

On this page:

Plugins

To be able to use Apache Tiles 3 support in IntelliJ IDEA, make sure that the following plugins are enabled:

  • Struts 1.x
  • Struts 2 (if you want to use the OGNL support).

(These plugins are bundled with the IDE and enabled by default.)

See Enabling and Disabling Plugins.

Libraries

To get the library files for your Tiles 3 development, use the Apache Tiles Downloads page.

Don't forget to add your libraries to the dependencies of corresponding modules.

Overview of Tiles 3 support

Tiles 3 support in IntelliJ IDEA includes code completion, and syntax and error highlighting for:

  • Tiles definition files
  • Expression languages (EL): Unified EL and Object-Graph Navigation Language (OGNL)
  • Tiles - JSP support tag library
Last modified: 5 September 2016