IntelliJ IDEA 2016.3 Help

Installing Gems for Testing

This feature is supported in the Ultimate edition only.

Using the supported testing frameworks requires the respective gems to be installed and activated in your project. Without the required gems, the corresponding context menu commands and code completion will not be available.

Prerequisites

Before you start working with Ruby, make sure that Ruby plugin is installed and enabled. The plugin is not bundled with IntelliJ IDEA.

Also make sure that the following prerequisites are met:

  • Ruby SDK is downloaded and installed on your machine.
  • The required framework SDKs are downloaded and installed on your machine.

Refer to their respective download and installation pages for details:

Installing gems for testing

To install Ruby gems for testing, follow these steps:

  1. Open Project Structure dialog, and click the node Modules.
  2. Choose the desired Ruby module.
  3. In the Gems tab, view the list of installed gems.
    /help/img/idea/2016.3/ij_assigning_ruby_sdk_for_a_project.png

See Also

```
Last modified: 21 March 2017