IntelliJ IDEA 2017.3 Help

Ruby Gems Support

This feature is supported in the Ultimate edition only.

Many types of the Ruby projects make use of the Ruby gems.

The approach of IntelliJ IDEA to the gems depends on the presence of the bundler.

  • If a project uses the bundler, then all the required gems are taken according to the Gemfile.
  • If there is no bundler, IntelliJ IDEA scans all the project files for the calls to Ruby gems, and produces a set of the required gems.

    If for some reason you are not happy with the set of gems defined by IntelliJ IDEA, you can create a Gemfile yourself and specify the gems of your choice.

Last modified: 11 October 2017

See Also