IntelliJ IDEA 2017.2 Help

Configuring Available Ruby Interpreters

This feature is supported in the Ultimate edition only.

In this section:

Overview

The list of Ruby SDKs, available for the various projects, can include interpreters installed locally or remotely.

The available Ruby interpreters are defined as the global SDKs. The procedure described below supposes that the necessary Ruby interpreters are already installed on your computer.

Viewing the list of available interpreters

To view the list of available interpreters

  1. Do one of the following:
    • On the main menu, choose File | Project Structure
    • On the main toolbar, click /help/img/idea/2017.2/projectStructure.png
    • Press Ctrl+Shift+Alt+S
  2. Under Platform Settings, click the node SDKs:
    /help/img/idea/2017.2/ij_list_of_available_ruby_sdks.png

Configuring the list of available interpreters

To configure the available Ruby interpreters

  1. Open the Project Structure dialog (e.g. Ctrl+Shift+Alt+S).
  2. In the Project Structure dialog box, click SDKs node under the Platform Settings.
  3. Click /help/img/idea/2017.2/new.png, and then choose Ruby SDK from the Add New SDK pop-up menu.
    /help/img/idea/2017.2/ij_available_ruby_interpreters1.png
  4. From the Select Interpreter Path popup, select whether you want to add an interpreter from your local computer, or the one located remotely.

    The next step depends on the selected interpreter location. When an interpreter is added, it is included in the list of available interpreters.

  5. Repeat steps 1 - 4 to add more Ruby interpreters to the list.

Removing interpreters from the list

To remove an interpreter from the list of available interpreters

  1. In the list of available interpreters, select the one to be deleted.
  2. Click /help/img/idea/2017.2/delete.png.
Last modified: 11 October 2017

See Also