IntelliJ IDEA 2020.2 Help

Data editor

From the Database tool window (for any table within a DB data source):

  • the Data Editor button on the toolbar (if the toolbar is not currently hidden)

  • Open Editor from the context menu

  • F4

Overview

The data editor provides a user interface for working with table data. In the data editor, you can sort, filter, add, edit and remove the data as well as perform other, associated tasks.

For more information about operations with tables, columns, rows, and cells, see the following articles:

Data editor with tool windows
Data editor with tool windows

Toolbar controls, context menu commands for data cells and keyboard shortcuts

Most of the available functions are accessed by means of controls on the toolbar, context menu commands for the data cells, and associated keyboard shortcuts.

ItemShortcutDescription
First page, Previous page, Next page, Last page

Use navigation icons and corresponding commands for switching between pages that show the table data.

A number of rows that you see simultaneously on the Result tab are referred to as a result set page. If this number is less than the number of rows in the table, only a subset of all the rows is shown at a time. If all the rows are currently shown, navigation icons and the corresponding commands are inactive.

  • First page: jump to the first page of results.

  • Previous page: go to the previous page of results.

  • Next page: go to the next page of results.

  • Last page: jump to the last page of results.

To change the size of a result set page, open settings (Ctrl+Alt+S) and navigate to Tools | Database | Data Views. In the Limit page size to field, type a new size of a result set page. Alternatively, to disable the page size restriction, clear the Limit page size to checkbox.

Reload page Reload Page Ctrl+F5

Reload data for the table view to synchronize the data that you see in the editor with the contents of the database. Also, use the Reload Page button when you want to apply a new page size limit setting after its change.

Add New Row Add New Row Alt+Insert

Add a row to the table.

To save a new row, click Submit the Submit button.

For more information about working with rows, see Tables.

Delete Row Delete Row Ctrl+Y

Delete the selected row or rows.

To select rows, click numbers in the gutter. To select multiple rows, press Ctrl and click the necessary rows.

Transaction mode
Tx and Tx Isolation

Select the isolation level for database transactions and the way the transactions are committed.

  • Auto: the current transaction is committed automatically when you submit your local changes to the database server.

  • Manual: the changes submitted to the database server are accumulated in a transaction that can either be committed or rolled back.

the Submit button Submit Ctrl+Enter Submit local changes to the database server. See Submit changes to a database.
the Commit buttonCommitCommit the current transaction. See also, Tx and Tx Isolation.
the Rollback button Rollback Roll back changes.
Cancel Query Cancel Query Ctrl+F2 Terminate execution of the current query.
Compare with Compare With Compare the current table with the table in the Services tool window. For more information about comparing tables, see Compare table data.
Data Extractor
Data Extractor

Select an output format for your data.

Also, you can configure the following options:

  • Skip Computed Columns (SQL): do not include virtual columns that are not physically stored in the table (for example, the identity column).

  • Skip Generated Columns (SQL): for INSERT and UPDATE statements, do not include auto-increment fields when copying or saving data.

  • Add Table Definition (SQL): for INSERT and UPDATE statements, add the table definition when copying or saving data.

  • Configure CSV Formats: open the CSV Formats dialog where you can manage your delimiter-separated values formats (for example, CSV, TSV).

  • Go to Scripts Directory: open a directory with scripts that convert table data into different output formats.

Export Data Export Data Copy the table data to the clipboard or save to a file.
Export Data Export Data Use this command to save the table data in a file. In the dialog that opens, specify the location and name of the file.
the Export button Export to Database Export the data to another table, schema or database. Select the target schema (a new table will be created) or table (the data will be added to the selected table). In the dialog that opens, specify the data mapping info and the settings for the target table.
View Query Use this button to view the query which was used to generate the current table view. To close the pane where the query is shown, press Escape.
Show Options Menu

The Show Options Menu list includes the following options:

  • Show Geo Viewer: enable a graphic viewer to explore geospatial data in your database.

  • Sort via ORDER BY: sort data on a database level. The Sort via ORDER BY option is available only for tables in the data editor but not for table result sets in the Services tool window.

    If the Sort via ORDER BY option is on, data for the whole table is sorted according to the corresponding database system. In the Output tab, you can see all the corresponding sorting operations.

    Sort via ORDER BY is on

    Do not turn this option on if you want to keep interactions with the database to a minimum. For example, when the table is large or the database connection is slow.

    If this option is off, the data is sorted locally and only for the rows that are currently shown.

    Sort via ORDER BY is off
  • Row Filter: show or hide the filter box.

  • Reset View: restore the initial table view if you customized the table view before (for example, hid columns or sorted data).

  • Paste Format: select how you want to treat the text from the clipboard on paste.

  • View Query: view the query that generated the table.

  • Open Database Settings: open the Database section in settings. In the Database section, you can view or edit the settings for your database, Hibernate and JPA consoles, data editors, and the Database tool window.

Edit F2

Edit a value in the selected cell or cells. Alternatively, you can double-click the cell and start typing a value. The Edit command is unavailable for read-only values. For read-only values, use the View command.

  • To open the auto-completion list, press Ctrl+Space.

  • To enter the modified value, press Enter.

  • To cancel editing, press Escape.

For more information about editing cells, see Cells.

Edit MaximizedF2

Expand the selected cell to edit a value in the cell.

In a maximized cell, press Enter to start a new line. To enter the value, press Ctrl+Enter. To restore an initial value and quit the editing mode, press Escape.

For more information about editing cells, see Cells.

Set DEFAULTCtrl+Alt+DSet the default value or values that you specified for the column. To view the default column value, right-click a table in the Database tool window (View | Tool Windows | Database) and select Modify Table. Double-click the column entry and see the value in the Default field.
Set NULLCtrl+Alt+NReplace the value or values with NULL. To ensure that the column accepts NULL values, right-click a table in the Database tool window (View | Tool Windows | Database) and select Modify Table. Double-click the column entry and see if the Not null checkbox is cleared.
Load FileLoad a file into the field.
RevertCtrl+Z Revert changes within the selection. For more information about reverting changes, see Submit changes to a database.
Clone RowCtrl+DCreate a copy of the selected row.
Quick DocumentationCtrl+Q Open the quick documentation view. To close the view, press Escape. For more information about quick documentation, see Using the quick documentation view.
View as | Transpose

Toggle the transposed table view. In the transposed view, the rows and columns are interchanged.

To make this mode a default for tables and views, open settings by pressing Ctrl+Alt+S and navigate to Tools | Database | Data Views and select the Transpose tables and views. When this option is enabled, query results are not transposed.

Go To | Row Ctrl+G Jump to a specified row. In the Go to Row dialog, specify the column and row number (use the column:row pattern).
Go To | Related Data F4

Jump to a related record. The command options are a combination of those for Go To | Referenced Data and Go To | Referencing Data. Read more about related data in Navigate between related data.

The command is not available if there are no related records.

Go To | Referenced Data Ctrl+B

Switch to a record that the current record references. If more than one record is referenced, select the target record in the popup that appears. Read more about related data in Navigate between related data.

The command is not available if there are no referenced records.

Go To | Referencing Data Alt+F7

Use this command or shortcut to see the records that reference the current record. Read more about related data in Navigate between related data. In the popup that appears there are two categories for the target records:

  • First Referencing Row: all the rows in the corresponding table are shown, and the first of the rows that references the current row is selected.

  • All Referencing Rows: only the rows that reference the current row are shown.

The command is not available if there are no records that reference the current one.

Filter by Use this command to access quick filtering options. The options include those for the current column name and depend on the value in the current cell.
CopyCtrl+C Copy the selection to the clipboard.
PasteCtrl+V Paste the contents of the clipboard into the table.
Save LOB Save a binary large object (LOB) currently selected in the table in a file.
Alt+J, Alt+Shift+J, Ctrl+W See Tables.
Last modified: 03 September 2020