AppCode 2018.1 Help

Installing, Updating and Uninstalling Repository Plugins

To be able to use repository plugins, you have to download and install such plugins first. After that, you get the ability to update these plugins when appropriate.

When a repository plugin becomes unnecessary, you can disable or uninstall it.

To download and install a repository plugin

Note that the plugin you have installed is automatically enabled. When necessary, you can disable it as described inEnabling and Disabling Plugins.

  1. Press ⌘, or choose AppCode | Preferences from the main menu, and then go to Plugins.
  2. Click the Install JetBrains plugin or the Browse repositories button.
  3. In the dialog that opens (the Browse Repositories dialog), right-click the required plugin and select Download and Install.

    Note that when looking for the plugin of interest, you can filter the plugin list and also to perform a search.

  4. Confirm your intention to download and install the selected plugin.
  5. Click Close.
  6. Click OK in the Preferences dialog and restart AppCode for the changes to take effect.

To update a repository plugin

  1. Press ⌘, or choose AppCode | Preferences from the main menu, and then go to Plugins.
  2. Right-click any of the plugins and select Reload List of Plugins.

    The names of repository plugins that have newer versions available are shown blue.

  3. Right-click the necessary plugin and select Update Plugin.
  4. Click OK in the Preferences dialog and restart AppCode for the changes to take effect.

To uninstall a repository plugin

  1. Press ⌘, or choose AppCode | Preferences from the main menu, and then go to Plugins.
  2. Right-click the repository plugin to be uninstalled and select Uninstall.
  3. Confirm your intention to uninstall the selected plugin.
  4. Click OK in the Preferences dialog and restart AppCode for the changes to take effect.
Last modified: 29 March 2018

See Also