AppCode 2020.3 Help

Supported Node.js versions

This page lists all Node.js versions supported by AppCode for developing applications. Please find the Node.js release schedule with the information about the status of the release on the Node.js official website.

The following Node.js versions are supported in AppCode 2020.3:

  • Node.js 10

  • Node.js 12

  • Node.js 14

  • Node.js 15

The active Long Term Service (LTS) version of Node.js is used for on-going testing of existing and upcoming product features.

For other supported Node.js versions, we guarantee that any regressions found in the current AppCode version related to the Node.js support or tool integrations that use Node.js (e.g. test runners or linters) will be fixed in the following bug-fix updates or next IDE major update.

We can't guarantee that all AppCode features will work as expected with Node.js versions that have reached their end-of-life. If any regressions or bugs associated with these Node.js versions are identified in the current AppCode version, they will not be fixed.

Last modified: 20 January 2021