PhpStorm 2016.3 Help

Yeoman

File | Settings | Languages and Frameworks | JavaScript | Yeoman for Windows and Linux
PhpStorm | Preferences | Languages and Frameworks | JavaScript | Yeoman for OS X
Ctrl+Alt+S
/help/img/idea/2016.3/settings.png


The page is available only when the Yeoman and the NodeJS plugins are installed and enabled. The plugins are not bundled with PhpStorm, but they can be installed from the JetBrains plugin repository as described in Installing, Updating and Uninstalling Repository Plugins and Enabling and Disabling Plugins. Once enabled, the plugins are available at the IDE level, that is, you can use it in all your PhpStorm projects.

On this page, specify the location of the Node.js executable file and the Yeoman project generator package installed through Node Package Manager.

ItemDescription
Node interpreter Specify here the location of the Node.js executable. Type the path manually, or choose it from the drop-down list if it was previously used, or click the Browse button /help/img/idea/2016.3/browseButton.png and choose the location in the dialog box that opens. See Node.js for details.
Yeoman yo package In this field, specify the location of the global yo package, see Installing and Removing External Software Using Node Package Manager, section Installing an External Tool Globally.

See Also

Last modified: 1 December 2016