PhpStorm 2019.3 Help

Supported PHP Versions

With PhpStorm, you can develop applications in PHP 5.3, PHP 5.4, PHP 5.5, PHP 5.6, PHP 7, PHP 7.1, PHP 7.2, PHP 7.3, and PHP 7.4. This topic outlines the coding assistance features available for each language version. You can set the language level for your project on the Languages & Frameworks | PHP page of the Settings/Preferences dialog Ctrl+Alt+S.

No correlation between the PHP version used in the project and the language level is enforced. Although the language version of each interpreter is detected automatically, you can still tell PhpStorm to provide you with coding assistance that corresponds to a different language level. However, if you attempt to use a code construct that is not supported by the specified language level, PhpStorm suggests a Switch to PHP <version> quick-fix.

Last modified: 27 March 2020