PyCharm Edu 3.5 Help

Project Interpreter

File | Settings | Project Interpreter for Windows and Linux
PyCharm Edu | Preferences | Project Interpreter for macOS
Ctrl+Alt+S
/help/img/idea/2017.1/settings.png


Use this page to select a Python interpreter for each of the projects opened in the same window.

In this section:

Interpreters

ItemDescription
Project InterpreterFor the project, selected in the Projects pane, choose Python interpreter from the drop-down list.

The interpreters in the list are configured using the /help/img/idea/2017.1/cogwheel_framed.png button, as described in the section Configuring Available Python Interpreters.

/help/img/idea/2017.1/cogwheel_framed.pngClick this button to reveal the list of available types of interpreters:
/help/img/idea/2017.1/py_interpreter_types.png

From the list, choose the one to be added:

Packages

This table shows the packages installed locally.

ItemDescription
PackageThis column shows the list of packages residing in the accessible remote repositories. For each package you can view its name and repository. Additional information is displayed at the tooltip.
VersionThis column shows the currently installed version of a package.
LatestThis column shows the latest available versions of the packages. If a version is outdated and the package can be upgraded, /help/img/idea/2017.1/arrow_right.png mark appears in this column.

Packages toolbar

ItemTooltip and shortcutDescription
/help/img/idea/2017.1/new.pngInstall
Alt+Insert
Click this button to install a new package from the accessible remote repositories.
/help/img/idea/2017.1/delete.pngUninstall
Alt+Delete
Click this button to uninstall the selected local package.
/help/img/idea/2017.1/arrowUp.pngUpgradeClick this button to install the latest available version of a package. This button is only available for the outdated package versions.

See Also

Last modified: 31 July 2017