PyCharm Edu 2018.2 Help

Supported Languages

Supported languages

Development of a modern application involves using multiple languages, that is why PyCharm Edu is an IDE for polyglot programming. With the deep understanding of all the subtleties of the source code structure and syntax, PyCharm Edu extends its support to:

  • Python
    • Python should be downloaded and installed on your computer.
    • PyCharm Edu supports the following versions of Python:

      • Python 2: versions 2.6 and 2.7
      • Python 3: from the version 3.4 up to the version 3.7 (since PyCharm Edu 2018.1)
  • Markup languages and Style Sheets:

Coding assistance

Coding assistance in PyCharm Edu includes:

Last modified: 9 August 2018

See Also