PyCharm 2021.2 Help

View data

When you double-click a table in the Database tool window (View | Tool Windows | Database), the table opens in the data editor. You can browse and edit table data in three modes: Table, Tree, Text, and Transpose. To switch between these modes, click the View as button (the View as button) and select the mode that you need.

  • Table: the default viewing mode of table data. Data in a table is stored in a cell that is an intersection of a vertical column and horizontal row.

    The table viewing mode

  • Tree: viewing mode in which data is displayed in the key-value table with the possibility to expand the key cell if it contains children nodes. Data from the expanded children node is distributed between key and value columns. You might consider using this mode to work with JSON and array data.

    The tree viewing mode

  • Text: viewing mode in which data is displayed as a text.

    The transposed table viewing mode

  • Transpose: viewing mode in which rows and columns are interchanged. You can combine this checkbox with other viewing modes.

    To make this mode a default for tables and views, open settings by pressing Ctrl+Alt+S and navigate to Tools | Database | Data Views and select the Automatically transpose tables. When this option is enabled, query results are not transposed.

    The transposed table viewing mode

View table data

  1. Open the Database tool window (View | Tool Windows | Database).

  2. In the database tree, navigate to the table that you want to open.

  3. Double-click the table.

Transpose a table

You can rotate the table data from rows to columns and from columns to rows. In the transposed view, the rows and columns are interchanged. You can combine the transpose action with other viewing modes.

  • To transpose a table, click the View as button (the View as button) and select Transpose.

    The transposed table viewing mode

View the query that generated the result set

  • To see the query that was used to generate the result table, click the Show Options Menu icon (the Show Options Menu icon) and select View Query. If necessary, you can select the query text and copy it to the clipboard by pressing Ctrl+C.

    To close the pane where the query is shown, press Escape.

    View the query that generated the table

Preview DML

  • When you insert, delete, or modify data in a table editor, you can preview the query that PyCharm uses to perform selected operations. To preview the query, click the Preview pending changes button (the Preview pending changes button) on the toolbar.

Reload data for the table view

You need to reload data for the table view if you want to synchronize the data that you see in the editor with the contents of the database. Or, when you want to apply the page size limit setting after its change.

  • Click the Reload Page icon The Reload All from Disk button on the toolbar.

  • Right-click the table and select Reload Page from the context menu.

  • Press Ctrl+F5.

Using Geo viewer for geographical data in PostgreSQL

The Geo viewer is a graphic viewer that you can use to explore geospatial data in your database. The Geo viewer opens in the Services tool window. You can click rows to navigate to the corresponding area on the map or click a pin on the map to navigate to the corresponding row.

To detach the Geo viewer tab from the Services tool window, drag it from the Services tool window.

Currently, PyCharm supports coordinates in the following formats: WKT, WKB, and PostGIS geometry 4326.

View geographical data with the Geo viewer

  1. In the Database tool window (View | Tool Windows | Database), double-click the table with geographical data.

  2. Click the Show Options Menu icon (Show Options Menu icon) and select Show Geo Viewer.

  3. Read the notification about possible risks of enabling JCEF. If you accept the risk, click Enable JCEF.

  4. In the Restart Required window, click Restart Now.

  5. After the restart, press Ctrl+F5 or reopen the table with geographical data.

  6. Click the Show Options Menu icon (Show Options Menu icon) and select Show Geo Viewer.

  7. View geographical data with the Geo viewer

Recover PyCharm after enabling JCEF

  1. Navigate to the config directory.

    Syntax
    %HOMEPATH%\.<product><version>\config\projects
    Example
    C:\Users\JohnS\.PyCharm2021.2\config\projects
    Syntax
    ~/Library/Application Support/<product><version>
    Example
    ~/Library/Application Support/PyCharm2021.2
    Syntax
    ~/.<product><version>/config/plugins
    Example
    ~/.PyCharm2021.2/config/plugins
  2. In the options directory, open ide.general.xml in a text editor.

  3. Remove the following line: <entry key="ide.browser.jcef.enabled" value="true" />

Last modified: 27 May 2021