RubyMine 2016.3 Help

CoffeeScript Support

In this section:

Overview

RubyMine provides CoffeeScript support. RubyMine recognizes *.coffee files, and allows you to edit them providing full range of coding assistance without any additional steps from your side. CoffeeScript files are marked with /help/img/idea/2016.3/icon_CoffeeScript.png icon.

To run, debug, and test your code, you will need it translated into JavaScript which requires a transpiler and Node.js. For more details on CoffeeScript transpilation, see Transpiling CoffeeScript to JavaScript.

Preparing for CoffeeScript development

  1. Make sure the CoffeeScript and Node.js plugins are installed and enabled. The plugins are not bundled with RubyMine, but they can be installed from the JetBrains plugin repository as described in Installing, Updating and Uninstalling Repository Plugins and Enabling and Disabling Plugins. Once enabled, the plugins are available at the IDE level, that is, you can use them in all your RubyMine projects.
  2. Download and install the Node.js runtime environment.
  3. Configure the Node.js interpreter in RubyMine:
    1. Open the Settings / Preferences Dialog by choosing File | Settings for Windows and Linux or RubyMine | Preferences for OS X, and click Node.js and NPM under Languages&Frameworks.
    2. On the Node.js and NPM page that opens, specify the location of the desired Node.js interpreter.
    See Configuring Node.js Interpreters for details.

Coding assistance

CoffeeScript support includes:

See Also

```

Language and Framework-Specific Guidelines:

Last modified: 22 March 2017