RubyMine 2023.3 Help

Supported Node.js versions

This page lists all Node.js versions supported by RubyMine for developing applications. Find the Node.js release schedule with the information about the status of the release on the Node.js official website.

The following Node.js versions are supported in RubyMine 2023.3 and later:

  • Node.js 14

  • Node.js 16 - the Active Long Term Supported (LTS) version

  • Node.js 18 - the current version

The active Long Term Service (LTS) version of Node.js is used for ongoing testing of existing and upcoming product features.

For other supported Node.js versions, we guarantee that any regressions found in the current RubyMine version related to the Node.js support or tool integrations that use Node.js (for example test runners or linters) will be fixed in the following bugfix updates or next IDE major update.

We can't guarantee that all RubyMine features will work as expected with Node.js versions that have reached their end-of-life. If any regressions or bugs associated with these Node.js versions are identified in the current RubyMine version, they will not be fixed.

Last modified: 11 October 2023