Upsource 2018.1 Help

Error: "Can't obtain updateLastError method for class com.sun.jna.Native"

The error occurs during the Upsource installation process, on the Cassandra database startup:

cassandra error

Cassandra throws the following exception while starting:

java.lang.UnsatisfiedLinkError: Can't obtain updateLastError method for class com.sun.jna.Native

Solution

Disable JNA before starting Upsource — run the following command:

<upsource_home>/apps/cassandra/bin/cassandra.bat configure -J-Djna.nosys=true
Last modified: 2 November 2018