WebStorm 10.0.0 Help

Managing Dart Packages and Assets

WebStorm provides dedicated interface for using the Pub tool. Alternatively, you can use the tool in the command line mode from the embedded local terminal. The pub tool is intended for installing, uninstalling, and upgrading Dart packages and assets for your project and for building Dart applications.

The pub tool is included in the Dart SDK, so when you download the SDK separately or within the art Editor Bundle, you automatically get the pub tool. For details, see Preparing for Dart Development and Dart Download Page.

On this page:

Basics

The pub tool saves the downloaded packages in caches, creates a packages folder next to the pubspec.yaml file. In the web folder, the pub tool creates a copy of the packages folder. As soon as a subfolder if created under the web folder, a copy of the packages folder is created in the new subfolder.

All the copies of the packages folder are automatically excluded from the project, that is, they are neither indexed nor shown in the project tree. To make the excluded copies visible, remove them from the exclusion list on the Directories page as described in Configuring Folders Within a Content Root.

Downloading and Upgrading Dart Dependencies

Last modified: 31 March 2015
comments powered by Disqus