Rails 4 Running Only with Ruby 1.9+


Rails 4 couldn’t be run with Ruby 1.8


Rails 4 running only with Ruby 1.9+

New Rails 4 Folders and Commands


New Rails4 project structure


New Rails4 generators

Rails 4 New and Deprecated Syntax


New Scope syntax


Deprecated syntax