GoLand 2026.3 Help

高级设置中的控件说明

除了您经常使用的标准设置外,GoLand 还提供了多种高级选项,您可以用来微调特定产品功能的行为。

由于高级设置包含不同部分,可以使用搜索字段快速导航到感兴趣的部分或所需选项。 您还可以搜索注册表键,因为某些高级选项有对应的注册表键。

Angular

项目

描述

在编辑器中显示导航弹出窗口

选中此复选框后,GoLand 会显示一个导航弹窗,帮助快速在 Angular 组件内的文件之间跳转,定位到同一文件内的样式和模板,或打开相关文件列表弹窗。

外观

项目

描述

启用 Islands UI 以使用自定义主题

为安装自 JetBrains Marketplace 的 自定义 UI 主题启用 Islands UI 元素,如圆角和分区分隔。 默认情况下,Islands UI 只应用于 内置 Islands 主题。

书签

项目

描述

仅在弹出窗口中显示行书签

默认情况下,GoLand 只在书签弹出窗口中显示行书签(Shift+F11 或 编辑 | 书签 | 显示行书签…)。 如果您希望在弹出窗中看到其他书签项目,例如文件或文件夹,请禁用此选项。 如需更多信息,请参阅 书签。

分支切换时恢复书签上下文

默认情况下,GoLand 会为每个 VCS 分支维护独立的书签上下文。 切换分支时会恢复该分支设置的书签。 禁用此选项后,尽可能在分支切换时保留书签。 欲了解更多信息,请参阅 切换分支时保留书签。

构建工具。 Gradle

项目

描述

使用 Gradle 运行

此选项默认情况下会被选中。 构建和运行操作将由 Gradle 执行。 清除此选项后,GoLand 将构建并运行你的项目。

下载源代码

默认情况下,GoLand 在初始项目同步时不会下载项目依赖项的源代码。

选择此选项以更改项目的行为,并在导入过程中始终下载依赖项的来源。

附加脚本依赖项源

此选项可在 Gradle 项目导入期间为你的构建脚本依赖项(即 build.gradle 文件 buildscript { dependencies { ... } } 块中声明的类路径项)附加源码 JAR 包。

启用此选项后,IDE 会为构建脚本本身使用的插件和库下载并附加源码工件——不是项目的运行时/编译依赖项,而是你的构建脚本所依赖的 Gradle 插件和工具。 这样你就可以在 IDE 内部导航到它们的源代码。 启用此选项后需要进行项目同步,才能附加源码。

代码补全

项目

描述

启用输入时自动补全

在输入时自动显示补全建议。 如果禁用,只有在按下 Alt+Shift+\ 时才会显示建议。

代码审查工具

项目

描述

代码审查的一体化差异

选择此选项可在代码审查中以单个可滚动差异视图处理所有更改的文件。

保持 Diff 线程的增加裕度

取消选择此选项可减少代码审查中注释周围的水平间距。

容器环境:WSL、Docker

项目

描述

获取环境变量的 Shell 模式

使用此选项可控制 IDE 如何启动 shell 以读取容器与远程环境(如 WSL 和 Docker)的环境变量。 可以选择 shell 是以交互式模式(默认)还是非交互式模式启动。 这将决定执行哪些 shell 启动文件,并因此决定哪些环境变量可供 IDE 使用。

数据库

项目

描述

重置架构内省级别以上对象的详细信息

丢弃超出架构当前内省级别的缓存对象详细信息。 此级别决定 GoLand 加载多少有关数据库结构的信息。

此选项可在不更改数据库中对象的情况下减少内存使用情况。 默认情况下已启用。

如果由脚本加载器检测到,则以表格形式打开文件

对于 scripted data loaders 支持的文件格式。 定义 GoLand 在表格视图中打开的文件。

  • 全部 :所有支持的表格数据文件。

  • 表格优先格式 :表示表格格式数据的文件格式。 目前,除 JSON 之外支持所有表格数据文件格式。

  • 无 :禁用所有文件的视图。

在“Search Everywhere”中显示“数据库”选项卡

启用 数据库 选项卡在 Search Everywhere 中(双击 Shift)。

有关“随处搜索”功能的更多信息,请参阅 全局搜索。

调试器

项目

描述

最近表达式的最大数量

要保存到 计算表达式 历史记录中的表达式数量。

显示内联运行到光标处弹窗

控制在调试模式下当您将鼠标悬停在一行上时是否显示 运行至光标 图标 运行到光标处。 点击此图标将继续执行,直到到达相应的行。

在文本光标变化时在浏览器中高亮显示当前元素

使用此复选框设置调试会话期间浏览器中的高亮显示。

  • 默认情况下,复选框为选中状态,当文本光标移动到编辑器中相应的代码段时,浏览器中会高亮显示元素。

  • 取消选中复选框后,按住 Shift 并在编辑器中将鼠标悬停于元素上即可在浏览器中高亮显示该元素。

开发容器

项目

描述

以原生方式打开开发容器项目

使用此选项可启动开发容器,并像打开本地项目一样在其中打开项目。 不会打开其他窗口。

请注意以下几点:

  • 在早于 2025.3 的 GoLand 版本中不支持此功能。

  • 开发容器仅支持 Docker 。

  • 此选项不支持为远程项目启动开发容器。

欲了解更多信息,请参阅 以原生方式使用 Dev Container 打开项目。

使用 --depth=1 克隆源代码

使用此选项通过检出最新版本的源代码来加速您的项目克隆过程。 如需更多信息,请参阅 Git 文档。

自动选择后端版本

选择此选项后,将自动选择最新版本的 IDE 。

如果开发容器后端/前端的部署耗时超过 10 秒,则显示通知

选择此选项后, IDE 会显示通知。

重建 Docker Compose 开发容器时使用 '--no-recreate'。 Main 服务将始终被重新创建。

选择此选项后,即使您使用 --no-recreate 选项以避免重建未更改的容器,也会重新创建主开发容器。

Docker

项目

描述

重启时自动连接 Docker

GoLand 启动后 连接到已配置的 Docker daemon。

镜像注册表实体加载限制

出于性能原因,默认情况下,GoLand 仅显示 Docker registry 中的前 100 张图片。 如果您需要列出更多,请增加此数字。 这也会增加内存使用量。

日志标签页应该是 Docker 容器的第一个标签页。

将 日志 选项卡显示为 容器概览窗格 中的第一个选项卡。

用于自动重新连接的定期 Docker 状态检查之间的延迟

GoLand 应该多久检查一次与 Docker 的连接状态(以毫秒为单位)。

在 SELinux 系统中对几乎所有绑定卷应用 :z 挂载选项

在 SELinux 工作站上添加 :z 配置标志到 Docker 绑定挂载以 将卷连接到 Docker 容器。

文档组件

启用文档组件中代码元素的高亮显示(快速文档 弹出窗口 和 工具窗口)。

项目

描述

行内代码的基本语法高亮显示

选择如何在文档中显示内联代码: 无高亮显示、 作为纯代码 或 高亮显示关键字。

多行代码块的基本语法高亮显示

在所有文档组件的多行代码块中高亮显示关键字、数字和字符串。

代码元素链接的语法高亮显示

代码元素中的所有链接都将使用与该元素(类型、函数、方法或字段)在编辑器配色方案中所选颜色对应的颜色完全高亮显示。

为内联和多行代码块添加背景

为快速文档中的代码添加背景色,以将其与周围文本区分开来。 此选项默认已启用。

对于内联代码,请选择除 无高亮显示 之外的高亮显示模式以显示背景。

在模式对话框中的代码补全期间自动显示 QuickDoc

在重构对话框等模态对话框中进行代码补全时,自动显示快速文档。 此选项默认处于禁用状态。

编辑器

请使用本部分来配置在 编辑器 中工作的其他选项。

项目

描述

使用撤消透明文本光标移动

选择此选项可以像常规文本编辑器一样立即撤销上一次编辑。

在无选区时调用复制或剪切操作时,不复制/剪切当前行

此选项允许您覆盖在编辑器中未选择任何内容时复制 默认行为或剪切 Ctrl+C 当前整行的 Ctrl+X 默认行为。

在未选择内容的情况下调用复制操作后,不选择已复制的行

默认情况下,如果您在不选择任何内容的情况下使用 Ctrl+C ,整行内容将被复制。 通过此操作,您可以避免该选择。

粘贴未选择内容时复制的行

您可以更改默认的 粘贴到插入符号行上方 行为,并选择 粘贴到插入点行 ,该行为恢复旧版的复制/粘贴行为,或者选择 如果粘贴到中间行则进行修剪 ,此行为将在中间粘贴时移除复制行前后的不必要空格。

使用其 Unicode 名称缩写渲染特殊字符,例如控制码。

选中此选项后,您可以使用 Unicode 名称缩写表示特殊字符,例如控制代码。

显示缩放指示器

使用此选项在编辑器中 放大或缩小代码时,查看显示当前字体大小的指示器,并提供将其恢复为默认值的选项。

Tab 字符渲染

您可以选择以下选项之一:

  • 水平线

  • > 符号

  • 长箭头

专注免费模式下的左边距

此选项允许您在 无干扰和禅模式中调整左侧编辑器边距。

默认情况下,这些查看模式下编辑器文本垂直居中,文本列宽与 在以下位置硬包装 选项在 编辑器|代码风格 设置页面上的设置相对应 Ctrl+Alt+S。 这意味着如果您的代码在 正确格式化时会居中,但如果有长的未换行行,文本可能会在左侧有大空白的情况下超出视口。 在这种情况下,您可能希望使用此选项减少左边距。

行号的字体增量

使用此选项可以更改左侧边栏中行号的字体大小,使其与编辑器中的字体大小进行比较。

对长度超过 n 个字符的行强制进行软换行

默认数量是 100000。 将此数字增加可能会对编辑器性能产生负面影响。

使用“扩展选择”选择空白字符

使用此选项在调用 扩展选择 操作时包含空格。

使用行注释操作后向下移动文本光标

此选项允许您配置是否在 对行使用行注释注释行 Ctrl+/ 时将文本光标移动到下一行。 请注意,如果编辑器中有选择内容,无论此选项如何,文本光标都不会移动。

隐藏用于代码编辑的浮动式工具栏

隐藏编辑器中提供代码编辑操作的浮动工具栏。

编辑器选项卡页

除了 GoLand 在编辑器中 使用选项卡时提供的标准 编辑器标签选项外,本节还包含一些作为内部注册表操作提供的额外选项。

项目

描述

导航到文件时,首选在停用拆分窗格中选择现有标签页

当您导航到一个已经在非活动拆分中打开的文件时,请使用此选项以在该拆分窗格中激活现有文件,而不是在活动拆分中打开文件的新副本。

在同一个标签页中打开声明源

当您导航到方法、类或变量时,包含其声明的源文件将在没有更改的情况下替换当前选项卡。

在主 IDE 窗口中打开从分离窗口调用的声明源

当您从独立窗口导航到方法、类或变量时,GoLand 将在主编辑器中打开包含声明的源文件。

通过双击编辑器标签页执行“隐藏所有工具窗口”/“还原窗口”

启用此选项后,您可以双击编辑器标签以 隐藏和恢复所有工具窗口。 或者,您可以通过按下 Ctrl+Shift+F12 或从主菜单中选择 窗口 | 活动工具窗口 | 隐藏所有窗口/还原窗口 来完成此操作。

通过双击编辑器标签页执行“最大化编辑器”/“标准化拆分”

当此选项启用时,您可以双击 split editor tab groups 中的标签页,以更改标签组的相对大小:第一次双击会将该标签页及其组扩展到最大,并将所有其他组缩小到最小宽度/高度;第二次双击会为每个标签组分配相同的宽度和高度。

或者,您可以从主菜单中选择 窗口 | 编辑器标签 | 最大化编辑器/恢复拆分 或从 查找操作弹出窗口中选择这些操作 Ctrl+Shift+A。

此选项可以与 通过双击编辑器标签页执行“隐藏所有工具窗口”/“还原窗口” 一起使用,但请准备好每次双击文件标签时在 IDE 布局中进行多次更改。

在嵌套拆分中均衡比例

使用此选项以使编辑器中多个水平或垂直拆分的大小均匀。

将固定的标签页保持在左侧

始终将 pinned tabs移动到编辑器选项卡栏的左侧。 否则,不固定标签页的位置未定义,您可以根据需要在标签栏上移动它们。

查找 / 替换

使用本节配置额外选项以便与 在项目中查找和替换目标 一起使用。

项目

描述

在“查找用法”视图中启用相似用法聚类

GoLand 分析搜索结果,检测最常见的使用模式,并根据其结构相似性将所有找到的用法分类到不同的组中。 这些使用集群出现在 预览 选项卡中。

欲了解更多信息,请参阅 在项目中搜索用法。

在 Find in Files/Show Usages 预览中显示的最大结果数

默认的结果最大数量是 100。 增加此限制可能会显著增加内存使用量。

显示“找到的结果过多”警告的上限

默认限制为 1000 个结果。

网关 WSL

项目

描述

将 WSL 项目作为本地项目原生打开(无需使用远程开发功能)

使用此选项像打开本地项目一样打开 WSL 文件系统中的项目。 不会打开其他窗口。

GitHub

项目

描述

GitHub 主机别名

为 github.com 设置别名。

GitHub 操作

项目

描述

GitHub Actions 编写支持(需要重启 IDE)

启用 GitHub Actions 支持 ,以自动执行构建、测试和部署流水线。

前往

这些选项默认已启用。

项目

描述

建议最佳的区域 GOPROXY

当依赖项下载缓慢或被阻止时,显示一条通知,建议使用区域性 Go 模块代理。 只有在应用建议时,GoLand 才会更改 GOPROXY。

关闭通知将禁用此选项。 再次选中该复选框以允许更多建议。

优化 'go list' 性能

并发运行 go list 以收集多个 Go 模块的依赖项信息。

如果并发运行导致资源占用率过高或发生错误,请清除此复选框以逐个处理模块。

同步 Go 主软件包的运行/调试配置

随着项目发生更改,自动为项目中的 main 软件包创建和更新运行/调试配置。

清除此复选框以手动管理 main 软件包的运行/调试配置。

IDE

使用此部分来配置存储您的项目中不同实体的额外选项。

项目

描述

最近项目的最大数量

使用此选项更改默认存储的最近项目数量,这是 50。

最近文件的最大数量

使用此选项更改默认存储的 最近文件数量,默认为 50。

最近位置的最大数量

使用此选项更改存储的默认数量的 最近位置 ,该数量为 25。

在本地历史记录中存储更改的持续时间

使用此选项来指定您希望保留在 本地历史记录中更改的天数。

JavaScript 和 TypeScript

项目

描述

语义高亮显示准确性

使用此字段可设置你希望通过高亮显示指出语义差异的详细程度。 可用选项包括: 高、 正常 (默认)、 基本 和 有限。

请注意,选择更高的精度等级可能会导致更高的 CPU 用法,从而影响性能。

高级 JavaScript 注解器

选中此复选框后,GoLand 将在 JavaScript 和 JSX 代码中执行更深层次的 JavaScript 专用语义分析。

高亮显示 JSX 客户端组件

选中此复选框后,GoLand 会对 JSX 服务器组件和 JSX 客户端组件应用不同的高亮显示样式。

高级 JSX 注解器

选中此复选框后,GoLand 会对 JSX 和 TSX 代码中的 JSX 标记进行更深层的语义分析。

当“在文件中查找”选择“目录”时,在库文件中搜索。

选中此复选框后,可在特定文件夹内搜索时包含库文件。

对于当前导入图之外的文件,回退到 IDE 类型评估器

选中此复选框后,将禁止评估项目 tsconfig.json 文件所确定的导入图之外文件的类型。

Kubernetes

项目

描述

如果没有可用集群,则显示空 Kubernetes 节点

如果选中,在没有可用集群的情况下,GoLand 会在 服务 工具窗口中显示 Kubernetes 节点。

要加载的 kubeconfig 文件的最大大小

指定 GoLand 尝试加载的 kubeconfig 文件的最大大小(以兆字节(MB)为单位)。

要加载的 CRD YAML 文件的最大大小

指定 GoLand 尝试加载的资源 YAML 文件的最大大小(以兆字节(MB)为单位)。

kubectl 集群操作的超时

指定 GoLand 等待 kubectl 集群操作完成的超时时间(单位:秒)。 如果操作耗时过长,将因延迟或无响应而被取消。

HTTP 请求的超时设置

指定 GoLand 等待发送到 Kubernetes 集群的 HTTP 请求完成的超时时间(单位:秒)。 如果请求耗时过长,将因延迟或无响应而被取消。

Markdown

项目

描述

隐藏浮动式工具栏

当您在 Markdown 文件中选择一些文本时,GoLand 会显示一个 浮动工具栏 ,其中包含各种格式选项。 如果您不想看到浮动工具栏,请选择此复选框,然后重新打开选项卡以应用更改。

在标题锚点中将多个破折号替换为一个

将章节标题中生成的锚点中的两个或更多破折号转换为一个。

Mermaid

项目

描述

附加代码隔离信息字符串正则表达式模式

指定一个正则表达式,用于识别 Markdown 中 Mermaid 代码块的其他语言标签。 输入一个与起始反引号后的整个标签匹配的模式。

例如, diagram-mermaid 会将具有该标签的代码块识别为 Mermaid 图表。 默认值为空,因此不会识别其他标签。

其他

项目

描述

HTTP 客户端请求日志中的最大请求数

指定在 http-requests-log.http 的请求历史中要存储多少个已执行的 HTTP 请求。

当存储的请求数量超过指定限制时,最早的请求及其关联的响应文件会被自动移除。

项目视图

请使用此部分配置额外选项以供在 项目工具窗口 中使用。

项目

描述

按输入键时将焦点移至编辑器

选中此选项后,您可以在 项目视图 中按 Enter 切换焦点到编辑器。

收起节点时,同时收起其下所有已展开的节点

当选择此选项时,GoLand 会折叠子节点以及父节点。

导航到库类时,请勿在项目树中选择它

即使启用了 项目 选项,也不要自动导航到 始终选择已打开的文件 工具窗口中的库文件。

您可以在工具窗口中手动导航到库文件:使用 选择已打开的文件 按钮,位于 项目 工具窗口工具栏,或按 Alt+F1 来打开 在…中选择 弹出窗口。

在项目视图中增大字体大小

如果您想更改 项目 视图中的字体大小,请选择此选项。 您需要重新启动 GoLand。

在项目视图中启用临时文件和控制台编辑器和控制台窗口显示功能。

在 IDE 级别的 项目 工具窗口中显示或隐藏 临时文件与控制台 节点。

该节点包含您的 scratch files 和 查询控制台。

要按项目隐藏该节点,请在 工具窗口设置中使用相应的选项。

Rails

项目

描述

自动加载生成器

默认启用,使用此选项自动加载 Rails 生成器。 禁用此选项时,您仍然可以手动触发操作。

Rake

项目

描述

自动加载任务

默认启用,使用此选项自动加载 Rake 任务。 禁用此选项时,您仍然可以手动触发操作。

运行/调试

项目

描述

临时配置数量限制

使用此选项可以更改默认存储的临时 run/debug configurations的数量,其默认值为 5。

终止进程时确认重新运行

当您对一个正在运行的进程调用 rerun 时,GoLand 会提示您确认终止现有进程并启动一个新进程的操作。 您可以通过取消选中此复选框来更改默认行为。

使配置默认固定

选择此选项可在您运行配置后自动固定在 运行 工具窗口中打开的选项卡。

新界面中最近运行配置的最大数量

指定将在 Run widget中显示的最近运行/调试配置的数量。

SSH

项目

描述

配置文件解析器

请选择解析器:

  • 遗留 :使用 legacy parser 处理 ~/.ssh/config。

  • OpenSSH :使用基于 ssh -G 的解析器。 您的计算机上必须安装 OpenSSH。

自定义 OpenSSH 工具路径

如果您已经选择了 OpenSSH 解析器,请指定 OpenSSH 的路径。

首选 SSH 会话后端

选择用于 SSH 连接的实现:

  • 遗留 :使用旧版 SSHJ 库。 这是默认选项。

  • OpenSSH: 使用系统 OpenSSH 客户端。

如果一个后端遇到连接问题,请尝试切换到另一个。

Search Everywhere

项目

描述

在“Search Everywhere”中显示文本搜索结果

在 Search Everywhere 中启用 文本搜索。 结果将显示在新的 文本 选项卡上,并在列表底部的 全部 选项卡上显示。

等待所有贡献者完成后再显示结果

等待所有搜索贡献者完成任务后再显示最终搜索结果。 此选项可固定搜索结果中某项目的位置,防止其在列表中跳动。 如果存在速度较慢的搜索贡献者,此选项可能会减慢 "Search Everywhere" 的操作速度。

在 贡献者等待超时(毫秒) 字段中,指定等待搜索贡献者完成其任务的时间长度。

在搜索结果上方显示通知

此选项默认已启用。 提示等信息通知会作为不可选择的灰色信息行显示在搜索结果中。 禁用该选项时, Search Everywhere 窗口只显示实际的搜索结果。

贡献者等待超时(毫秒)

搜索时,结果会以不同速度从多个来源返回。 为避免搜索结果列表频繁重排或闪烁,启用此选项会短暂延迟显示结果,以便可以收集并一起展示。 该值指定显示结果前的最大延迟(默认 2,000 ms 或 2 秒),即使部分较慢的来源还未完成。 如果主要来源较快返回足够的匹配项,则会立即显示结果。 仅当主要来源较慢时才适用超时。

在结果列表顶部显示最近的文件

启用此选项可先显示来自最近文件的结果,而不是按与查询匹配程度排序。

在“Search Everywhere”的“操作”标签页中启用拼写错误容错搜索支持。

当搜索 IDE 操作(Ctrl+Shift+A )并拼写其名称有误时,IDE 也能识别出正确的拼写并找到相应的操作。 例如,输入拼写错误的操作名称时,仍会返回正确的操作,而不是没有结果。

基于机器学习对“操作”选项卡中的结果进行排序

默认情况下, 操作 选项卡上的搜索结果是使用机器学习进行排序的,而不是标准的排名机制。

基于机器学习对“文件”选项卡中的结果进行排序

默认情况下, 个文件 选项卡上的搜索结果是使用机器学习进行排序的,而不是标准的排名机制。

基于机器学习对 Classes 标签页中的结果进行排序

默认情况下, 类 选项卡上的搜索结果是使用机器学习进行排序的,而不是标准的排名机制。

在 Go 代码中,此选项卡列出类型。

基于机器学习对“全部”选项卡中的结果进行排序

在 全部 选项卡上使用机器学习排序搜索结果,而不是标准排序机制。

在“操作”选项卡中启用语义搜索

请选择此选项,如果您希望 GoLand 在 操作 选项卡中使用语义搜索(一种分析搜索查询背后的意图和上下文含义的技术)以提供更相关的结果。

在“文件”选项卡中启用语义搜索

请选择此选项,如果您希望 GoLand 在 个文件 选项卡中使用语义搜索(一种分析搜索查询背后的意图和上下文含义的技术)以提供更相关的结果。

在“符号”选项卡中启用语义搜索

请选择此选项,如果您希望 GoLand 在 符号 选项卡中使用语义搜索(一种分析搜索查询背后的意图和上下文含义的技术)以提供更相关的结果。

在“类”选项卡中启用语义搜索

请选择此选项,如果您希望 GoLand 在 类 选项卡中使用语义搜索(一种分析搜索查询背后的意图和上下文含义的技术)以提供更相关的结果。

在查找、替换、重命名中搜索作用域

项目

描述

保留最后选择的搜索范围

选择此选项可快速查看搜索作用域的历史记录。

安全分析

项目

描述

显示“问题”标签页

使用此选项可显示 Java 或 Kotlin 安全代码分析输出。

启动

项目

描述

如果在项目首次启动时没有打开任何文件,打开 README.md 文件

如果您选择此选项,GoLand 会在您启动项目时打开一个 README.md 文件,如果没有任何已打开的文件。

建议的重构

项目

描述

在编辑器中显示建议的重构的提示

检测到重构时,在编辑器中显示内联提示。 禁用该选项时,重构仍可用,但不会显示提示。

终端

配置与使用 embedded terminal emulator相关的高级设置。

项目

描述

显示应用程序标题

显示在终端运行的应用程序设置的标题。

终端回滚缓存区大小

使用此选项可增大终端中的缓冲区大小。

提前输入

在终端中启用 typeahead,这在您预期打字延迟时对远程连接很有用。

提前输入延迟阈值

当终端延迟超过指定值(以毫秒为单位)时,开启 typeahead。

为备用屏缓冲区使用 1.0 行间距

使用备用屏幕缓冲区的终端应用程序可能有其自己的视觉风格。 此设置在终端的备用屏幕缓冲模式下保持使用 1.0 行间距。

包括行间距在内填充字符背景

如果替代屏幕缓冲模式中的行间距值超过 1.0,行之间可能会出现白色的水平间隙。 选中此复选框以填写这些空白。

终端字符编码

指定终端的编码。

新终端输出容量

为 重构终端指定缓冲区大小。

按下 Shift+Enter 时发送 Esc+CR

选择此选项后,按下 Shift Enter 时将向 shell 发送 Esc + 回车,而不是普通回车。

默认情况下,终端为 Enter 和 Shift Enter 发送相同的按键序列。 启用此选项后,按下 Shift Enter 时会在回车前发送一个额外的 Esc 字符。 这样命令行应用程序就可以区分并处理 Shift Enter ,例如在输入多行命令时插入新行。

在部署目录中启动 SSH 终端

选择此选项可在部署目录中启动新的 SSH 会话。

禁用后,SSH 会话将在默认远程目录(主目录或 SSH 配置中定义的路径)中启动。

Terraform

项目

描述

提前构建本地元数据

当相关文件发生更改时,重建本地提供程序元数据,而不是等到 IDE 需要它来提供编码辅助。

此选项默认处于禁用状态。 启用它可以提前准备元数据,但会增加额外的后台工作。

使用全局元数据

从用户级 Terraform 目录加载其他提供程序元数据:macOS 和 Linux 上的 ~/.terraform.d ,或 Windows 上由 APPDATA 环境变量指定的目录中的 terraform.d 子目录。

此选项默认处于禁用状态。

嵌入提示中显示的最大用法数

限制编辑器提示中为 Terraform 元素计数的用法数量。 默认限制为 50 时,如果用法超过 50 个,提示会显示 50+ 个用法 ,而不是精确计数。

有关其他 Terraform 选项的说明,请参阅 Terraform 高级设置。

测试索引任务

项目

描述

将测试索引显示为后台任务

您可以在进度条中像其他 进程 一样监控并暂停/取消测试索引。 此选项默认已启用。

在指定的超时时间(毫秒)后将测试索引显示为后台任务

此选项设置测试索引作为进程出现在进度条中的时间间隔。

工具窗口

项目

描述

始终显示工具窗口标题图标

默认情况下,工具窗口标题中的图标(例如, 隐藏 和 选项 )仅在您将鼠标悬停在工具窗口上或工具窗口获得焦点时显示。

启用此选项可始终显示工具窗口标题图标。

允许通过标题拖动工具窗口以移至另一位置

通过拖动标题移动工具窗口。

当此选项被禁用时,您可以通过拖动工具窗口条、使用 移动到 上下文菜单选项或位于 工具窗口选项菜单/选项 图标下的工具窗口设置来 移动工具窗口。

用户界面

项目

描述

在 Windows/macOS 上使用原生文件选择器对话框

在 Windows 和 macOS 上,IDE 将使用操作系统专用的文件选择对话框来打开文件和目录。

在 IDE 框架页眉显示文件类型图标

在 macOS 上,该图标可用于将文件拖动到其他应用程序。

为 macOS 键盘快捷键使用文字而非符号

如果您希望看到带有文字的快捷方式而不是符号,请选择此选项。

释放鼠标右键即可激活菜单项

启用此选项(默认)时,在某项上释放按钮会选择该项,在其他位置释放按钮会关闭菜单。 禁用该选项时,按住并释放的手势无任何作用,将以常规方式打开菜单并点击项目。

列表和树中的循环滚动

按下第一个元素时选择最后一个元素,反之亦然。

在对话框将鼠标光标定位于默认按钮上

当选择此选项时,鼠标指针将置于对话框中的默认按钮上(通常是 确定)。

禁用双修饰键快捷键

您可以禁用使用双键的快捷键。 例如, Shift 或 Ctrl。

在非模态对话框中显示设置

默认情况下,设置窗口是非模态的,这意味着设置窗口打开时仍可与 IDE 交互。

取消选中该选项可使设置窗口成为模态,并在其关闭前阻止与 IDE 交互。

使用简化的初始屏幕

简化的初始屏幕为标准创业公司图片提供了替代方案,最大程度减少鲜艳颜色或复杂图形等视觉触发器,为有光敏性或感官偏好需求的用户提供更友好的体验。

版本控制

项目

描述

作为编辑器标签页打开差异

选中此选项时,“差异查看器”将显示为编辑器选项卡。

一体化差异

选择此选项后,所有更改的文件都会显示在单个连续的差异视图中。

文件在编辑器中打开时从 VCS 加载注解

选择此选项时,GoLand 在您打开编辑器中的文件时加载注解。

高亮显示已忽略的文件

当选择此选项时,GoLand 将显示来自 VCS 的忽略文件列表并在编辑器中显示它们的状态。

启用提交工具窗口

当您选择此选项时,GoLand将在单独的工具窗口中显示 本地更改 和 搁置 标签。

切换提交控件

当选择此选项时,GoLand 会在执行提交后隐藏提交面板和复选框,并允许您在 提交更改 对话框中切换它们。

提交后自动关闭窗口/浮动模式下的提交工具窗口

当 提交 工具窗口处于 窗口或浮动模式时,此选项可用。 选择后,工具窗口会在更改提交后自动关闭。

为推送选择所有包含新提交的仓库

如果选择此选项,GoLand 将默认选择所有要推送的提交。

强制推送时不显示警告

此选项适用于未受保护分支上的强制推送操作。 选择后,GoLand 在强制推送前不会要求确认。

为 Git 和 Mercurial 使用模态提交界面

选择此选项可在单独的模态提交对话框中提交本地更改。

版本控制。 Git

项目

描述

递归克隆项目中的子模块

选择此选项后,在从 Git 检出时, git clone --recurse-submodules 被使用来克隆包含所有可用子模块的主存储库。

从 Git 读取时应用内容转换

当选择此选项时,GoLand 将在从 Git 读取文件内容时对 --filters 或 --textconv 标志使用 git cat-file 命令。

使用安全强制推送

选择此选项时,GoLand 在从 IDE 调用强制推送时使用 --force-with-lease 而不是仅使用 --force。

检查传入与传出提交

选中此选项后,GoLand 会在 VCS 微件中检查并指示分支名称旁的传入(蓝色箭头图标 传入提交指示器 )或传出(绿色箭头图标 传出提交指示器 )提交。

更新项目后自动打开"更新信息"标签页

执行 更新操作后, 更新信息 选项卡将在 Git 工具窗口 Alt+9 中打开。

不运行 Git 提交挂钩

选择此选项以在提交操作期间自动禁用运行提交钩子。

分支名称清理符号

指定一个符号以自动替换 Git 分支名称中的空格和其他受限字符(默认: -)。

在最近项目列表中显示分支名称

默认情况下,项目中已检出分支的名称会显示在欢迎界面以及主菜单的最近项目列表中。 您可以禁用此设置,或仅为 同名项目 切换此设置。

在"随处搜索"中显示 Git 标签页

选择此选项可将 Git 选项卡添加到 全局搜索窗口。

欢迎屏幕

项目

描述

以非模态模式显示“欢迎”屏幕

在非模态窗口中显示欢迎屏幕。 清除此复选框以改用经典欢迎屏幕。 此选项默认已启用。

2026年 11月 9日