# 无法连接到 MySQL 5.1

> For the complete documentation index, see [llms.txt](https://www.jetbrains.com/zh-cn/help/idea/llms.txt).

Procedure:

要连接到数据库，请创建一个数据源以存储您的连接详细信息。

1. 选择您要创建的数据源。 您可以通过以下方式执行此操作：

* 在主菜单中，前往 `文件 | 新建 | 数据源` 并选择 MySQL 。

* 在 数据库 工具窗口中，点击工具栏上的 ![新建图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.add.svg) 新建 。 导航到 数据源 并选择 MySQL 。

![创建一个新的数据源](https://resources.jetbrains.com/help/img/idea/2026.3/create_new_data_source.png)

2. 点击   驱动程序   链接，然后选择   MySQL for 5.1  。

3. 要下载 MySQL 5.1 的 JDBC 驱动程序，请点击对话框底部的   下载  链接。

4. 请指定数据库连接详情。 或者，粘贴 JDBC URL 到   URL   字段中。

要删除密码，请右键点击   密码   字段，然后选择   设置为空  。

![数据源和驱动程序对话框的常规选项卡](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_general_tab.png)

有关   数据源和驱动程序   对话框（ `Shift+Enter` (Windows), `⌘ I` (macOS), `⇧ ⏎` (IntelliJ IDEA Classic (macOS)), `⌘ I` (macOS System Shortcuts), `Shift+Enter` (XWin), `Shift+Enter` (GNOME), `Shift+Enter` (KDE), `Shift+Enter` (Emacs), `Shift+Enter` (Sublime Text), `⌘ I` (Sublime Text (macOS)), `Shift+Enter` (Visual Studio), `⌘ I` (Visual Studio (macOS)), `Shift+Enter` (NetBeans), `Shift+Enter` (Eclipse), `⌘ I` (Eclipse (macOS))）中   常规   及其他选项卡上的连接设置（例如，   主持人  、   端口   等）的参考信息，请参见 [数据源](data-sources-and-drivers-dialog.html#db)。

5. 确保可以使用提供的详细信息建立数据库连接。 为此，请点击连接详细信息部分底部的   测试连接   链接。

![测试连接链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_test_connection_link.png)

如果您遇到任何连接问题，请参考 [无法连接到数据库](connectivity-problems.html)页面。

6. （可选）默认情况下，仅默认模式会被内省并可供使用。 如果您还想使用其他模式，请在   架构   选项卡中选择它们以进行内省。

![数据源和驱动程序对话框的 Schemas 选项卡](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_schemas_tab.png)

7. 点击   OK   创建数据源。

8. 在   数据库   工具窗口中找到您的新数据源。

* 有关 数据库 工具窗口的更多信息，请参见相应的 [参考主题](database-tool-window.html)。 > **Tip:** > 要在新数据源节点下查看更多模式，请点击 第 N 个，共 M 个 按钮并选择您需要的模式。 IntelliJ IDEA 将进行内省并显示它们。 > > > > ![选择数据库和架构以在数据库工具窗口中进行自省和显示](https://resources.jetbrains.com/help/img/idea/2026.3/connection_flow_show_databases_and_schemas.png)

* 有关在 IntelliJ IDEA 中使用数据库对象的更多信息，请参考 [数据库对象](database-objects.html)。

* 要编写并运行查询，请通过点击数据源并按下 `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F4` (NetBeans), `F12` (Eclipse), `F3` (Eclipse (macOS)) 打开默认的 [查询控制台](query-consoles.html)。

* 若要查看和编辑数据库对象的数据，请双击该对象以打开 [数据编辑器和查看器](data-editor-and-viewer.html)。

![连接 MySQL 5.1](https://resources.jetbrains.com/help/img/idea/2026.3/db_connect_to_mysql_51.png)

Procedure: 无法通过 SSL 连接到云中的 MySQL 5.*

1. 通过以下任一方式打开数据源属性：

* 在 数据库 工具窗口工具栏中，点击 ![数据源图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.manageDataSources.svg) 数据源 。

* 请按 `Shift+Enter` (Windows), `⌘ I` (macOS), `⇧ ⏎` (IntelliJ IDEA Classic (macOS)), `⌘ I` (macOS System Shortcuts), `Shift+Enter` (XWin), `Shift+Enter` (GNOME), `Shift+Enter` (KDE), `Shift+Enter` (Emacs), `Shift+Enter` (Sublime Text), `⌘ I` (Sublime Text (macOS)), `Shift+Enter` (Visual Studio), `⌘ I` (Visual Studio (macOS)), `Shift+Enter` (NetBeans), `Shift+Enter` (Eclipse), `⌘ I` (Eclipse (macOS)) .

![打开数据源和驱动程序对话框](https://resources.jetbrains.com/help/img/idea/2026.3/open_data_sources_and_drivers_dialog.png)

2. 点击   驱动程序   链接，然后选择   前往 Driver  。

3. 在   驱动程序文件  窗格中，点击   ver. *.*.*.*  链接并选择   5.1.40  。

4. 点击创建的 MySQL 数据源条目。

5. 请指定数据库连接详情。 或者，粘贴 JDBC URL 到   URL   字段中。

要删除密码，请右键点击   密码   字段，然后选择   设置为空  。

![数据源和驱动程序对话框的常规选项卡](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_general_tab.png)

有关   数据源和驱动程序   对话框（ `Shift+Enter` (Windows), `⌘ I` (macOS), `⇧ ⏎` (IntelliJ IDEA Classic (macOS)), `⌘ I` (macOS System Shortcuts), `Shift+Enter` (XWin), `Shift+Enter` (GNOME), `Shift+Enter` (KDE), `Shift+Enter` (Emacs), `Shift+Enter` (Sublime Text), `⌘ I` (Sublime Text (macOS)), `Shift+Enter` (Visual Studio), `⌘ I` (Visual Studio (macOS)), `Shift+Enter` (NetBeans), `Shift+Enter` (Eclipse), `⌘ I` (Eclipse (macOS))）中   常规   及其他选项卡上的连接设置（例如，   主持人  、   端口   等）的参考信息，请参见 [数据源](data-sources-and-drivers-dialog.html#db)。

6. 确保可以使用提供的详细信息建立数据库连接。 为此，请点击连接详细信息部分底部的   测试连接   链接。

![测试连接链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_test_connection_link.png)

如果您遇到任何连接问题，请参考 [无法连接到数据库](connectivity-problems.html)页面。

7. （可选）默认情况下，仅默认模式会被内省并可供使用。 如果您还想使用其他模式，请在   架构   选项卡中选择它们以进行内省。

![数据源和驱动程序对话框的 Schemas 选项卡](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_schemas_tab.png)

8. 点击   OK   创建数据源。

9. 在   数据库   工具窗口中找到您的新数据源。

* 有关 数据库 工具窗口的更多信息，请参见相应的 [参考主题](database-tool-window.html)。 > **Tip:** > 要在新数据源节点下查看更多模式，请点击 第 N 个，共 M 个 按钮并选择您需要的模式。 IntelliJ IDEA 将进行内省并显示它们。 > > > > ![选择数据库和架构以在数据库工具窗口中进行自省和显示](https://resources.jetbrains.com/help/img/idea/2026.3/connection_flow_show_databases_and_schemas.png)

* 有关在 IntelliJ IDEA 中使用数据库对象的更多信息，请参考 [数据库对象](database-objects.html)。

* 要编写并运行查询，请通过点击数据源并按下 `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F4` (NetBeans), `F12` (Eclipse), `F3` (Eclipse (macOS)) 打开默认的 [查询控制台](query-consoles.html)。

* 若要查看和编辑数据库对象的数据，请双击该对象以打开 [数据编辑器和查看器](data-editor-and-viewer.html)。

## See also

### 参考

[数据源及其元素](database-tool-window.html#icons-for-data-sources-and-their-elements) [数据源和驱动程序对话框](data-sources-and-drivers-dialog.html)

### 工具 Windows

[数据库工具窗口](database-tool-window.html)

