# 使用不同的身份验证方法创建 Google BigQuery 数据源

> For the complete documentation index, see [llms.txt](https://www.jetbrains.com/zh-cn/help/idea/llms.txt).

Procedure: 启用 数据库工具和 SQL 插件

此功能依赖于 数据库工具和 SQL 插件，该插件默认情况下在 IntelliJ IDEA 中绑定并启用。 如果相关功能不可用，请确保您没有禁用插件。

> **Note:**
> 没有 Ultimate 订阅时，数据库工具和 SQL 的功能支持在 IntelliJ IDEA 中受限。

1. 按 `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS)) 打开设置，然后选择  `插件` 。

2. 找到  数据库工具和 SQL  插件并点击   启用  。

Procedure: 官方文档

* 有关 Google BigQuery 的完整信息，请参阅 [官方文档](https://cloud.google.com/bigquery/docs)。

Google BigQuery是一项基于 REST 的网络服务，允许您在大数据集下运行复杂的基于 SQL 的分析查询。

要创建 Google BigQuery 数据源并测试连接，您可以使用以下方法：

* [使用 Google 用户帐户](#google-user-account)

* [使用 Google 服务账号](#google-service-account)

* [使用应用程序默认凭证](#application-default-credentials)

* [使用访问令牌和刷新令牌](#connecting-with-access-and-refresh-tokens-oauth-2-0)

## Google 用户帐户

当您使用 Google 用户帐户进行授权时，需要在网页浏览器中接收授权代码。

Procedure: 连接到 Google BigQuery

要连接到数据库，请创建一个数据源以存储您的连接详细信息。

1. 选择您要创建的数据源。 您可以通过以下方式执行此操作：

* 在主菜单中，前往 `文件 | 新建 | 数据源` 并选择 Google BigQuery 。

* 在 数据库 工具窗口中，点击工具栏上的 ![新建图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.add.svg) 新建 。 导航到 数据源 并选择 Google BigQuery 。

![创建一个新的数据源](https://resources.jetbrains.com/help/img/idea/2026.3/create_new_data_source.png)

2. 请检查连接设置区域底部是否有一个   下载缺少的驱动程序文件   链接。 点击此链接下载与数据库交互所需的驱动程序。 如需直接下载链接，请参考 [JetBrains JDBC drivers](https://www.jetbrains.com/zh-cn/datagrip/jdbc-drivers/)页面。

![下载缺失的驱动文件链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_download_missing_drivers_link.png)

下载的 JDBC 驱动程序的位置是 [IntelliJ IDEA 配置目录](directories-used-by-the-ide-to-store-settings-caches-plugins-and-logs.html#config-directory)。

您也可以使用自己的数据库驱动程序，而不是提供的那些。 要了解有关使用驱动程序连接到数据库的更多信息，请参阅 [将用户驱动程序添加到现有连接中](jdbc-drivers.html#configure_a_jdbc_driver_for_an_existing_data_source)。

如果没有   下载缺少的驱动程序文件   链接，则表示您已经拥有所需的驱动程序。

3. 从   身份验证   列表中选择   Google 用户帐户  。

4. 在   项目 ID   字段中，输入项目 ID。

通常，这是服务账号电子邮件中位于 at 符号（  `@` ）之后的部分。 例如，  `bigqueryproject-322409` 。 有关项目 ID 的格式，请参阅 [创建服务账号的官方说明](https://cloud.google.com/iam/docs/service-accounts-create)。

5. 从   需要授权码  对话框中剪切 URL，将其粘贴到您的网络浏览器地址栏中，然后按 `Enter` (Windows), `⏎` (macOS), `⏎` (IntelliJ IDEA Classic (macOS)), `⏎` (macOS System Shortcuts), `Enter` (XWin), `Enter` (GNOME), `Enter` (KDE), `Enter` (Emacs), `Enter` (Sublime Text), `⏎` (Sublime Text (macOS)), `Enter` (Visual Studio), `⏎` (Visual Studio (macOS)), `Enter` (NetBeans), `Enter` (Eclipse), `⏎` (Eclipse (macOS))以访问该 URL。

6. 在您的 Google 帐户中授权访问 Google BigQuery 应用程序。

7. 请从 Google 复制收到的授权代码，粘贴到   需要授权码  对话框中，然后点击   OK  。

8. 确保可以使用提供的详细信息建立数据库连接。 为此，请点击连接详细信息部分底部的   测试连接   链接。

![测试连接链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_test_connection_link.png)

如果您遇到任何连接问题，请参考 [无法连接到数据库](connectivity-problems.html)页面。

9. （可选）默认情况下，仅默认项目和数据集会被内省并可供使用。 如果您还想使用其他项目和数据集，请在   架构   选项卡中选择它们以进行内省。

![数据源和驱动程序对话框的 Schemas 选项卡](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_schemas_tab.png)

10. 点击   OK   创建数据源。

11. 在   数据库   工具窗口中找到您的新数据源。

* 有关 数据库 工具窗口的更多信息，请参见相应的 [参考主题](database-tool-window.html)。 > **Tip:** > 要在新的数据源节点下查看更多项目和数据集，请点击 第 N 个，共 M 个 按钮并选择您需要的项目和数据集。 IntelliJ IDEA 将进行内省并显示它们。 > > > > ![选择数据库和架构以在数据库工具窗口中进行自省和显示](https://resources.jetbrains.com/help/img/idea/2026.3/connection_flow_show_databases_and_schemas.png)

* 有关在 IntelliJ IDEA 中使用数据库对象的更多信息，请参考 [数据库对象](database-objects.html)。

* 要编写并运行查询，请通过点击数据源并按下 `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F4` (NetBeans), `F12` (Eclipse), `F3` (Eclipse (macOS)) 打开默认的 [查询控制台](query-consoles.html)。

* 若要查看和编辑数据库对象的数据，请双击该对象以打开 [数据编辑器和查看器](data-editor-and-viewer.html)。

[Video](https://resources.jetbrains.com/help/img/idea/2026.3/application_default_credentials.json` 。

可以使用  `GOOGLE_APPLICATION_CREDENTIALS`  环境变量为凭据文件设置自定义位置。 或者，在   服务帐户密钥文件   字段中设置凭据文件的路径。

要为连接生成服务账号密钥文件，需要创建一个 [Google Cloud Platform 服务账号](https://cloud.google.com/iam/docs/service-accounts)。

Procedure: 步骤 1。 获取凭证文件

1. 按照 [官方说明](https://cloud.google.com/iam/docs/service-accounts-create#creating)创建服务账户。

在   授予此服务帐号对该项目的访问权限  步骤中，选择此服务帐户的角色。

例如，对于只读访问，请从   Google BigQuery   菜单中选择   Google BigQuery 数据查看器  、   Google BigQuery 作业用户   和   Google BigQuery 用户  。 或者，选择  `Google BigQuery | Google BigQuery 管理员`  以访问项目中的所有资源。

有关角色和权限的更多信息，请参阅 [cloud.google.com 上的预定义角色和权限](https://cloud.google.com/bigquery/docs/access-control)。

2. 按照 [官方说明](https://cloud.google.com/iam/docs/keys-create-delete#creating)生成并下载服务账户密钥文件。

Procedure: 步骤 2。 连接到 Google BigQuery

要连接到数据库，请创建一个数据源以存储您的连接详细信息。

1. 选择您要创建的数据源。 您可以通过以下方式执行此操作：

* 在主菜单中，前往 `文件 | 新建 | 数据源` 并选择 Google BigQuery 。

* 在 数据库 工具窗口中，点击工具栏上的 ![新建图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.add.svg) 新建 。 导航到 数据源 并选择 Google BigQuery 。

![创建一个新的数据源](https://resources.jetbrains.com/help/img/idea/2026.3/create_new_data_source.png)

2. 请检查连接设置区域底部是否有一个   下载缺少的驱动程序文件   链接。 点击此链接下载与数据库交互所需的驱动程序。 如需直接下载链接，请参考 [JetBrains JDBC drivers](https://www.jetbrains.com/zh-cn/datagrip/jdbc-drivers/)页面。

![下载缺失的驱动文件链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_download_missing_drivers_link.png)

下载的 JDBC 驱动程序的位置是 [IntelliJ IDEA 配置目录](directories-used-by-the-ide-to-store-settings-caches-plugins-and-logs.html#config-directory)。

您也可以使用自己的数据库驱动程序，而不是提供的那些。 要了解有关使用驱动程序连接到数据库的更多信息，请参阅 [将用户驱动程序添加到现有连接中](jdbc-drivers.html#configure_a_jdbc_driver_for_an_existing_data_source)。

如果没有   下载缺少的驱动程序文件   链接，则表示您已经拥有所需的驱动程序。

3. 从   身份验证   列表中选择   应用默认凭据  。

4. 在   服务帐户密钥文件   字段中，输入在 [步骤 1 获得的 JSON 服务账号密钥文件的路径。 获取凭证](#obtain_credentials_adc)。

5. 确保可以使用提供的详细信息建立数据库连接。 为此，请点击连接详细信息部分底部的   测试连接   链接。

![测试连接链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_test_connection_link.png)

如果您遇到任何连接问题，请参考 [无法连接到数据库](connectivity-problems.html)页面。

6. （可选）默认情况下，仅默认项目和数据集会被内省并可供使用。 如果您还想使用其他项目和数据集，请在   架构   选项卡中选择它们以进行内省。

![数据源和驱动程序对话框的 Schemas 选项卡](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_schemas_tab.png)

7. 点击   OK   创建数据源。

8. 在   数据库   工具窗口中找到您的新数据源。

* 有关 数据库 工具窗口的更多信息，请参见相应的 [参考主题](database-tool-window.html)。 > **Tip:** > 要在新的数据源节点下查看更多项目和数据集，请点击 第 N 个，共 M 个 按钮并选择您需要的项目和数据集。 IntelliJ IDEA 将进行内省并显示它们。 > > > > ![选择数据库和架构以在数据库工具窗口中进行自省和显示](https://resources.jetbrains.com/help/img/idea/2026.3/connection_flow_show_databases_and_schemas.png)

* 有关在 IntelliJ IDEA 中使用数据库对象的更多信息，请参考 [数据库对象](database-objects.html)。

* 要编写并运行查询，请通过点击数据源并按下 `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F4` (NetBeans), `F12` (Eclipse), `F3` (Eclipse (macOS)) 打开默认的 [查询控制台](query-consoles.html)。

* 若要查看和编辑数据库对象的数据，请双击该对象以打开 [数据编辑器和查看器](data-editor-and-viewer.html)。

![与应用程序默认凭据连接](https://resources.jetbrains.com/help/img/idea/2026.3/application_default_credentials.json` 。

可以使用  `GOOGLE_APPLICATION_CREDENTIALS`  环境变量为凭据文件设置自定义位置。 或者，在   密钥文件   字段中设置凭据文件的路径。

要为连接生成服务账号密钥文件，需要创建一个 [Google Cloud Platform 服务账号](https://cloud.google.com/iam/docs/service-accounts)。

Procedure: 步骤 1。 获取凭证文件

1. 按照 [官方说明](https://cloud.google.com/iam/docs/service-accounts-create#creating)创建服务账户。

在   授予此服务帐号对该项目的访问权限  步骤中，选择此服务帐户的角色。

例如，对于只读访问，请从   Google BigQuery   菜单中选择   Google BigQuery 数据查看器  、   Google BigQuery 作业用户   和   Google BigQuery 用户  。 或者，选择  `Google BigQuery | Google BigQuery 管理员`  以访问项目中的所有资源。

有关角色和权限的更多信息，请参阅 [cloud.google.com 上的预定义角色和权限](https://cloud.google.com/bigquery/docs/access-control)。

2. 按照 [官方说明](https://cloud.google.com/iam/docs/keys-create-delete#creating)生成并下载服务账户密钥文件。

Procedure: 步骤 2。 连接到 Google BigQuery

要连接到数据库，请创建一个数据源以存储您的连接详细信息。

1. 选择您要创建的数据源。 您可以通过以下方式执行此操作：

* 在主菜单中，前往 `文件 | 新建 | 数据源` 并选择 Google BigQuery 。

* 在 数据库 工具窗口中，点击工具栏上的 ![新建图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.add.svg) 新建 。 导航到 数据源 并选择 Google BigQuery 。

![创建一个新的数据源](https://resources.jetbrains.com/help/img/idea/2026.3/create_new_data_source.png)

2. 请检查连接设置区域底部是否有一个   下载缺少的驱动程序文件   链接。 点击此链接下载与数据库交互所需的驱动程序。 如需直接下载链接，请参考 [JetBrains JDBC drivers](https://www.jetbrains.com/zh-cn/datagrip/jdbc-drivers/)页面。

![下载缺失的驱动文件链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_download_missing_drivers_link.png)

下载的 JDBC 驱动程序的位置是 [IntelliJ IDEA 配置目录](directories-used-by-the-ide-to-store-settings-caches-plugins-and-logs.html#config-directory)。

您也可以使用自己的数据库驱动程序，而不是提供的那些。 要了解有关使用驱动程序连接到数据库的更多信息，请参阅 [将用户驱动程序添加到现有连接中](jdbc-drivers.html#configure_a_jdbc_driver_for_an_existing_data_source)。

如果没有   下载缺少的驱动程序文件   链接，则表示您已经拥有所需的驱动程序。

3. 从   身份验证   列表中选择   Google Service Account  。

4. 在   服务帐户邮箱   字段中，输入服务账号的名称。

您可以在 Google Cloud Platform 的   服务帐户  页面(  `IAM & 管理 | 服务账号` )找到该服务帐户的名称   电子邮件  。 有关创建服务账户名称格式的更多信息，请参阅 [官方说明](https://cloud.google.com/iam/docs/service-accounts-create)。 服务帐户的名称应如下所示：  `intellij-ide@bigqueryproject-322409.iam.gserviceaccount.com` 。

5. 在   项目 ID   字段中，输入项目 ID。

通常，这是服务账号电子邮件中位于 at 符号（  `@` ）之后的部分。 例如，  `bigqueryproject-322409` 。 有关项目 ID 的格式，请参阅 [创建服务账号的官方说明](https://cloud.google.com/iam/docs/service-accounts-create)。

6. 在   密钥文件   字段中，输入在 [步骤 1 获得的 JSON 服务账号密钥文件的路径。 获取凭据](#obtain_credentials_gsa)。

7. 确保可以使用提供的详细信息建立数据库连接。 为此，请点击连接详细信息部分底部的   测试连接   链接。

![测试连接链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_test_connection_link.png)

如果您遇到任何连接问题，请参考 [无法连接到数据库](connectivity-problems.html)页面。

8. （可选）默认情况下，仅默认项目和数据集会被内省并可供使用。 如果您还想使用其他项目和数据集，请在   架构   选项卡中选择它们以进行内省。

![数据源和驱动程序对话框的 Schemas 选项卡](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_schemas_tab.png)

9. 点击   OK   创建数据源。

10. 在   数据库   工具窗口中找到您的新数据源。

* 有关 数据库 工具窗口的更多信息，请参见相应的 [参考主题](database-tool-window.html)。 > **Tip:** > 要在新的数据源节点下查看更多项目和数据集，请点击 第 N 个，共 M 个 按钮并选择您需要的项目和数据集。 IntelliJ IDEA 将进行内省并显示它们。 > > > > ![选择数据库和架构以在数据库工具窗口中进行自省和显示](https://resources.jetbrains.com/help/img/idea/2026.3/connection_flow_show_databases_and_schemas.png)

* 有关在 IntelliJ IDEA 中使用数据库对象的更多信息，请参考 [数据库对象](database-objects.html)。

* 要编写并运行查询，请通过点击数据源并按下 `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F4` (NetBeans), `F12` (Eclipse), `F3` (Eclipse (macOS)) 打开默认的 [查询控制台](query-consoles.html)。

* 若要查看和编辑数据库对象的数据，请双击该对象以打开 [数据编辑器和查看器](data-editor-and-viewer.html)。

![与 Google 服务帐户连接](https://resources.jetbrains.com/help/img/idea/2026.3/db_connecting_to_bigquery_with_a_google_service_account_2021_3.png)

## 访问及刷新令牌（OAuth 2.0）

要使用   访问令牌与刷新令牌   身份验证方法连接到 Google BigQuery 数据库，您需要以下凭据：客户端 ID 和客户端密钥、刷新和访问令牌。

在使用 OAuth 2.0 进行身份验证时，您的用户在同意用户同意屏幕上显示的条款后将被验证。 OAuth 同意屏幕是一个对话框，显示关于谁请求访问用户数据及其数据类型的通知。

在生成 client ID 和 client secret 之前，您需要配置 OAuth 同意屏幕。

Procedure: 步骤 1。 获取凭证

1. 按照 [官方说明](https://developers.google.com/workspace/guides/configure-oauth-consent)创建 OAuth 同意屏幕。

有关用户同意的更多信息，请参阅 [support.google.com 的用户同意部分](https://support.google.com/cloud/answer/6158849?hl=en#zippy=%2Cuser-consent)

2. 按照 [官方说明](https://support.google.com/cloud/answer/6158849)获取客户端 ID 和客户端密钥。

对于 URI，请使用以下内容：

```CURL
https://developers.google.com/oauthplayground
```

在   OAuth 客户端已创建   窗口中查找您的 client ID 和 client secret。 或者，您可以点击创建的 OAuth 客户端 ID 配置并在此获取您的凭据。

3. 拥有 client ID 和 client secret，您可以生成 authorization code 和 tokens。 要执行此操作，请执行以下步骤：

1.  在一个单独的浏览器标签中打开 [OAuth 2.0 Playground](https://developers.google.com/oauthplayground/)。

2.  请点击   OAuth 2.0 配置   图标，选择   使用您自己的 OAuth 凭据   复选框。

3.

请将您的 client ID 和 client secret 粘贴到   OAuth Client ID   和   OAuth 客户端密钥   字段中。

![OAuth 2.0 配置](https://resources.jetbrains.com/help/img/idea/2026.3/db_o_auth_2_0_configuration.png)

4.  请在   关闭   窗口中点击   OAuth 2.0 配置  。

5.  在   步骤 1。 选择并授权 API  上的向导中，选择  `BigQuery API v2 | https://www.googleapis.com/auth/bigquery` 。

6.  点击   授权 API  。

7.

在浏览器中按照向导操作并授予应用程序权限。

![授予应用程序权限](https://resources.jetbrains.com/help/img/idea/2026.3/db_give_permissions_to_the_application.png)

8.

在   第二步 交换授权码获取令牌  上，点击   将授权码交换为令牌  。

9.

复制收到的刷新令牌和访问令牌。

![刷新和访问令牌](https://resources.jetbrains.com/help/img/idea/2026.3/db_refresh_and_access_tokens.png)

Procedure: 步骤 2。 连接到 Google BigQuery

要连接到数据库，请创建一个数据源以存储您的连接详细信息。

1. 选择您要创建的数据源。 您可以通过以下方式执行此操作：

* 在主菜单中，前往 `文件 | 新建 | 数据源` 并选择 Google BigQuery 。

* 在 数据库 工具窗口中，点击工具栏上的 ![新建图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.add.svg) 新建 。 导航到 数据源 并选择 Google BigQuery 。

![创建一个新的数据源](https://resources.jetbrains.com/help/img/idea/2026.3/create_new_data_source.png)

2. 请检查连接设置区域底部是否有一个   下载缺少的驱动程序文件   链接。 点击此链接下载与数据库交互所需的驱动程序。 如需直接下载链接，请参考 [JetBrains JDBC drivers](https://www.jetbrains.com/zh-cn/datagrip/jdbc-drivers/)页面。

![下载缺失的驱动文件链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_download_missing_drivers_link.png)

下载的 JDBC 驱动程序的位置是 [IntelliJ IDEA 配置目录](directories-used-by-the-ide-to-store-settings-caches-plugins-and-logs.html#config-directory)。

您也可以使用自己的数据库驱动程序，而不是提供的那些。 要了解有关使用驱动程序连接到数据库的更多信息，请参阅 [将用户驱动程序添加到现有连接中](jdbc-drivers.html#configure_a_jdbc_driver_for_an_existing_data_source)。

如果没有   下载缺少的驱动程序文件   链接，则表示您已经拥有所需的驱动程序。

3. 从   身份验证   列表中选择   访问令牌与刷新令牌  。

4. 在   项目 ID   字段中，输入项目 ID。

通常，这是服务账号电子邮件中位于 at 符号（  `@` ）之后的部分。 例如，  `bigqueryproject-322409` 。 有关项目 ID 的格式，请参阅 [创建服务账号的官方说明](https://cloud.google.com/iam/docs/service-accounts-create)。

5. 在   访问令牌  字段中，粘贴 [您的访问令牌](#refresh_access_tokens)。

6. 在   刷新令牌  字段中，粘贴 [您的 refresh token](#refresh_access_tokens)。

7. 在   客户端 ID  字段中，粘贴 [您的 client ID](#client_id_client_secret)。

8. 在   客户端密钥  字段中，粘贴 [您的 client secret](#client_id_client_secret)。

9. 确保可以使用提供的详细信息建立数据库连接。 为此，请点击连接详细信息部分底部的   测试连接   链接。

![测试连接链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_test_connection_link.png)

如果您遇到任何连接问题，请参考 [无法连接到数据库](connectivity-problems.html)页面。

10. （可选）默认情况下，仅默认项目和数据集会被内省并可供使用。 如果您还想使用其他项目和数据集，请在   架构   选项卡中选择它们以进行内省。

![数据源和驱动程序对话框的 Schemas 选项卡](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_schemas_tab.png)

11. 点击   OK   创建数据源。

12. 在   数据库   工具窗口中找到您的新数据源。

* 有关 数据库 工具窗口的更多信息，请参见相应的 [参考主题](database-tool-window.html)。 > **Tip:** > 要在新的数据源节点下查看更多项目和数据集，请点击 第 N 个，共 M 个 按钮并选择您需要的项目和数据集。 IntelliJ IDEA 将进行内省并显示它们。 > > > > ![选择数据库和架构以在数据库工具窗口中进行自省和显示](https://resources.jetbrains.com/help/img/idea/2026.3/connection_flow_show_databases_and_schemas.png)

* 有关在 IntelliJ IDEA 中使用数据库对象的更多信息，请参考 [数据库对象](database-objects.html)。

* 要编写并运行查询，请通过点击数据源并按下 `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F4` (NetBeans), `F12` (Eclipse), `F3` (Eclipse (macOS)) 打开默认的 [查询控制台](query-consoles.html)。

* 若要查看和编辑数据库对象的数据，请双击该对象以打开 [数据编辑器和查看器](data-editor-and-viewer.html)。

![使用令牌连接](https://resources.jetbrains.com/help/img/idea/2026.3/db_connecting_with_tokens_2021_3.png)

## See also

### 参考

[数据源及其元素](database-tool-window.html#icons-for-data-sources-and-their-elements) [数据源和驱动程序对话框](data-sources-and-drivers-dialog.html)

### 工具 Windows

[数据库工具窗口](database-tool-window.html)

