# 数据编辑器和查看器

> For the complete documentation index, see [llms.txt](https://www.jetbrains.com/zh-cn/help/idea/llms.txt).

Procedure: 启用 数据库工具和 SQL 插件

此功能依赖于 数据库工具和 SQL 插件，该插件默认情况下在 IntelliJ IDEA 中绑定并启用。 如果相关功能不可用，请确保您没有禁用插件。

> **Note:**
> 没有 Ultimate 订阅时，数据库工具和 SQL 的功能支持在 IntelliJ IDEA 中受限。

1. 按 `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS)) 打开设置，然后选择  `插件` 。

2. 找到  数据库工具和 SQL  插件并点击   启用  。

## 概述

数据编辑器和查看器 ，或  数据编辑器 ，提供了一个用于处理数据的用户界面。 在数据编辑器中，可以对数据进行排序、应用筛选器、添加、编辑和移除，并执行其他相关任务。

在 IntelliJ IDEA 中，数据编辑器和查看器允许您处理 [数据库对象数据](#open_database_object_data)、 [查询结果集](#view_query_result_set)以及 [用户文件数据](#view_user_files_data_as_a_table)。

数据库对象数据:

![数据编辑器中的数据库对象数据](https://resources.jetbrains.com/help/img/idea/2026.3/data_editor_db_object_data_intro.png)

1.  [工具栏。](#toolbar_controls)

2.  [过滤](tables-filter.html#filtering_sorting_data) 和 [排序](tables-sort.html#filtering_sorting_data) 查询窗格。

3.  [表视图](tables-view-data.html#data_view_modes_list)中的数据库对象数据。

有关   数据库   工具窗口的更多信息，请参阅 [数据库工具窗口](database-tool-window.html)。

查询结果集：Services 工具窗口:

![结果选项卡中的数据编辑器](https://resources.jetbrains.com/help/img/idea/2026.3/db_data_editor_query_result_tab_intro.png)

1.  [工具栏。](#toolbar_controls)

2.  在 [表格视图](tables-view-data.html#data_view_modes_list) 中的查询结果集。

有关   服务   工具窗口的   结果   选项卡的更多信息，请参阅 [结果选项卡](viewing-query-results.html#result_tabs)。

查询结果集：In-Editor Results:

![编辑器内结果中的数据编辑器](https://resources.jetbrains.com/help/img/idea/2026.3/db_data_editor_query_result_ineditor_intro.png)

1.  [工具栏。](#toolbar_controls)

2.  在 [表格视图](tables-view-data.html#data_view_modes_list) 中的查询结果集。

有关   在编辑器中查看结果   的更多信息，请参阅 [编辑器内结果](viewing-query-results.html#in_editor_results)。

用户文件数据:

![定界符分隔值文件编辑器中的数据编辑器选项卡](https://resources.jetbrains.com/help/img/idea/2026.3/data_editor_for_dsv_files_data.png)

1.  工具栏。

2.  用户文件数据。

有关使用用户文件内容的更多信息，请参阅 [将 DSV 文件作为表格编辑](editing-csv-and-tsv-files.html) 和 [数据加载器](data-loaders.html)。

默认的 [视图模式](tables-view-data.html#data_view_modes)是   表  。 在此模式下，您可以 [筛选](tables-filter.html)和 [排序](tables-sort.html)数据，直接编辑 [单元格](cells.html)的值，并处理数据表的 [行](rows.html)。

Procedure: 打开数据库对象数据

要在数据编辑器中打开数据库对象数据，请在   数据库   工具窗口中执行以下操作之一：

* 双击数据库对象。

* 选择一个数据库对象并按 `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F4` (NetBeans), `F12` (Eclipse), `F3` (Eclipse (macOS))。

* 选择一个数据库对象，然后点击工具栏上的 ![编辑数据图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.table.svg)   编辑数据  。

* 右键点击对象并选择   编辑数据  。

![数据编辑器选项卡](https://resources.jetbrains.com/help/img/idea/2026.3/data_editor_db_object_data.png)

Procedure: 查看查询结果集

要在数据编辑器中查看查询结果集，请在 查询控制台 中执行以下操作之一：

* 运行 SQL 查询。 数据编辑器将在   服务   工具窗口的   结果   选项卡中打开。

* 点击工具栏上的 ![编辑器内结果图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.editorOutput.svg)   在编辑器中查看结果   并运行查询。 数据编辑器将在 查询控制台 的编辑器内结果窗格中打开。

“服务”工具窗口:

![结果选项卡中的数据编辑器](https://resources.jetbrains.com/help/img/idea/2026.3/db_data_editor_query_result_tab.png)

有关   服务   工具窗口的   结果   选项卡的更多信息，请参阅 [结果选项卡](viewing-query-results.html#result_tabs)。

在编辑器中查看结果:

![编辑器内结果中的数据编辑器](https://resources.jetbrains.com/help/img/idea/2026.3/db_data_editor_query_result_ineditor_glossary.png)

有关   在编辑器中查看结果   的更多信息，请参阅 [编辑器内结果](viewing-query-results.html#in_editor_results)。

Procedure: 查看用户文件数据表

* 对于 [支持格式](data-loaders.html#supported_file_formats) 的表格数据用户文件，请执行以下操作：

* 在 项目 工具窗口中，点击要以表格形式查看的表格数据文件。

对于此类文件，表格视图是只读的。

![Excel 文件的内容显示在数据编辑器中](https://resources.jetbrains.com/help/img/idea/2026.3/tabular_data_file_data_in_data_editor_excel.png)

* 对于 DSV 用户文件，请执行以下操作：

1.

在   项目   工具窗口中，点击您想要以表格形式查看和编辑的 DSV 文件。

2.

在分隔符分隔的文本文件内右键点击，然后点击   作为表编辑  。 或者，您可以在编辑器中点击   作为表编辑   图标。

3.

在打开的   为 <file_name> 配置 CSV 格式   对话框中，指定格式设置并点击   OK  。

该对话框提供三种预定义格式（ CSV、TSV 和竖线分隔 ），并允许您创建自定义格式。 例如，您可能需要用分号作为行分隔符的逗号分隔值。

确认格式设置后，   数据   选项卡将相应地以表格形式显示数据。 如果您想使用不同的格式设置，请重复之前的步骤并再次打开数据编辑器。

[Video](https://resources.jetbrains.com/help/img/idea/2026.3/open_dsv_file_as_table.mp4)

> **Tip:**
> 如果您只想编辑部分数据，请在文件内选择所需的片段。

Procedure: 关闭数据编辑器

* 要关闭数据编辑器，请点击与相应选项卡标题相邻的 ![关闭图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.closeSmall.svg)   关闭  。

## 与数据协作

### 查看数据

您可以在三种模式下浏览和编辑数据：   表  、   树  、   文本  和   转置  。 在   表  模式中，您还可以调换视图。 使用值编辑器查看和编辑单个单元格的内容。

有关数据视图模式和其他功能的完整信息，请参阅 [查看数据](tables-view-data.html)。

![转置表格视图模式](https://resources.jetbrains.com/help/img/idea/2026.3/db_viewing_modes_transposed_table.png)

### 比较数据

比较两个数据库对象的数据。 为了进行比较，您可以定义多少列应有所不同，以便认为两列相等。 您还可以选择忽略任一对象中的额外列。

有关完整信息，请参阅 [比较数据库对象的数据](compare-data.html)。

![将表格数据的容差比较设置为一](https://resources.jetbrains.com/help/img/idea/2026.3/db_compare_table_data_tolerance_one.png)

### 排序数据

您可以通过点击列标题或在相应字段中输入排序查询来对数据进行排序。 默认情况下，每次您排序数据时，IntelliJ IDEA 会向数据库发送一个新的  `排序依据` 查询。 您还可以更改设置并在客户端对数据进行排序。

有关排序数据的更多信息，请参阅 [排序数据](tables-sort.html) 主题。

[Video](https://resources.jetbrains.com/help/img/idea/2026.3/db_stacked_sorting.mp4)

### 使用筛选器筛选数据

过滤数据的方式如下：

* 指定筛选条件。

* 在表格上运行搜索。

* 在相应字段中输入筛选查询。

有关筛选数据的更多信息，请参阅 [使用筛选器筛选数据](tables-filter.html) 主题。

![用于排序的 WHERE 和 ORDER BY 字段](https://resources.jetbrains.com/help/img/idea/2026.3/db_where_and_order_by_fields_for_sorting.png)

### 导出数据

IntelliJ IDEA 使用  数据提取器  将数据以各种格式导出到文件或剪贴板。 每次您导出或复制数据时，复制的数据格式由所选的数据提取器定义。

![数据编辑器工具栏上的 Data extractor 列表](https://resources.jetbrains.com/help/img/idea/2026.3/db_toolbar_data_extractors_list.png)

可以使用内置数据提取器、配置基于 CSV 或 DSV 格式的自定义提取器，并使用提供的 API 创建自定义数据提取器。

最后选择的提取器将成为新打开编辑器选项卡的默认提取器。 对于 MongoDB 来说，默认的提取器总是 JSON。

有关数据提取器的更多信息，请参见 [相应页面](data-extractors.html)。

有关导出 IntelliJ IDEA 数据的更多信息，请参阅 [导出数据](export-data.html#methods-for-exporting-data)。

### 行

通过添加、删除、克隆等操作来操作行。 您还可以在相关行之间、行的子集之间进行导航，或转到指定的行。

有关这些及其他功能的完整信息，请参阅 [行](rows.html)。

## 参考

大多数可用功能都可以通过工具栏上的控件、数据单元格的上下文菜单命令以及相关键盘快捷键来访问。

### 工具栏控件

|  图标  |  操作和快捷键  |  描述  |
| --- | --- | --- |
|     ![第一页](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.actions.playFirst.svg)       ![上一页](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.actions.playBack.svg)    ![“更改页面大小”按钮](https://resources.jetbrains.com/help/img/idea/2026.3/db_page_size.png)    ![下一页](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.actions.playForward.svg)       ![最后一页](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.actions.playLast.svg)     |     第一页       上一页 `Ctrl+Alt+Up` (Windows), `⌘ ⌥ ↑` (macOS), `⌘ ⌥ ↑` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ ↑` (macOS System Shortcuts), `Ctrl+Alt+Up` (XWin), `Ctrl+Alt+Up` (GNOME), `Ctrl+Alt+Up` (KDE), `Ctrl+Alt+Up` (Emacs), `Ctrl+Alt+Up` (Sublime Text), `⌘ ⌥ ↑` (Sublime Text (macOS)), `Ctrl+Alt+Up` (Visual Studio), `⌘ ⌥ ↑` (Visual Studio (macOS)), `Ctrl+Alt+Up` (NetBeans), `Ctrl+Alt+Up` (Eclipse), `⌘ ⌥ ↑` (Eclipse (macOS))       更改页面大小       下一页 `Ctrl+Alt+Down` (Windows), `⌘ ⌥ ↓` (macOS), `⌘ ⌥ ↓` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ ↓` (macOS System Shortcuts), `Ctrl+Alt+Down` (XWin), `Ctrl+Alt+Down` (GNOME), `Ctrl+Alt+Down` (KDE), `Ctrl+Alt+Down` (Emacs), `Ctrl+Alt+Down` (Sublime Text), `⌘ ⌥ ↓` (Sublime Text (macOS)), `Ctrl+Alt+Down` (Visual Studio), `⌘ ⌥ ↓` (Visual Studio (macOS)), `Ctrl+Alt+Down` (NetBeans), `Ctrl+Alt+Down` (Eclipse), `⌘ ⌥ ↓` (Eclipse (macOS))       最后一页     |     如果在  `数据库 \| 数据编辑器和查看器 \| 控件自定义 \| 网格分页工具栏的位置`  下的 IDE 设置 ( `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS))) 中选择了该位置，则会显示在工具栏上。       使用导航图标和相应的命令在显示表格数据的页面之间切换，并更改页面大小。       您在工具栏上看到的行数称为  结果集页面 。 如果此数字小于表中的行数，则一次仅显示所有行的一个子集。 如果当前已显示所有行，则导航图标和相应命令处于非活动状态。 您可以看到导航按钮之间的界限。 您可以通过点击并选择必要的限制或 [在设置中](#change_limit_in_settings)进行更改。        * ![第一页](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.actions.playFirst.svg) 第一页 ：跳转到结果的第一页。    * ![上一页](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.actions.playBack.svg) 上一页 ：转到结果的上一页。    * ![下一页](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.actions.playForward.svg) 下一页 ：转到结果的下一页。    * ![最后一页](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.actions.playLast.svg) 最后一页 ：跳转到结果的最后一页。      要更改结果集页面的大小，请点击   更改页面大小   按钮并选择大小。 或者，打开设置（ `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS))），然后导航到  `工具 \| 数据库 \| 数据编辑器和查看器` 。 在   页面大小限制为   字段中，输入结果集页面的新大小。 或者，要禁用页面大小限制，请清除   页面大小限制为   复选框。     |
|     ![重新加载页面图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.general.refresh.svg)     |     重新加载页面    `Ctrl+F5` (Windows), `⌘ R` (macOS), `⌃ F5` (IntelliJ IDEA Classic (macOS)), `⌘ R` (macOS System Shortcuts), `Ctrl+F5` (XWin), `Ctrl+F5` (GNOME), `Ctrl+5` (KDE), `Ctrl+F5` (Emacs), `Ctrl+F5` (Sublime Text), `⌘ R` (Sublime Text (macOS)), `Ctrl+Alt+R` (Visual Studio), `⌘ ⌥ R` (Visual Studio (macOS)), `Ctrl+F5` (NetBeans), `Ctrl+F5` (Eclipse), `Ctrl+F5` (Eclipse (macOS))  |     为表视图 [重新加载数据](tables-view-data.html#updating_table_view)，以便将编辑器中看到的数据与数据库内容同步。 此外，当您想在更改后应用新的   重新加载页面  设置时，请使用 [页面大小限制](rows.html#making_all_rows_visible_proc)按钮。     |
|  ![更新间隔图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.general.history.svg)  |  更新间隔  |  选择、暂停或禁用当前表的更新间隔。 也可以设置自定义值。  |
|     ![“取消正在运行的语句”图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.run.stop.svg)           |     取消正在运行的语句    `Ctrl+F2` (Windows), `⌘ F2` (macOS), `⌘ F2` (IntelliJ IDEA Classic (macOS)), `⌃ ⇧ .` (macOS System Shortcuts), `Ctrl+F2` (XWin), `Ctrl+F2` (GNOME), `Ctrl+2` (KDE), `Ctrl+F2` (Emacs), `Ctrl+F2` (Sublime Text), `Ctrl+F2` (Sublime Text (macOS)), `Shift+F5` (Visual Studio), `⇧ F5` (Visual Studio (macOS)), `Shift+F5` (NetBeans), `Ctrl+F2` (Eclipse), `⌘ F2` (Eclipse (macOS))  |  终止当前一个或多个语句的执行。  |
|     ![添加行图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.general.add.svg)     |     添加行    `Alt+Insert` (Windows), `⌘ N` (macOS), `⌃ N` (IntelliJ IDEA Classic (macOS)), `⌘ N` (macOS System Shortcuts), `Alt+Insert` (XWin), `Alt+Insert` (GNOME), `Alt+Insert` (KDE), `Alt+Insert` (Emacs), `Ctrl+N` (Sublime Text), `⌘ N` (Sublime Text (macOS)), `Ctrl+N` (Visual Studio), `⌘ N` (Visual Studio (macOS)), `Alt+Insert` (NetBeans), `Alt+Insert` (Eclipse), `⌘ N` (Eclipse (macOS))  |     向表中添加一行。       要保存新行，请点击工具栏上的 ![提交按钮](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.submitDB.svg)   提交  。       有关使用行的更多信息，请参阅 [表](working-with-the-data-editor.html)。     |
|     ![删除行图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.general.remove.svg)     |     删除行    `Ctrl+Y` (Windows), `⌘ ⌫` (macOS), `⌘ Y` (IntelliJ IDEA Classic (macOS)), `⌘ ⌫` (macOS System Shortcuts), `Ctrl+Y` (XWin), `Ctrl+Y` (GNOME), `Ctrl+Y` (KDE), `Ctrl+Y` (Emacs), `Ctrl+Shift+K` (Sublime Text), `⌃ ⇧ K` (Sublime Text (macOS)), `Ctrl+L` (Visual Studio), `⌘ ⇧ L` (Visual Studio (macOS)), `Ctrl+E` (NetBeans), `Ctrl+D` (Eclipse), `⌘ D` (Eclipse (macOS))  |     删除所选的一行或多行。       要选择多行，请点击装订区域中的编号。 此外，您也可以按 `Ctrl` (Windows), `Ctrl` (macOS), `Ctrl` (IntelliJ IDEA Classic (macOS)), `Ctrl` (macOS System Shortcuts), `Ctrl` (XWin), `Ctrl` (GNOME), `Ctrl` (KDE), `Ctrl` (Emacs), `Ctrl` (Sublime Text), `Ctrl` (Sublime Text (macOS)), `Ctrl` (Visual Studio), `Ctrl` (Visual Studio (macOS)), `Ctrl` (NetBeans), `Ctrl` (Eclipse), `Ctrl` (Eclipse (macOS)) 并点击所需的行。     |
|  ![“还原所选项”按钮](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.general.reset.svg)  |     还原所选项​​       `Ctrl+Alt+Z` (Windows), `⌘ ⌥ Z` (macOS), `⌘ ⌥ Z` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ Z` (macOS System Shortcuts), `Ctrl+Alt+Z` (XWin), `Ctrl+Alt+Z` (GNOME), `Ctrl+Alt+Z` (KDE), `Ctrl+Alt+Z` (Emacs), `Ctrl+Alt+Z` (Sublime Text), `⌘ ⌥ Z` (Sublime Text (macOS)), `Ctrl+Alt+Z` (Visual Studio), `⌘ ⌥ Z` (Visual Studio (macOS)), `Ctrl+Alt+Z` (NetBeans), `Ctrl+Alt+Z` (Eclipse), `⌃ ⌥ ⇧ Z` (Eclipse (macOS))     |     还原对单元格值所做的更改。 可以选择不同单元格的作用域，并还原此作用域中的值。       有关还原更改的更多信息，请参阅 [将更改提交到数据库](submitting-and-reverting-changes.html)。     |
|  ![预览待处理更改图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.previewChanges.svg)  |     预览挂起的更改     |     [预览 DML](tables-view-data.html#preview-dml)，查看对表所做的更改。     |
|     ![提交按钮](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.submitDB.svg)     |     提交       `Ctrl+Enter` (Windows), `⌘ ⏎` (macOS), `⌘ ⏎` (IntelliJ IDEA Classic (macOS)), `⌘ ⏎` (macOS System Shortcuts), `Ctrl+Enter` (XWin), `Ctrl+Enter` (GNOME), `Ctrl+Enter` (KDE), `Ctrl+Enter` (Emacs), `Ctrl+Enter` (Sublime Text), `⌘ ⏎` (Sublime Text (macOS)), `Ctrl+Enter` (Visual Studio), `⌘ ⏎` (Visual Studio (macOS)), `Ctrl+Enter` (NetBeans), `Ctrl+Enter` (Eclipse), `⌘ ⏎` (Eclipse (macOS))     |  将本地更改提交到数据库服务器。 有关提交和还原更改的更多信息，请参阅 [将更改提交到数据库](submitting-and-reverting-changes.html)。  |
|     ![事务模式](https://resources.jetbrains.com/help/img/idea/2026.3/buttonTransactionControlDB.png)     |     事务模式       和       事务隔离级别     |     选择数据库事务的 [隔离级别](https://en.wikipedia.org/wiki/Isolation_(database_systems))以及事务的提交方式。        * 自动 ：将本地更改提交到数据库服务器时，当前事务会自动提交。    * 手动 ：提交到数据库服务器的更改会累积在一个事务中，可通过工具栏上的 ![“提交并提交事务”图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.commit.svg) 提交并提交事务 或 ![“回滚”按钮](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.rollback.svg) 回滚 按钮显式提交或回滚该事务。      有关数据库事务模式和隔离的更多信息，请参阅 [将更改提交到数据库](submitting-and-reverting-changes.html)。     |
|     ![“提交并提交事务”图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.commit.svg)     |     提交并提交事务 `Ctrl+Alt+Shift+Enter` (Windows), `⌘ ⌥ ⇧ ⏎` (macOS), `⌘ ⌥ ⇧ ⏎` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ ⇧ ⏎` (macOS System Shortcuts), `Ctrl+Alt+Shift+Enter` (XWin), `Ctrl+Alt+Shift+Enter` (GNOME), `Ctrl+Alt+Shift+Enter` (KDE), `Ctrl+Alt+Shift+Enter` (Emacs), `Ctrl+Alt+Shift+Enter` (Sublime Text), `⌘ ⌥ ⇧ ⏎` (Sublime Text (macOS)), `Ctrl+Alt+Shift+Enter` (Visual Studio), `⌘ ⌥ ⇧ ⏎` (Visual Studio (macOS)), `Ctrl+Alt+Shift+Enter` (NetBeans), `Ctrl+Alt+Shift+Enter` (Eclipse), `⌘ ⌥ ⇧ ⏎` (Eclipse (macOS))     |     （对于   手动   事务模式。）提交并提交当前事务。 此按钮仅适用于手动事务模式。 另请参阅 [事务模式和隔离](submitting-and-reverting-changes.html)。     |
|  ![“回滚”图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.rollback.svg)  |     回滚     |  （适用于   手动   事务模式。）回滚更改。 此按钮仅适用于手动事务模式。 另请参阅 [事务模式和隔离](submitting-and-reverting-changes.html)。  |
|  ![转到 DDL](https://resources.jetbrains.com/help/img/idea/2026.3/db_go_to_ddl.png)  |     转到 DDL     |     在编辑器中打开对象的 DDL。     |
|     ![当前页面查找按钮](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.general.search.svg)     |     在当前页查找       `Ctrl+F` (Windows), `⌘ F` (macOS), `⌘ F` (IntelliJ IDEA Classic (macOS)), `⌘ F` (macOS System Shortcuts), `Ctrl+F` (XWin), `Ctrl+F` (GNOME), `Ctrl+F` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+F` (Sublime Text), `⌘ F` (Sublime Text (macOS)), `Ctrl+F` (Visual Studio), `⌘ F` (Visual Studio (macOS)), `Ctrl+F` (NetBeans), `Ctrl+F` (Eclipse), `Ctrl+F` (Eclipse (macOS))     |     为当前结果页面打开一个搜索字段。     |
|  ![“启用本地筛选器”图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.grid.core.impl.icons.expui.columnFilter.svg)  |  启用本地筛选器  |     为网格中的每一列启用本地筛选器。       有关本地筛选器的更多信息，请参阅 [筛选数据](tables-filter.html#use_the_local_filter) 主题。     |
|  ![“显示记录视图”图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.grid.core.impl.icons.expui.singleRecordView.svg)  |  记录视图  |     在侧面板中查看和编辑某条记录的值。       有关该操作的更多信息，请参阅 [数据视图](tables-view-data.html#single_record_view) 主题。     |
|  SQL  |  显示产生此结果集的查询  |     （对于查询结果集。）在弹出窗口中显示生成当前结果集的查询。 使用弹出工具栏在 查询控制台 中打开查询、将其复制到剪贴板，或在源文件中定位该查询。       适用于在   服务   工具窗口中显示的结果集，或作为编辑器内结果显示的结果集。     |
|  ![“显示地理查看器”图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.nodes.ppWeb.svg)  |  显示地理位置查看器  |     启用图形查看器以探索数据库中的地理空间数据。       有关 Geo 查看器 的更多信息，请参阅 [在 PostgreSQL 中将 Geo 查看器 用于地理数据](null)。     |
|  ![“在编辑器中打开”图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.openNewTab.svg)  |  在编辑器标签页中打开  |     （对于查询结果集。）在单独的 数据编辑器 标签页中打开当前结果集。       适用于在   服务   工具窗口中显示的结果集，或作为编辑器内结果显示的结果集。     |
|  ![显示图表图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.charts.icons.chart.chart.svg)  |  显示图表  |     打开数据可视化。       有关图表的更多信息，请参阅 [可视化数据](tables-view-data.html#visualize_data)。     |
|  ![数据提取器](https://resources.jetbrains.com/help/img/idea/2026.3/DataExtractorButton.png)  |     数据提取器     |     为数据选择输出格式。 有关可用格式列表以及数据提取器的完整信息，请参阅 [数据提取器](data-extractors.html) 主题。       此外，您可以配置以下选项：        * 跳过计算列 ：不包含未在表中物理存储的虚拟列（例如，标识列）。    * 跳过生成列 ：对于 `INSERT` 和 `UPDATE` 语句，在复制或保存数据时不包含自动递增字段。    * 配置 CSV 格式 ：打开 [CSV 格式](data-extractors.html#csv_formats_dialog) 对话框，可在其中管理分隔符分隔值格式（例如，CSV、TSV）。    * Go 到 Scripts 目录 ：打开包含将表格数据转换为不同输出格式的脚本的目录。      有关数据提取器的更多信息，请参阅 [数据提取工具](data-extractors.html) 主题。     |
|     ![导出数据图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.general.download.svg)     |     导出数据     |  将表格数据导出到剪贴板或保存到文件。  |
|     ![复制到数据库图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.general.upload.svg)     |     复制到数据库     |     将数据复制到另一个表、架构或数据库。 选择目标架构（将创建新表）或表（数据将添加到所选表中）。 在打开的对话框中，指定数据映射信息和目标表的设置。     |
|     ![“比较数据”图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.vcs.diff.svg)     |     比较数据     |     将当前表与列表中的表进行比较。       有关比较表的更多信息，请参阅 [比较表格数据](compare-data.html#compare-table-data)。     |
|  ![“管理列”图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.nodes.dataColumn.png)  |  管理列…  |     打开   管理列   弹出窗口以查找列、显示或隐藏列、更改其顺序，以及固定或取消固定列。       图标上的指示器会显示存在隐藏列。     |
|  ![“视图为”图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.general.show.svg)  |  视图方式  |     选择浏览和编辑表格数据的模式。        * 转置 ：一种查看模式，其中行和列被 [互换](tables-view-data.html#transposing_table)。 您可以将此复选框与其他查看模式结合使用。 若要将此模式设为表和视图的默认模式，请按 `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS)) 打开设置，并导航至 `工具 \| 数据库 \| 数据编辑器和查看器` 。 请从 自动转置表格 列表中选择 始终 。 当此选项启用时，查询结果不会被转置。    * 表 ：表格数据的默认查看模式。 表格中的数据存储在垂直列和水平行的交叉单元格中。    * 树 ：一种查看模式，在该模式下数据以键值表的形式显示，且如果键单元包含子节点，则可以展开。 展开的子节点中的数据在键列和值列之间分配。 您可以考虑使用此模式来处理 JSON 和数组数据。    * 文本 ：在此查看模式中，数据将以文本形式显示。 此模式使用数据提取器来表示数据。 例如，如果 逗号分隔值 数据提取器在工具栏上的 数据提取工具 列表中被选中，则数据库对象数据将以 CSV 格式显示。 有关数据提取器的更多信息，请参阅 [数据提取工具](data-extractors.html) 主题。      有关查看数据的更多信息，请参阅 [数据视图](tables-view-data.html)。     |
|     ![显示选项菜单图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.general.settings.svg)     |     显示选项菜单     |       显示选项菜单   列表包括以下选项：        * 显示值编辑器 ：打开单独的编辑器，可在其中编辑存储在单元格中的数据。 有关该编辑器的更多信息，请参阅 [值编辑器](tables-view-data.html#value-editor)。    * 显示汇总视图 ：打开聚合视图，可在其中选择多个单元格的值并获得单个汇总值。 有关该视图的更多信息，请参阅 [聚合视图](tables-view-data.html#aggregate-view)。    * 通过 ORDER BY 排序 ：通过向数据库发送新的 `排序依据` 查询在数据库端排序数据。 客户端排序不会运行任何新查询，只会对当前页面进行排序。 > **Note:** > 服务器端排序仅适用于 [数据库对象数据](#open_database_object_data)，不适用于 [查询结果集](#view_query_result_set)。 > **Tip:** > 如果您想将与数据库的交互保持在最低限度，请不要启用此选项。 例如，当表格较大或与数据库的连接速度较慢时。 如果您想在客户端使用排序，请清除 通过 ORDER BY 排序 复选框。 您可以定义默认的表格排序方法。 要做到这一点，请按 `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS)) 打开设置，然后导航到 `工具 \| 数据库 \| 数据编辑器和查看器` 。 。 在 数据排序 部分，选中或清除 通过 ORDER BY 排序 复选框。 有关排序数据的更多信息，请参阅 [排序数据](tables-sort.html)。    * 显示筛选器 ：显示或隐藏过滤框。    * 粘贴格式设置 ：选择粘贴时如何处理剪贴板中的文本。    * 重置视图 ：如果之前自定义过表视图（例如隐藏列或排序数据），则恢复初始表视图。    * 视图查询 ： [查看生成表的查询](tables-view-data.html#view-the-query-that-generated-the-result-set)。    * 将查询复制到控制台 ：将生成该表的查询复制到 查询控制台。    * 将查询复制到剪贴板 ：将生成该表的查询复制到剪贴板。    * 打开数据视图设置... ：打开设置中的 数据编辑器和查看器 部分，可在其中定义表格数据在 查询控制台s 和数据编辑器中的显示及修改方式。 有关 数据编辑器和查看器 设置部分的更多信息，请参阅 [数据编辑器和查看器](settings-tools-database-data-views.html)。    |

### 上下文菜单

可以在上下文菜单中找到处理单元格的所有基本操作。 要调用上下文菜单，请右键点击要修改的单元格。 下表列出了所有操作。

![数据编辑器中单元格的上下文菜单](https://resources.jetbrains.com/help/img/idea/2026.3/db_cell_context_menu.png)

|  操作  |  快捷键  |  描述  |
| --- | --- | --- |
|     编辑     |  `Enter` (Windows), `⏎` (macOS), `⏎` (IntelliJ IDEA Classic (macOS)), `⏎` (macOS System Shortcuts), `Enter` (XWin), `Enter` (GNOME), `Enter` (KDE), `Enter` (Emacs), `Enter` (Sublime Text), `⏎` (Sublime Text (macOS)), `Enter` (Visual Studio), `⏎` (Visual Studio (macOS)), `Enter` (NetBeans), `Enter` (Eclipse), `⏎` (Eclipse (macOS))  |     编辑所选单元格中的值。 或者，可以双击单元格并开始键入值。   编辑   命令对只读值不可用。        * 要打开自动完成列表，请按 `Ctrl+Space` (Windows), `⌃ Space` (macOS), `⌃ Space` (IntelliJ IDEA Classic (macOS)), `⌃ Space` (macOS System Shortcuts), `Ctrl+Space` (XWin), `Ctrl+Space` (GNOME), `Ctrl+Space` (KDE), `Alt+/` (Emacs), `Ctrl+Space` (Sublime Text), `⌃ Space` (Sublime Text (macOS)), `Ctrl+Space` (Visual Studio), `⌃ Space` (Visual Studio (macOS)), `Ctrl+Space` (NetBeans), `Ctrl+Space` (Eclipse), `⌃ Space` (Eclipse (macOS))。    * 要确认您的更改，请按 `Enter` (Windows), `⏎` (macOS), `⏎` (IntelliJ IDEA Classic (macOS)), `⏎` (macOS System Shortcuts), `Enter` (XWin), `Enter` (GNOME), `Enter` (KDE), `Enter` (Emacs), `Enter` (Sublime Text), `⏎` (Sublime Text (macOS)), `Enter` (Visual Studio), `⏎` (Visual Studio (macOS)), `Enter` (NetBeans), `Enter` (Eclipse), `⏎` (Eclipse (macOS))。    * 要取消编辑，请按 `Escape` (Windows), `⎋` (macOS), `⎋` (IntelliJ IDEA Classic (macOS)), `⎋` (macOS System Shortcuts), `Escape` (XWin), `Escape` (GNOME), `Escape` (KDE), `Escape, Escape` (Emacs), `Escape` (Sublime Text), `⎋` (Sublime Text (macOS)), `Escape` (Visual Studio), `⎋` (Visual Studio (macOS)), `Escape` (NetBeans), `Escape` (Eclipse), `⎋` (Eclipse (macOS))。      有关编辑单元格的更多信息，请参阅 [单元](cells.html)。     |
|  ![“显示记录视图”图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.grid.core.impl.icons.expui.singleRecordView.svg) 显示记录视图  |  |     在侧面板中查看和编辑某条记录的值。       有关该操作的更多信息，请参阅 [数据视图](tables-view-data.html#single_record_view) 主题。     |
|  在值编辑器中打开  |  `Shift+Enter` (Windows), `⇧ ⏎` (macOS), `⇧ ⏎` (IntelliJ IDEA Classic (macOS)), `⇧ ⏎` (macOS System Shortcuts), `Shift+Enter` (XWin), `Shift+Enter` (GNOME), `Shift+Enter` (KDE), `Shift+Enter` (Emacs), `Shift+Enter` (Sublime Text), `⇧ ⏎` (Sublime Text (macOS)), `Shift+Enter` (Visual Studio), `⇧ ⏎` (Visual Studio (macOS)), `Shift+Enter` (NetBeans), `Shift+Enter` (Eclipse), `⇧ ⏎` (Eclipse (macOS))  |     在单独的值编辑器中打开，您可以编辑存储在单元格中的数据。       有关该编辑器的更多信息，请参阅 [值编辑器](tables-view-data.html#value-editor)。     |
|  显示汇总视图  |  |     打开聚合视图，可在其中选择多个单元格的值并获得单个汇总值。       有关该视图的更多信息，请参阅 [聚合视图](null)。     |
|  ![“还原所选项”按钮](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.general.reset.svg) 还原所选  |  `Ctrl+Alt+Z` (Windows), `⌘ ⌥ Z` (macOS), `⌘ ⌥ Z` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ Z` (macOS System Shortcuts), `Ctrl+Alt+Z` (XWin), `Ctrl+Alt+Z` (GNOME), `Ctrl+Alt+Z` (KDE), `Ctrl+Alt+Z` (Emacs), `Ctrl+Alt+Z` (Sublime Text), `⌘ ⌥ Z` (Sublime Text (macOS)), `Ctrl+Alt+Z` (Visual Studio), `⌘ ⌥ Z` (Visual Studio (macOS)), `Ctrl+Alt+Z` (NetBeans), `Ctrl+Alt+Z` (Eclipse), `⌃ ⌥ ⇧ Z` (Eclipse (macOS))  |     还原对单元格值所做的更改。 可以选择不同单元格的作用域，并还原此作用域中的值。       有关还原更改的更多信息，请参阅 [将更改提交到数据库](submitting-and-reverting-changes.html)。     |
|  设置高亮语言  |  |  选择 IDE 用于高亮显示单元格中数据的语言。  |
|  更改显示类型  |  |  选择 IDE 应如何在列中显示二进制数据。 16 字节数据默认显示为 UUID。  |
|  设置为 DEFAULT  |  `Ctrl+Alt+D` (Windows), `⌘ ⌥ D` (macOS), `⌘ ⌥ D` (IntelliJ IDEA Classic (macOS)), `⌃ ⌥ ⇧ D` (macOS System Shortcuts), `Ctrl+Alt+D` (XWin), `Ctrl+Alt+D` (GNOME), `Ctrl+Alt+D` (KDE), `Ctrl+Alt+D` (Emacs), `Ctrl+Alt+D` (Sublime Text), `⌘ ⌥ D` (Sublime Text (macOS)), `Ctrl+Alt+D` (Visual Studio), `⌘ ⌥ D` (Visual Studio (macOS)), `Ctrl+Alt+D` (NetBeans), `Ctrl+Alt+D` (Eclipse), `⌘ ⌥ D` (Eclipse (macOS))  |     将当前单元格值设置为默认值或为该列指定的值。       有关查看或设置默认值的更多信息，请参阅 [管理单元格的默认值和 NULL 值](cells.html#manage-default-values-for-a-cell)。     |
|  NULL  |  `Ctrl+Alt+N` (Windows), `⌘ ⌥ N` (macOS), `⌘ ⌥ N` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ N` (macOS System Shortcuts), `Ctrl+Alt+N` (XWin), `Ctrl+Alt+N` (GNOME), `Ctrl+Alt+N` (KDE), `Ctrl+Alt+N` (Emacs), `Ctrl+Alt+N` (Sublime Text), `⌘ ⌥ N` (Sublime Text (macOS)), `Ctrl+Alt+N` (Visual Studio), `⌘ ⌥ N` (Visual Studio (macOS)), `Ctrl+Alt+N` (NetBeans), `Ctrl+Alt+N` (Eclipse), `⌘ ⌥ N` (Eclipse (macOS))  |     将当前单元格值设置为 NULL。       有关允许 NULL 值的更多信息，请参阅 [管理单元格的默认值和 NULL 值](cells.html#manage-default-values-for-a-cell)。     |
|  生成 UUID  |  |     为所选单元格生成 UUID。     |
|  加载文件…  |  |     将文件加载到字段中。     |
|  保存 LOB…  |  |  对于包含二进制大对象 ( [LOB](http://en.wikipedia.org/wiki/Binary_large_object)) 的单元格。 将单元格内容保存到文件中。  |
|  ![复制图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.general.copy.svg)复制  |  `Ctrl+C` (Windows), `⌘ C` (macOS), `⌘ C` (IntelliJ IDEA Classic (macOS)), `⌘ C` (macOS System Shortcuts), `Ctrl+C` (XWin), `Ctrl+C` (GNOME), `Ctrl+C` (KDE), `Ctrl+Insert` (Emacs), `Ctrl+C` (Sublime Text), `⌘ C` (Sublime Text (macOS)), `Ctrl+C` (Visual Studio), `⌘ C` (Visual Studio (macOS)), `Ctrl+C` (NetBeans), `Ctrl+C` (Eclipse), `⌘ C` (Eclipse (macOS))  |  将选定内容复制到剪贴板。  |
|  更改数据提取程序  |  |  更改 [数据提取器](data-extractors.html)，该数据提取器当前是从工具栏上的   数据提取器   列表中选择的。  |
|  ![“复制聚合结果 (SUM)”图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.general.copy.svg)复制聚合结果（SUM）  |   |     复制一系列单元格的汇总值。 默认情况下，IntelliJ IDEA 会复制  `SUM`  聚合结果。 要更改默认设置，请右键点击状态栏，并确保已选择   聚合器   选项。 点击状态栏上的聚合器微件，并选择要用作默认值的聚合器。     |
|  ![粘贴图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.general.paste.svg)粘贴  |  `Ctrl+V` (Windows), `⌘ V` (macOS), `⌘ V` (IntelliJ IDEA Classic (macOS)), `⌘ V` (macOS System Shortcuts), `Ctrl+V` (XWin), `Ctrl+V` (GNOME), `Ctrl+V` (KDE), `Shift+Insert` (Emacs), `Ctrl+Shift+V` (Sublime Text), `⌘ ⇧ V` (Sublime Text (macOS)), `Ctrl+V` (Visual Studio), `⌘ V` (Visual Studio (macOS)), `Ctrl+V` (NetBeans), `Ctrl+V` (Eclipse), `⌘ V` (Eclipse (macOS))  |  将剪贴板内容粘贴到表中。  |
|  ![](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.add.svg) 添加行  |   |  在表的末尾添加一行。  |
|  ![](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.remove.svg) 删除行  |  `Alt+Delete` (Windows), `Alt+Delete` (macOS), `Alt+Delete` (IntelliJ IDEA Classic (macOS)), `Alt+Delete` (macOS System Shortcuts), `Alt+Delete` (XWin), `Alt+Delete` (GNOME), `Alt+Delete` (KDE), `Alt+Delete` (Emacs), `Alt+Delete` (Sublime Text), `Alt+Delete` (Sublime Text (macOS)), `Alt+Delete` (Visual Studio), `Alt+Delete` (Visual Studio (macOS)), `Alt+Delete` (NetBeans), `Alt+Delete` (Eclipse), `Alt+Delete` (Eclipse (macOS))  |  删除所选行。  |
|  ![](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.copy.svg) 克隆行  |   |  创建所选行的副本，并将该副本添加到表的末尾。  |
|  转到  |  导航栏  |  `Alt+Home` (Windows), `⌘ ↑` (macOS), `⌥ Home` (IntelliJ IDEA Classic (macOS)), `⌘ ⌃ ↑` (macOS System Shortcuts), `Alt+Home` (XWin), `Alt+Home` (GNOME), `Alt+Home` (KDE), `Alt+Home` (Emacs), `Alt+Home` (Sublime Text), `⌥ Home` (Sublime Text (macOS)), `Ctrl+F2` (Visual Studio), `⌘ F2` (Visual Studio (macOS)), `Alt+Home` (NetBeans), `Alt+Home` (Eclipse), `⌘ ⌥ B` (Eclipse (macOS))  |  跳转到导航栏。  |
|  数据库  |  `Alt+Shift+B` (Windows), `⌥ ⇧ B` (macOS), `⌥ ⇧ B` (IntelliJ IDEA Classic (macOS)), `⌥ ⇧ B` (macOS System Shortcuts), `Alt+Shift+B` (XWin), `Alt+Shift+B` (GNOME), `Alt+Shift+B` (KDE), `Alt+Shift+B` (Emacs), `Alt+Shift+B` (Sublime Text), `⌥ ⇧ B` (Sublime Text (macOS)), `Alt+Shift+B` (Visual Studio), `⌥ ⇧ B` (Visual Studio (macOS)), `Alt+Shift+B` (NetBeans), `Alt+Shift+B` (Eclipse), `⌥ ⇧ B` (Eclipse (macOS))  |  在   数据库   工具窗口中打开选定的对象。  |
|  相关符号…  |  `Ctrl+Alt+Home` (Windows), `⌘ ⌃ ↑` (macOS), `⌘ ⌥ Home` (IntelliJ IDEA Classic (macOS)), `⌘ ⌃ ↓` (macOS System Shortcuts), `Ctrl+Alt+Home` (XWin), `Ctrl+Alt+Home` (GNOME), `Ctrl+Alt+Home` (KDE), `Ctrl+Alt+Home` (Emacs), `Ctrl+Alt+Home` (Sublime Text), `Ctrl+Alt+Home` (Sublime Text (macOS)), `Ctrl+Alt+F7` (Visual Studio), `⌘ ⇧ F7` (Visual Studio (macOS)), `Ctrl+Alt+Home` (NetBeans), `Ctrl+Alt+Home` (Eclipse), `⌘ ⌃ ↑` (Eclipse (macOS))  |  导航到某个相关对象。  |
|  DDL  |  `Ctrl+Alt+Home` (Windows), `⌘ ⌃ ↑` (macOS), `⌘ ⌥ Home` (IntelliJ IDEA Classic (macOS)), `⌘ ⌃ ↓` (macOS System Shortcuts), `Ctrl+Alt+Home` (XWin), `Ctrl+Alt+Home` (GNOME), `Ctrl+Alt+Home` (KDE), `Ctrl+Alt+Home` (Emacs), `Ctrl+Alt+Home` (Sublime Text), `Ctrl+Alt+Home` (Sublime Text (macOS)), `Ctrl+Alt+F7` (Visual Studio), `⌘ ⇧ F7` (Visual Studio (macOS)), `Ctrl+Alt+Home` (NetBeans), `Ctrl+Alt+Home` (Eclipse), `⌘ ⌃ ↑` (Eclipse (macOS))  |  打开对象定义 (DDL)。  |
|  行…  |  `Ctrl+G` (Windows), `⌘ L` (macOS), `⌘ G` (IntelliJ IDEA Classic (macOS)), `⌘ L` (macOS System Shortcuts), `Ctrl+G` (XWin), `Ctrl+G` (GNOME), `Ctrl+G` (KDE), `Alt+G` (Emacs), `Ctrl+G` (Sublime Text), `⌃ G` (Sublime Text (macOS)), `Ctrl+G` (Visual Studio), `⌘ G` (Visual Studio (macOS)), `Ctrl+G` (NetBeans), `Ctrl+L` (Eclipse), `⌘ L` (Eclipse (macOS))  |     跳转到指定行。       在   转到行   对话框中，指定列号和行号 (使用  `列:行`  模式)。     |
|  ![相关行图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.goToTable.svg) 相关行  |  `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F4` (NetBeans), `F12` (Eclipse), `F3` (Eclipse (macOS))  |     导航到相关记录：        * 当前记录引用的记录。    * 引用当前记录的记录。      如果有多条记录引用当前记录或被当前记录引用，请在出现的弹出窗口中选择目标记录。       如果没有相关记录，则此操作不可用。       有关相关数据的更多信息，请参阅 [在相关行之间导航](rows.html#navigate-between-related-rows)。       有关操作行为选项的更多信息，请参阅 [高级设置](advanced-settings.html#related_rows_action_behavior)。     |
|  ![“打开 URL”图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.toolwindows.web.svg) 打开 URL  |  `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F4` (NetBeans), `F12` (Eclipse), `F3` (Eclipse (macOS))  |     在操作系统的默认浏览器中打开 URL。       需要在   工具 \| 数据库 \| 数据编辑器和查看器   设置页面 `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS)) 启用链接打开   URL 点击设置  。     |
|  ![打开文件图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.inline.browse.svg) 打开文件  |  `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F4` (NetBeans), `F12` (Eclipse), `F3` (Eclipse (macOS))  |     在操作系统的默认文件浏览器中打开文件 URI。 例如，  `file:///Users/Username/image.png` 。       需要在   工具 \| 数据库 \| 数据编辑器和查看器   设置页面 `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS)) 启用链接打开   URL 点击设置  。     |
|  按筛选器筛选  |  |    > **Note:** > 服务器端过滤仅适用于 [数据库对象数据](#open_database_object_data)，不适用于 [查询结果集](#view_query_result_set)。      选择要应用于列的筛选器。     |
|  ![](https://resources.jetbrains.com/help/img/idea/2026.3/app.actions.search.svg) 文本搜索…  |  `Ctrl+Alt+Shift+F` (Windows), `⌘ ⌥ ⇧ F` (macOS), `⌘ ⌥ ⇧ F` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ ⇧ F` (macOS System Shortcuts), `Ctrl+Alt+Shift+F` (XWin), `Ctrl+Alt+Shift+F` (GNOME), `Ctrl+Alt+Shift+F` (KDE), `Ctrl+Alt+Shift+F` (Emacs), `Ctrl+Alt+Shift+F` (Sublime Text), `⌘ ⌥ ⇧ F` (Sublime Text (macOS)), `Ctrl+Alt+Shift+F` (Visual Studio), `⌘ ⌥ ⇧ F` (Visual Studio (macOS)), `Ctrl+Alt+Shift+F` (NetBeans), `Ctrl+Alt+Shift+F` (Eclipse), `⌘ ⌥ ⇧ F` (Eclipse (macOS))  |     打开一个搜索窗口，可在其中搜索数据库或数据库组中的数据。 有关全文文本搜索的更多信息，请参阅 [数据库中的全文搜索](full-text-search-for-databases.html)。     |
|  ![](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.general.download.svg) 导出表到剪贴板  |  |  将整个表格复制到剪贴板。 此操作不依赖于   页面大小限制为   设置。  |
|  切换会话  |  |  打开一个窗口以选择另一个会话或创建新会话。 有关会话的更多信息，请参阅 [会话](managing-connection-sessions.html)。  |
|  快速文档  |  `Ctrl+Q` (Windows), `F1` (macOS), `⌃ J` (IntelliJ IDEA Classic (macOS)), `⌘ I` (macOS System Shortcuts), `Ctrl+Q` (XWin), `Ctrl+Q` (GNOME), `Ctrl+Q` (KDE), `Ctrl+Q` (Emacs), `Ctrl+Q` (Sublime Text), `Ctrl+Q` (Sublime Text (macOS)), `Ctrl+K, I` (Visual Studio), `⌘ K, I` (Visual Studio (macOS)), `Ctrl+Q` (NetBeans), `Alt+Middle-Click` (Eclipse), `⌥ Middle-Click` (Eclipse (macOS))  |     显示所选对象的信息。 对于不同的数据库对象，快速文档会显示相应的信息。 例如，对于一组单元格，将看到所选内容的摘要。 可以在常规视图或转置视图中预览它，还可以通过外键查看相关记录。     |

## See also

### 概念

[表](working-with-the-data-editor.html) [列](columns.html) [行](rows.html) [单元](cells.html)

### 语言和框架特定指南

[数据库工具和 SQL](relational-databases.html)

### 参考

[数据库工具窗口](database-tool-window.html) [查询控制台参考](query-consoles.html#reference)

