# 使用 Kerberos 和不同操作系统创建 Microsoft SQL 服务器 数据源

> For the complete documentation index, see [llms.txt](https://www.jetbrains.com/zh-cn/help/idea/llms.txt).

Procedure: 启用 数据库工具和 SQL 插件

此功能依赖于 数据库工具和 SQL 插件，该插件默认情况下在 IntelliJ IDEA 中绑定并启用。 如果相关功能不可用，请确保您没有禁用插件。

> **Note:**
> 没有 Ultimate 订阅时，数据库工具和 SQL 的功能支持在 IntelliJ IDEA 中受限。

1. 按 `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS)) 打开设置，然后选择  `插件` 。

2. 找到  数据库工具和 SQL  插件并点击   启用  。

Procedure: 官方文档和软件

* 有关 Microsoft SQL 服务器 的完整信息，请参阅 [官方文档](https://learn.microsoft.com/en-us/sql/sql-server/?view=sql-server-ver15)。

* 要下载 Microsoft SQL 服务器 数据库软件，请参阅 [官方软件下载](https://www.microsoft.com/en-us/sql-server/sql-server-downloads)。

本主题为您提供了如何从 IntelliJ IDEA 创建 Microsoft SQL 服务器 数据源的示例。 它描述了在 [Windows](#windows)、 [macOS](#macos-and-linux) 和 [Linux](#macos-and-linux) 上配置 IntelliJ IDEA 的方法。

请注意，   使用 Windows 域身份验证   复选框仅在 Windows 上可用。 要在 macOS 和 Linux 上配置 Windows 域身份验证，请参阅 [使用 Windows 域身份验证进行连接](#connect-by-using-windows-domain-authentication-macos-and-linux)。

### 必需设置

Microsoft SQL 服务器 在专用端口上接受 TCP/IP 连接。 默认情况下，它是端口  `1433` ，并且会被 Microsoft Windows 防火墙关闭。 通过端口连接时，请确保防火墙不会关闭您使用的端口。

如果已启用 [SQL Server 浏览器](https://docs.microsoft.com/en-us/sql/tools/configuration-manager/sql-server-browser-service?view=sql-server-2017)，也可以使用 Microsoft SQL 服务器 实例名称建立 TCP/IP 连接。

Procedure: 启用和配置 TCP/IP 连接

* 按照 [官方说明](https://learn.microsoft.com/en-us/sql/database-engine/configure-windows/configure-a-server-to-listen-on-a-specific-tcp-port?view=sql-server-ver16#assign-a-tcpip-port-number-to-the-sql-server-database-engine)启用协议、检查并分配端口号。 确认其他正在运行的应用程序未使用同一端口。

Microsoft SQL 服务器 实例的名称为   MSSQL 服务器  。 默认情况下，端口是  `1433` 。

> **Note:**
> 如果更改了任何设置，请重启服务器。 在大多数情况下，重启可以解决连接问题。

## 使用 Kerberos 连接

在使用 Kerberos 身份验证连接到 Microsoft SQL 服务器 数据库之前，请通过在命令提示符或 [终端](terminal-emulator.html) 中运行 Kerberos 命令，确保您拥有身份验证工单。

Procedure:

* 如果您的计算机上有工单缓存文件，并且 `useTicketCache` 设置为 `true` ，请运行 `klist` 命令。 确保缓存项中列出了您的工单。

* 如果您的计算机上未启用工单缓存，请执行以下操作： 1. 运行 `klist` 命令，并确保其中列出了您的工单。 2. 如果您的身份验证工单不在列表中，请使用您的用户名运行 `kinit` 命令，以从服务器获取工单： `kinit sqlsrvkrb` 。 请使用您的用户名，而不是 `sqlsrvkrb` 。 出现提示时，输入您的密码。

有关 Kerberos 工单的更多信息，请参阅 [Kerberos 网站](https://web.mit.edu/kerberos/krb5-devel/doc/user/tkt_mgmt.html)。

Procedure: 创建数据源

要连接到数据库，请创建一个数据源以存储您的连接详细信息。

1. 选择您要创建的数据源。 您可以通过以下方式执行此操作：

* 在主菜单中，前往 `文件 | 新建 | 数据源` 并选择 Microsoft SQL 服务器 。

* 在 数据库 工具窗口中，点击工具栏上的 ![新建图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.add.svg) 新建 。 导航到 数据源 并选择 Microsoft SQL 服务器 。

![创建一个新的数据源](https://resources.jetbrains.com/help/img/idea/2026.3/create_new_data_source.png)

2. 点击   驱动程序  链接并选择您的连接驱动程序。

3. 请检查连接设置区域底部是否有一个   下载缺少的驱动程序文件   链接。 点击此链接下载与数据库交互所需的驱动程序。 如需直接下载链接，请参考 [JetBrains JDBC drivers](https://www.jetbrains.com/zh-cn/datagrip/jdbc-drivers/)页面。

![下载缺失的驱动文件链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_download_missing_drivers_link.png)

下载的 JDBC 驱动程序的位置是 [IntelliJ IDEA 配置目录](directories-used-by-the-ide-to-store-settings-caches-plugins-and-logs.html#config-directory)。

您也可以使用自己的数据库驱动程序，而不是提供的那些。 要了解有关使用驱动程序连接到数据库的更多信息，请参阅 [将用户驱动程序添加到现有连接中](jdbc-drivers.html#configure_a_jdbc_driver_for_an_existing_data_source)。

如果没有   下载缺少的驱动程序文件   链接，则表示您已经拥有所需的驱动程序。

4. 请指定数据库连接详情。 或者，粘贴 JDBC URL 到   URL   字段中。

* 在 主持人 、 实例 和 端口 字段中，指定您的连接详细信息。

* 从 身份验证 列表中选择 Kerberos 。

* 在 用户 和 密码 字段中，输入您的用户凭证。 要使用无密码，请将 密码 字段留空。 要删除曾经输入的密码，请右键点击 密码 字段并选择 设置为空 。 !["设置为空"上下文菜单操作](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_password_set_empty.png)

* 在 数据库 字段中，输入您要连接的数据库名称。

5. 确保可以使用提供的详细信息建立数据库连接。 为此，请点击连接详细信息部分底部的   测试连接   链接。

![测试连接链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_test_connection_link.png)

如果您遇到任何连接问题，请参考 [无法连接到数据库](connectivity-problems.html)页面。

6. （可选）默认情况下，仅默认数据库和架构会被内省并可供使用。 如果您还想使用其他数据库和架构，请在   架构  选项卡中选择它们以进行内省。

![数据源和驱动程序对话框的 Schemas 选项卡](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_schemas_tab.png)

7. 点击   OK   创建数据源。

8. 在   数据库   工具窗口中找到您的新数据源。

* 有关 数据库 工具窗口的更多信息，请参见相应的 [参考主题](database-tool-window.html)。 > **Tip:** > 要在新的数据源节点下查看更多数据库和架构，请点击 第 N 个，共 M 个 按钮并选择您需要的那些。 IntelliJ IDEA 将进行内省并显示它们。 > > > > ![选择数据库和架构以在数据库工具窗口中进行自省和显示](https://resources.jetbrains.com/help/img/idea/2026.3/connection_flow_show_databases_and_schemas.png)

* 有关在 IntelliJ IDEA 中使用数据库对象的更多信息，请参考 [数据库对象](database-objects.html)。

* 要编写并运行查询，请通过点击数据源并按下 `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F4` (NetBeans), `F12` (Eclipse), `F3` (Eclipse (macOS)) 打开默认的 [查询控制台](query-consoles.html)。

* 若要查看和编辑数据库对象的数据，请双击该对象以打开 [数据编辑器和查看器](data-editor-and-viewer.html)。

![使用 Kerberos 连接](https://resources.jetbrains.com/help/img/idea/2026.3/db_connect_by_using_kerberos.png)

## Windows

Procedure: 使用 SQL 服务器 身份验证连接

1. 在   数据库  工具窗口（  `视图 | 工具窗口 |   数据库` ）中，点击   数据源属性},{  图标 ![数据源属性图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.manageDataSources.svg)。 或者，按 `Ctrl+Alt+Shift+S` 。

2. 在   数据源和驱动程序   对话框中，点击   添加   图标 ( !["添加"图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.add.svg))，然后选择   Microsoft SQL 服务器  。

3. 点击   驱动程序   链接，然后选择   Microsoft SQL 服务器 (jTds)  。

4. 请检查连接设置区域底部是否有一个   下载缺少的驱动程序文件   链接。 点击此链接下载与数据库交互所需的驱动程序。 如需直接下载链接，请参考 [JetBrains JDBC drivers](https://www.jetbrains.com/zh-cn/datagrip/jdbc-drivers/)页面。

![下载缺失的驱动文件链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_download_missing_drivers_link.png)

下载的 JDBC 驱动程序的位置是 [IntelliJ IDEA 配置目录](directories-used-by-the-ide-to-store-settings-caches-plugins-and-logs.html#config-directory)。

您也可以使用自己的数据库驱动程序，而不是提供的那些。 要了解有关使用驱动程序连接到数据库的更多信息，请参阅 [将用户驱动程序添加到现有连接中](jdbc-drivers.html#configure_a_jdbc_driver_for_an_existing_data_source)。

如果没有   下载缺少的驱动程序文件   链接，则表示您已经拥有所需的驱动程序。

5. 在   主持人  、   实例   和   端口   字段中，指定您的连接详细信息。 如果服务器名称（例如  `桌面` ）不起作用，请将其替换为服务器 IP 地址。

6. 从   身份验证   列表中选择   用户 & 密码  。

7. 在   用户   和   密码   字段中，指定您的凭据。

8. 确保可以使用提供的详细信息建立数据库连接。 为此，请点击连接详细信息部分底部的   测试连接   链接。

![测试连接链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_test_connection_link.png)

如果您遇到任何连接问题，请参考 [无法连接到数据库](connectivity-problems.html)页面。

9. （可选）默认情况下，仅默认数据库和架构会被内省并可供使用。 如果您还想使用其他数据库和架构，请在   架构  选项卡中选择它们以进行内省。

![数据源和驱动程序对话框的 Schemas 选项卡](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_schemas_tab.png)

10. 点击   OK   创建数据源。

11. 在   数据库   工具窗口中找到您的新数据源。

* 有关 数据库 工具窗口的更多信息，请参见相应的 [参考主题](database-tool-window.html)。 > **Tip:** > 要在新的数据源节点下查看更多数据库和架构，请点击 第 N 个，共 M 个 按钮并选择您需要的那些。 IntelliJ IDEA 将进行内省并显示它们。 > > > > ![选择数据库和架构以在数据库工具窗口中进行自省和显示](https://resources.jetbrains.com/help/img/idea/2026.3/connection_flow_show_databases_and_schemas.png)

* 有关在 IntelliJ IDEA 中使用数据库对象的更多信息，请参考 [数据库对象](database-objects.html)。

* 要编写并运行查询，请通过点击数据源并按下 `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F4` (NetBeans), `F12` (Eclipse), `F3` (Eclipse (macOS)) 打开默认的 [查询控制台](query-consoles.html)。

* 若要查看和编辑数据库对象的数据，请双击该对象以打开 [数据编辑器和查看器](data-editor-and-viewer.html)。

![使用 SQL 服务器 身份验证连接](https://resources.jetbrains.com/help/img/idea/2026.3/db_tutorial_connect_by_using_sql_server_authentication.png)

Procedure: 使用单一登录连接 Microsoft SQL 服务器

如果您在与 Microsoft SQL 服务器 数据库相同的域中运行 IntelliJ IDEA 的 Windows，可以使用单点登录 (SSO)。

1. 在   数据库  工具窗口（  `视图 | 工具窗口 |   数据库` ）中，点击   数据源属性},{  图标 ![数据源属性图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.manageDataSources.svg)。 或者，按 `Ctrl+Alt+Shift+S` 。

2. 在   数据源和驱动程序   对话框中，点击   添加   图标 ( !["添加"图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.add.svg))，然后选择   Microsoft SQL 服务器  。

3. 点击   驱动程序   链接，然后选择   Microsoft SQL 服务器 (jTds)  。

4. 请检查连接设置区域底部是否有一个   下载缺少的驱动程序文件   链接。 点击此链接下载与数据库交互所需的驱动程序。 如需直接下载链接，请参考 [JetBrains JDBC drivers](https://www.jetbrains.com/zh-cn/datagrip/jdbc-drivers/)页面。

![下载缺失的驱动文件链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_download_missing_drivers_link.png)

下载的 JDBC 驱动程序的位置是 [IntelliJ IDEA 配置目录](directories-used-by-the-ide-to-store-settings-caches-plugins-and-logs.html#config-directory)。

您也可以使用自己的数据库驱动程序，而不是提供的那些。 要了解有关使用驱动程序连接到数据库的更多信息，请参阅 [将用户驱动程序添加到现有连接中](jdbc-drivers.html#configure_a_jdbc_driver_for_an_existing_data_source)。

如果没有   下载缺少的驱动程序文件   链接，则表示您已经拥有所需的驱动程序。

5. 在   主持人  、   实例   和   端口   字段中，指定您的连接详细信息。 如果服务器名称（例如  `桌面` ）不起作用，请将其替换为服务器 IP 地址。

6. 从   身份验证   列表中选择   Windows 凭据  （仅限 Windows 的选项）。

7. 确保可以使用提供的详细信息建立数据库连接。 为此，请点击连接详细信息部分底部的   测试连接   链接。

![测试连接链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_test_connection_link.png)

如果您遇到任何连接问题，请参考 [无法连接到数据库](connectivity-problems.html)页面。

8. （可选）默认情况下，仅默认数据库和架构会被内省并可供使用。 如果您还想使用其他数据库和架构，请在   架构  选项卡中选择它们以进行内省。

![数据源和驱动程序对话框的 Schemas 选项卡](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_schemas_tab.png)

9. 点击   OK   创建数据源。

10. 在   数据库   工具窗口中找到您的新数据源。

* 有关 数据库 工具窗口的更多信息，请参见相应的 [参考主题](database-tool-window.html)。 > **Tip:** > 要在新的数据源节点下查看更多数据库和架构，请点击 第 N 个，共 M 个 按钮并选择您需要的那些。 IntelliJ IDEA 将进行内省并显示它们。 > > > > ![选择数据库和架构以在数据库工具窗口中进行自省和显示](https://resources.jetbrains.com/help/img/idea/2026.3/connection_flow_show_databases_and_schemas.png)

* 有关在 IntelliJ IDEA 中使用数据库对象的更多信息，请参考 [数据库对象](database-objects.html)。

* 要编写并运行查询，请通过点击数据源并按下 `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F4` (NetBeans), `F12` (Eclipse), `F3` (Eclipse (macOS)) 打开默认的 [查询控制台](query-consoles.html)。

* 若要查看和编辑数据库对象的数据，请双击该对象以打开 [数据编辑器和查看器](data-editor-and-viewer.html)。

![使用 SQL 服务器 身份验证连接](https://resources.jetbrains.com/help/img/idea/2026.3/db_tutorial_connect_by_using_sso_authentication.png)

Procedure: 使用 Windows 域身份验证进行连接

1. 在   数据库  工具窗口（  `视图 | 工具窗口 |   数据库` ）中，点击   数据源属性},{  图标 ![数据源属性图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.manageDataSources.svg)。 或者，按 `Ctrl+Alt+Shift+S` 。

2. 在   数据源和驱动程序   对话框中，点击   添加   图标 ( !["添加"图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.add.svg))，然后选择   Microsoft SQL 服务器  。

3. 点击   驱动程序   链接，然后选择   Microsoft SQL 服务器 (jTds)  。

4. 请检查连接设置区域底部是否有一个   下载缺少的驱动程序文件   链接。 点击此链接下载与数据库交互所需的驱动程序。 如需直接下载链接，请参考 [JetBrains JDBC drivers](https://www.jetbrains.com/zh-cn/datagrip/jdbc-drivers/)页面。

![下载缺失的驱动文件链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_download_missing_drivers_link.png)

下载的 JDBC 驱动程序的位置是 [IntelliJ IDEA 配置目录](directories-used-by-the-ide-to-store-settings-caches-plugins-and-logs.html#config-directory)。

您也可以使用自己的数据库驱动程序，而不是提供的那些。 要了解有关使用驱动程序连接到数据库的更多信息，请参阅 [将用户驱动程序添加到现有连接中](jdbc-drivers.html#configure_a_jdbc_driver_for_an_existing_data_source)。

如果没有   下载缺少的驱动程序文件   链接，则表示您已经拥有所需的驱动程序。

5. 在   主持人  、   实例   和   端口   字段中，指定您的连接详细信息。 如果服务器名称（例如  `桌面` ）不起作用，请将其替换为服务器 IP 地址。

6. 从   身份验证   列表中选择   域凭据  。

7. 在   域   字段中，指定域（例如  `开发` ）。

8. 在   用户   和   密码   字段中，指定您的域凭据。 在   用户   字段中，输入不带域前缀的域用户（例如，使用  `John.Smith`  而不是  `DOMAIN\John.Smith` ）。

或者，在   常规   选项卡上指定连接字符串。 请参考以下完整连接字符串示例：

```
jdbc:jtds:sqlserver://DESKTOP:1433;domain=DEVELOPMENT;instance=MSSQLSERVER;databaseName=guest;
```

9. 确保可以使用提供的详细信息建立数据库连接。 为此，请点击连接详细信息部分底部的   测试连接   链接。

![测试连接链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_test_connection_link.png)

如果您遇到任何连接问题，请参考 [无法连接到数据库](connectivity-problems.html)页面。

10. （可选）默认情况下，仅默认数据库和架构会被内省并可供使用。 如果您还想使用其他数据库和架构，请在   架构  选项卡中选择它们以进行内省。

![数据源和驱动程序对话框的 Schemas 选项卡](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_schemas_tab.png)

11. 点击   OK   创建数据源。

12. 在   数据库   工具窗口中找到您的新数据源。

* 有关 数据库 工具窗口的更多信息，请参见相应的 [参考主题](database-tool-window.html)。 > **Tip:** > 要在新的数据源节点下查看更多数据库和架构，请点击 第 N 个，共 M 个 按钮并选择您需要的那些。 IntelliJ IDEA 将进行内省并显示它们。 > > > > ![选择数据库和架构以在数据库工具窗口中进行自省和显示](https://resources.jetbrains.com/help/img/idea/2026.3/connection_flow_show_databases_and_schemas.png)

* 有关在 IntelliJ IDEA 中使用数据库对象的更多信息，请参考 [数据库对象](database-objects.html)。

* 要编写并运行查询，请通过点击数据源并按下 `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F4` (NetBeans), `F12` (Eclipse), `F3` (Eclipse (macOS)) 打开默认的 [查询控制台](query-consoles.html)。

* 若要查看和编辑数据库对象的数据，请双击该对象以打开 [数据编辑器和查看器](data-editor-and-viewer.html)。

![使用 SQL 服务器 身份验证连接](https://resources.jetbrains.com/help/img/idea/2026.3/db_tutorial_connect_by_using_windows_domain_authentication.png)

## macOS 和 Linux

Procedure: 使用 SQL 服务器 身份验证连接

1. 在   数据库  工具窗口（  `视图 | 工具窗口 |   数据库` ）中，点击   数据源属性},{  图标 ![数据源属性图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.manageDataSources.svg)。 或者，按 `⌘ ;` 。

2. 在   数据源和驱动程序   对话框中，点击   添加   图标 ( !["添加"图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.add.svg))，然后选择   Microsoft SQL 服务器  。

3. 点击   驱动程序   链接，然后选择   Microsoft SQL 服务器 (jTds)  。

4. 请检查连接设置区域底部是否有一个   下载缺少的驱动程序文件   链接。 点击此链接下载与数据库交互所需的驱动程序。 如需直接下载链接，请参考 [JetBrains JDBC drivers](https://www.jetbrains.com/zh-cn/datagrip/jdbc-drivers/)页面。

![下载缺失的驱动文件链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_download_missing_drivers_link.png)

下载的 JDBC 驱动程序的位置是 [IntelliJ IDEA 配置目录](directories-used-by-the-ide-to-store-settings-caches-plugins-and-logs.html#config-directory)。

您也可以使用自己的数据库驱动程序，而不是提供的那些。 要了解有关使用驱动程序连接到数据库的更多信息，请参阅 [将用户驱动程序添加到现有连接中](jdbc-drivers.html#configure_a_jdbc_driver_for_an_existing_data_source)。

如果没有   下载缺少的驱动程序文件   链接，则表示您已经拥有所需的驱动程序。

5. 在   主持人  、   实例   和   端口   字段中，指定您的连接详细信息。 如果服务器名称（例如  `桌面` ）不起作用，请将其替换为服务器 IP 地址。

6. 从   身份验证   列表中选择   用户 & 密码  。

7. 在   用户   和   密码   字段中，指定您的凭据。

8. 确保可以使用提供的详细信息建立数据库连接。 为此，请点击连接详细信息部分底部的   测试连接   链接。

![测试连接链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_test_connection_link.png)

如果您遇到任何连接问题，请参考 [无法连接到数据库](connectivity-problems.html)页面。

9. （可选）默认情况下，只有默认的数据库和模式、项目和数据集、数据库、模式、键空间、名称空间是可反省和可使用的。 如果还想使用其他数据库和架构、项目和数据集、数据库、架构和共享数据库、数据库、架构、键空间、命名空间，请在   架构   选项卡中选择它们以进行内省。

![数据源和驱动程序对话框的 Schemas 选项卡](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_schemas_tab.png)

10. 点击   OK   创建数据源。

11. 在   数据库   工具窗口中找到您的新数据源。

* 有关 数据库 工具窗口的更多信息，请参见相应的 [参考主题](database-tool-window.html)。 > **Tip:** > 若要在新的数据源节点下查看更多数据库和架构、项目和数据集、数据库、架构和共享数据库、数据库、架构、键空间、命名空间，请点击 第 N 个，共 M 个 按钮并选择所需项。 IntelliJ IDEA 将进行内省并显示它们。 > > > > ![选择数据库和架构以在数据库工具窗口中进行自省和显示](https://resources.jetbrains.com/help/img/idea/2026.3/connection_flow_show_databases_and_schemas.png)

* 有关在 IntelliJ IDEA 中使用数据库对象的更多信息，请参考 [数据库对象](database-objects.html)。

* 要编写并运行查询，请通过点击数据源并按下 `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F4` (NetBeans), `F12` (Eclipse), `F3` (Eclipse (macOS)) 打开默认的 [查询控制台](query-consoles.html)。

* 若要查看和编辑数据库对象的数据，请双击该对象以打开 [数据编辑器和查看器](data-editor-and-viewer.html)。

![使用 SQL 服务器 身份验证连接](https://resources.jetbrains.com/help/img/idea/2026.3/db_tutorial_macos_linux_connect_by_using_sql_server_authentication.png)

Procedure: 使用 Windows 域身份验证进行连接

1. 在   数据库  工具窗口（  `视图 | 工具窗口 |   数据库` ）中，点击   数据源属性},{  图标 ![数据源属性图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.manageDataSources.svg)。 或者，按 `⌘ ;` 。

2. 在   数据源和驱动程序   对话框中，点击   添加   图标 ( !["添加"图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.add.svg))，然后选择   Microsoft SQL 服务器  。

3. 点击   驱动程序   链接，然后选择   Microsoft SQL 服务器 (jTds)  。

4. 请检查连接设置区域底部是否有一个   下载缺少的驱动程序文件   链接。 点击此链接下载与数据库交互所需的驱动程序。 如需直接下载链接，请参考 [JetBrains JDBC drivers](https://www.jetbrains.com/zh-cn/datagrip/jdbc-drivers/)页面。

![下载缺失的驱动文件链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_download_missing_drivers_link.png)

下载的 JDBC 驱动程序的位置是 [IntelliJ IDEA 配置目录](directories-used-by-the-ide-to-store-settings-caches-plugins-and-logs.html#config-directory)。

您也可以使用自己的数据库驱动程序，而不是提供的那些。 要了解有关使用驱动程序连接到数据库的更多信息，请参阅 [将用户驱动程序添加到现有连接中](jdbc-drivers.html#configure_a_jdbc_driver_for_an_existing_data_source)。

如果没有   下载缺少的驱动程序文件   链接，则表示您已经拥有所需的驱动程序。

5. 在   主持人  、   实例   和   端口   字段中，指定您的连接详细信息。 如果服务器名称（例如  `桌面` ）不起作用，请将其替换为服务器 IP 地址。

6. 从   身份验证   列表中选择   域凭据  。

7. 在   域   字段中，指定域（例如  `开发` ）。

8. 在   用户   和   密码   字段中，指定您的域凭据。 在   用户   字段中，输入不带域前缀的域用户（例如，使用  `John.Smith`  而不是  `DOMAIN\John.Smith` ）。

或者，在   常规   选项卡上指定连接字符串。 请参考以下完整连接字符串示例：

```
jdbc:jtds:sqlserver://DESKTOP:1433;domain=DEVELOPMENT;instance=MSSQLSERVER;databaseName=guest;
```

9. 确保可以使用提供的详细信息建立数据库连接。 为此，请点击连接详细信息部分底部的   测试连接   链接。

![测试连接链接](https://resources.jetbrains.com/help/img/idea/2026.3/db_test_connection_link.png)

如果您遇到任何连接问题，请参考 [无法连接到数据库](connectivity-problems.html)页面。

10. （可选）默认情况下，只有默认的数据库和模式、项目和数据集、数据库、模式、键空间、名称空间是可反省和可使用的。 如果还想使用其他数据库和架构、项目和数据集、数据库、架构和共享数据库、数据库、架构、键空间、命名空间，请在   架构   选项卡中选择它们以进行内省。

![数据源和驱动程序对话框的 Schemas 选项卡](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_schemas_tab.png)

11. 点击   OK   创建数据源。

12. 在   数据库   工具窗口中找到您的新数据源。

* 有关 数据库 工具窗口的更多信息，请参见相应的 [参考主题](database-tool-window.html)。 > **Tip:** > 若要在新的数据源节点下查看更多数据库和架构、项目和数据集、数据库、架构和共享数据库、数据库、架构、键空间、命名空间，请点击 第 N 个，共 M 个 按钮并选择所需项。 IntelliJ IDEA 将进行内省并显示它们。 > > > > ![选择数据库和架构以在数据库工具窗口中进行自省和显示](https://resources.jetbrains.com/help/img/idea/2026.3/connection_flow_show_databases_and_schemas.png)

* 有关在 IntelliJ IDEA 中使用数据库对象的更多信息，请参考 [数据库对象](database-objects.html)。

* 要编写并运行查询，请通过点击数据源并按下 `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F4` (NetBeans), `F12` (Eclipse), `F3` (Eclipse (macOS)) 打开默认的 [查询控制台](query-consoles.html)。

* 若要查看和编辑数据库对象的数据，请双击该对象以打开 [数据编辑器和查看器](data-editor-and-viewer.html)。

![使用 SQL 服务器 身份验证连接](https://resources.jetbrains.com/help/img/idea/2026.3/db_tutorial_macos_linux_connect_by_using_windows_domain_authentication.png)

## See also

### 参考

[数据源及其元素](database-tool-window.html#icons-for-data-sources-and-their-elements) [数据源和驱动程序对话框](data-sources-and-drivers-dialog.html)

### 工具 Windows

[数据库工具窗口](database-tool-window.html)

## See also

### 外部链接

[Transition from SSMS to IntelliJ IDEA: 10 tips](https://blog.jetbrains.com/datagrip/2021/08/19/transition-from-ssms-to-datagrip-10-tips/)

