# 数据库管理功能术语表

> For the complete documentation index, see [llms.txt](https://www.jetbrains.com/zh-cn/help/idea/llms.txt).

Procedure: 启用 数据库工具和 SQL 插件

此功能依赖于 数据库工具和 SQL 插件，该插件默认情况下在 IntelliJ IDEA 中绑定并启用。 如果相关功能不可用，请确保您没有禁用插件。

> **Note:**
> 没有 Ultimate 订阅时，数据库工具和 SQL 的功能支持在 IntelliJ IDEA 中受限。

1. 按 `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS)) 打开设置，然后选择  `插件` 。

2. 找到  数据库工具和 SQL  插件并点击   启用  。

连接到数据库
: 要连接到数据库，IntelliJ IDEA 需要连接详细信息（例如主机、端口、密码、SSH 配置设置等）。 对于每个数据库，连接详细信息都存储在专用连接配置中 —  [数据源](managing-data-sources.html) 。
:
:
:
: 对于数据源，到数据库的连接是在特殊包装器 –  [会话](managing-connection-sessions.html)  中建立的。 每个会话都是单个连接的包装器，并存储该连接的信息（例如是否处于活动状态、事务控制模式以及其他设置）。
:
:
:
: 在会话中，当您执行需要与数据库交互的操作时，会出现连接。
:
:
:
: 例如，当您在   数据库   工具窗口中双击数据源下的表时，会创建一个新的会话，连接后，它将 [数据编辑器](data-editor-and-viewer.html) 作为其客户端。 IntelliJ IDEA 需要一个活跃连接来从数据库中请求表数据，接收数据，并在数据编辑器中显示它。
:
:
:
: [Video](https://resources.jetbrains.com/help/img/idea/2026.3/connect_session.mp4)
:
: 有关连接到数据库的更多信息，请参阅 [连接到数据库](connecting-to-a-database.html) 主题。

数据源
: 数据源 是一个连接配置。 它存储了用于建立连接到数据库的连接详细信息列表。 例如，主机、端口、数据库名称、驱动程序、SSH 和 SSL 配置设置等。 在数据源设置中，您还可以选择数据库和架构进行  内省 ，并在   数据库  工具窗口中显示，还可以更改连接的驱动程序。
:
:
:
: ![带有连接详细信息的 PostgreSQL 数据库的数据源](https://resources.jetbrains.com/help/img/idea/2026.3/db_connection_details_postgresql_default.png)
:
: 可以在   数据库   工具窗口（  `视图 | 工具窗口 |   数据库` ）中查看已创建的数据源列表并浏览它们。
:
:
:
: ![数据库工具窗口中的数据源](https://resources.jetbrains.com/help/img/idea/2026.3/data_sources_list.png)
:
: 有关为受支持的数据库厂商创建数据源的更多信息，请参阅 [创建数据源](managing-data-sources.html#create_a_data_source)部分。
:
:
:
: 有关管理数据源的更多信息，请参阅 [数据源](managing-data-sources.html)主题。
:
:
:
: 如需了解有关   数据源和驱动程序  对话框的更多信息，请参阅 [数据源和驱动程序对话框](data-sources-and-drivers-dialog.html)主题。

DDL 数据源
: DDL 数据源  是数据库结构的虚拟视图，基于包含数据定义语言语句（DDL 语句）的 SQL 文件。 您可以在编辑器中引用这些文件中定义的所有表、列和其他对象。 还支持图表。
:
:
:
: DDL 数据源可用于维护数据库版本控制。 将 SQL 文件置于 VCS 系统下，并在每次数据库结构更新时重新生成它们。
:
:
:
: 创建后，DDL 数据源可在   数据库   工具窗口（  `视图 | 工具窗口 |   数据库` ）中使用。 您可以在   项目   工具窗口（  `视图 | 工具窗口 |   项目` ）中创建和管理包含语句的 SQL 文件。
:
:
:
: ![在 Database 工具窗口中的 DDL 数据源和在 Project 工具窗口中的 SQL 语句文件](https://resources.jetbrains.com/help/img/idea/2026.3/ddl_data_source_and_files.png)
:
: 有关 DDL 数据源的更多信息，请参阅 [DDL 数据源](ddl-data-sources.html) 主题。

会话
: 每个会话都是单个连接的包装器，并存储该连接的信息（例如是否处于活动状态、事务控制模式以及其他设置）。
:
:
:
: 会话可以拥有  客户端  – 这些文件的查询会使用会话持有的连接发送。 [数据编辑器](data-editor-and-viewer.html) 也可以作为会话的客户端。
:
:
:
: 例如，当您在   数据库   工具窗口中双击表时，一个新的会话会连接到数据库，并将该表作为其客户端附加到会话中。
:
: 您可以在   服务  工具窗口中查看数据源、会话和会话客户端。 会话图标角落的绿点表示已连接的会话。
:
: 有关会话的更多信息，请参阅 [会话](managing-connection-sessions.html)。

数据编辑器和查看器
: 数据编辑器和查看器 ，或  数据编辑器 ，提供了一个用于处理数据的用户界面。 在数据编辑器中，可以对数据进行排序、应用筛选器、添加、编辑和移除，并执行其他相关任务。
:
:
:
: 在 IntelliJ IDEA 中，数据编辑器和查看器允许您处理 [数据库对象数据](null)、 [查询结果集](null)以及 [用户文件数据](null)。
:
:
:
: 数据库对象数据:
:
:
: ![数据编辑器中的数据库对象数据](https://resources.jetbrains.com/help/img/idea/2026.3/data_editor_db_object_data_glossary.png)
:
: 查询结果集：Services 工具窗口:
:
:
: ![结果选项卡中的数据编辑器](https://resources.jetbrains.com/help/img/idea/2026.3/db_data_editor_query_result_tab_glossary.png)
:
: 查询结果集：In-Editor Results:
:
:
: ![编辑器内结果中的数据编辑器](https://resources.jetbrains.com/help/img/idea/2026.3/db_data_editor_query_result_ineditor_glossary.png)
:
: 用户文件数据:
:
:
: ![定界符分隔值文件编辑器中的数据编辑器选项卡](https://resources.jetbrains.com/help/img/idea/2026.3/data_editor_for_dsv_files_data_intro.png)
:
:
: 有关数据编辑器的更多信息，请参考 [数据编辑器和查看器](data-editor-and-viewer.html)。

数据库工具窗口
: 在   数据库   工具窗口中，您可以使用数据库和 DDL [数据源](managing-data-sources.html#data_sources)。 您可以查看和修改数据库中的数据结构，并执行其他相关任务。
:
:
:
: 可用的数据源显示为数据源、架构、表等的树状结构。
:
:
:
: ![数据库工具窗口](https://resources.jetbrains.com/help/img/idea/2026.3/db_database_tool_window.png)
:
: 有关在   数据库   工具窗口中使用数据库对象的更多信息，请参阅 [数据库对象](database-objects.html) 部分。
:
:
:
: 有关   数据库   工具窗口的更多信息，请参阅 [数据库工具窗口](database-tool-window.html) 主题。

内省
: [Introspection](introspection.html) 是加载数据库元数据的过程。 当您执行 Introspection 时，数据源中的结构信息会被检查，以检测表、列、例程及其他具有其属性的数据库对象。
:
:
:
: IntelliJ IDEA 使用此信息在   数据库   工具窗口中显示对象，显示其 DDL，在代码补全时提供建议，以及用于其他代码辅助功能。
:
:
:
: 一旦您启动 Introspection，IntelliJ IDEA 会在状态栏右侧显示 Introspection 进度条。
:
:
:
: ![运行 Introspection 过程](https://resources.jetbrains.com/help/img/idea/2026.3/introspection_run.png)
:
: 默认情况下，仅对选择在   数据库   工具窗口中显示的架构和数据库进行 Introspection。
:
:
:
: 对于某些数据库，支持三个内省级别以减少内省对象的数量。 有关这些级别的更多信息，请参阅 [内省级别](introspection-levels.html) 主题。

查询文件
: 查询文件s  是可在 IDE 中为数据源创建并存储在 IDE 项目中的 SQL 和 JS 文件。 在查询文件s中，可以编写、运行和存储 SQL 语句。 如果选择将其存储在 [当前项目目录](null)中，则 查询文件 会包含在项目上下文中。 可以在数据源下的   查询文件   文件夹中的   数据库   中找到 查询文件s。
:
:
:
: ![查询文件](https://resources.jetbrains.com/help/img/idea/2026.3/query_file_overview.png) 可以在 [创建它](query-files.html#create_a_query_file)时指定 查询文件 的位置。 查询文件 可以存储在当前项目目录、附加到项目的目录或项目外部的目录中。
:
: * 有关 查询文件s 的更多信息，请参阅 [查询文件](query-files.html) 主题。
:
: * 有关 IntelliJ IDEA 中其他类型 SQL 文件的更多信息，请参阅 [文件管理](working-with-files.html) 主题。

查询控制台
: 查询控制台s  是为数据源自动创建的 SQL 和 JS 文件，始终附加到该数据源，并存储在 IDE 项目之外。 可以像在终端中一样，在 查询控制台s 中编写和执行 SQL 语句。 查询控制台s 不包含在项目上下文中。
:
:
:
: ![查询控制台](https://resources.jetbrains.com/help/img/idea/2026.3/db_query_console_overview.png)
:
: 有关在查询控制台s中处理查询结果的更多信息，请参阅 [查询结果](viewing-query-results.html)。
:
:
:
: 创建数据源时，默认会自动创建一个 查询控制台，并将其附加到此数据源。 如有必要，可以为此数据源创建额外的 查询控制台s。
:
:
:
: 默认情况下，查询控制台s 存储在  `Scratches and Consoles | Database Consoles`  内部目录中。
:
:
:
: * 有关查询控制台s的更多信息，请参阅 [查询控制台](query-consoles.html) 主题。
:
: * 有关 IntelliJ IDEA 中其他类型 SQL 文件的更多信息，请参阅 [文件管理](working-with-files.html) 主题。

用户文件
: 用户文件  是存储在您的机器或任何其他您有权访问的地方的文件。 要在 IntelliJ IDEA 中使用它们，请在   项目   工具窗口中访问包含它们的目录。
:
:
:
: 如需了解有关用户文件的详细信息，请参阅 [用户文件](working-with-user-files.html)主题。
:
:
:
: 有关 IntelliJ IDEA 中其他类型 SQL 文件的更多信息，请参阅 [文件管理](working-with-files.html) 主题。

例程
: 在 IntelliJ IDEA 中，  例程  结合了函数和过程。 您可以设置   数据库   工具窗口以单独显示它们，或在单个   例程   节点下显示。
:
:
:
: * 在 例程 节点下组合的过程和函数 ![在 Database 工具窗口中启用例程显示](https://resources.jetbrains.com/help/img/idea/2026.3/routines_database_tool_window.png)
:
: * 在专用节点下单独显示的过程和函数 ![在 Database 工具窗口中禁用例程显示](https://resources.jetbrains.com/help/img/idea/2026.3/routines_database_tool_window_separated.png)
:
:
:
: 有关 数据库工具窗口 及其视图选项的更多信息，请参阅 [数据库工具窗口](database-tool-window.html) 主题和 [视图选项](database-tool-window.html#view_options) 章节。

