llms.txt: machine-readable documentation index. Markdown version of this page is also available.

IntelliJ IDEA 2026.3 Help

JavaScript linter

IntelliJ IDEA 可与 ESLint 及其他最常用的 JavaScript 代码静态分析工具集成,这些工具无需执行代码即可检测问题。

安装并启用后,每次打开 JavaScript 文件时,linter 都会自动激活,报告检测到的错误和警告,并在可能的情况下建议快速修复。

您可以在编辑器以及 问题 工具窗口的 文件 选项卡中查看当前文件中检测到的错误的描述及其快速修复。

所有之前打开的文件中的错误及其快速修复会显示在 项目错误 选项卡的 问题 工具窗口中。 若要打开工具窗口,请点击编辑器右上角的 检查 小组件:

检查小部件

有关详情,请参阅 在编辑器中查看问题并应用快速修复以及 问题工具窗口。

在编辑器中查看问题并应用快速修复

  1. 在编辑器中,将鼠标悬停在高亮显示的问题上。 IntelliJ IDEA 会显示包含问题描述的工具提示。

    JavaScript 代码检查器:错误和警告会被高亮显示,问题的描述会在工具提示中显示。

    为了解决这个问题,请点击 <Linter 名称>:修复“<规则名称>” 或按 Alt+Shift+Enter。

  2. 要解决当前文件中检测到的所有问题,请点击 更多操作… (Alt+Enter ),然后从列表中选择 <Linter name>:修复当前文件。

    JavaScript 静态分析工具:解决问题

    或者,按 Alt+Enter 并从列表中选择相关的建议。

问题工具窗口

对于每个错误,IntelliJ IDEA 显示简要描述和错误发生的行号。 从错误消息中,您可以导航到发生问题的代码,或应用 quick-fix,或在 编辑器预览 窗格中手动修复问题(打开预览按钮)。

  • 要打开 问题 工具窗口,请点击编辑器右上角的 检查 小部件。

    检查小部件

    或者,从主菜单中选择 查看 | 工具窗口 | 问题 或按 Alt+6。

  • 在 文件 选项卡中,查看活动编辑器选项卡中文件内检测到的错误。

    在问题工具窗口中的快速修复
  • 在 项目错误 选项卡中,查看所有之前打开的文件中的错误,错误消息按检测到错误的文件分组。

    您还可以启用 project-wide analysis。 在这种情况下,您项目中检测到的所有问题将显示在此标签页中。

  • 在 检查结果 选项卡中,查看运行一次或多次检查后检测到的问题。

  • 要查看问题的建议快速修复,请选择相应的错误信息,然后从其上下文菜单中选择 显示快速修复 ,或点击工具栏上的 显示快速修复按钮 ,或直接按 Alt+Enter。

    要解决问题,请从列表中选择适当的快速修复。

    "问题"工具窗口:修复一个问题
  • 或者,点击 打开编辑器预览按钮 以打开 编辑器预览 窗格,并在那里手动修复问题,无需离开工具窗口。

    问题工具窗口:在编辑器预览窗格中修复错误
  • 要解决整个文件中检测到的问题,请从上下文菜单中选择 <Linter 名称 >:修复当前文件。

  • 如需导航到发生错误的位置,请双击相应的错误消息,或从其上下文菜单中选择 跳转到源 ,或直接按 F4。

  • 还可以编辑 linter 的设置,在出现问题的语句或整个文件中抑制规则,以及将当前文件从分析中排除。 请参阅 禁用和抑制检查了解详细信息。

    问题工具窗口:上下文菜单
  • 要按错误信息的严重程度进行筛选并自定义排序,请点击 视图选项按钮 ,然后在列表中选择或清除相关项目。

    查看选项:配置问题工具窗口的外观
  • 要复制错误信息,请从其上下文菜单中选择 复制问题描述 或按 Ctrl+C。

2026年 11月 3日