# 快速入门数据库功能

> For the complete documentation index, see [llms.txt](https://www.jetbrains.com/zh-cn/help/idea/llms.txt).

本快速入门指南将向您介绍关键概念，并帮助您迈出使用 IntelliJ IDEA 数据库的第一步。

## 开始之前

Procedure: 启用 数据库工具和 SQL 插件

此功能依赖于 数据库工具和 SQL 插件，该插件默认情况下在 IntelliJ IDEA 中绑定并启用。 如果相关功能不可用，请确保您没有禁用插件。

> **Note:**
> 在未订阅 Ultimate 的情况下，IntelliJ IDEA 中无法使用 数据库工具和 SQL 插件。

1. 按 `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS)) 打开设置，然后选择  `插件` 。

2. 找到  数据库工具和 SQL  插件并点击   启用  。

现在可以为数据库设置连接配置。

##  步骤 1。 创建数据源 

根据数据库供应商（MySQL、PostgreSQL、甲骨文 等），您需要创建相应的  数据源 ，以便使用它连接到数据库。

数据源
: 数据源 是一个连接配置。 它存储了用于建立连接到数据库的连接详细信息列表。 例如，主机、端口、数据库名称、驱动程序、SSH 和 SSL 配置设置等。 在数据源设置中，您还可以选择数据库和架构进行  内省 ，并在   数据库  工具窗口中显示，还可以更改连接的驱动程序。
:
: 在 [数据源](managing-data-sources.html) 中查找有关数据源的更多信息。

在本教程中，您将设置一个演示数据源并连接到一个演示数据库。 为此，您可以使用远程部署的 PostgreSQL 或 MySQL 示例数据库，或者下载并使用 SQLite 示例数据库文件。

> **Note:**
> 本主题讨论的演示数据源也可以在   数据库   工具窗口中作为一键创建的快速操作使用，当项目中尚未存在数据源时可用。

您还可以使用您已设置并运行的其他数据库的连接凭据来设置此演示数据源。 为此并连接到您的数据库，请在本教程中描述的   数据源和驱动程序   对话框的相应字段中输入凭据或其 JDBC URL。

Procedure:

PostgreSQL:

1.  在 IntelliJ IDEA 中，转到   数据库  工具窗口（  `视图 | 工具窗口 |   数据库`  或 `⌘ 1` (Windows), `⌘ 1` (macOS), `⌘ 1` (IntelliJ IDEA Classic (macOS)), `⌘ 1` (macOS System Shortcuts), `⌘ 1` (XWin), `⌘ 1` (GNOME), `⌘ 1` (KDE), `⌘ 1` (Emacs), `⌘ 1` (Sublime Text), `⌘ 1` (Sublime Text (macOS)), `Ctrl+Alt+3` (Visual Studio), `⌘ ⌃ 3` (Visual Studio (macOS)), `⌘ 1` (NetBeans), `⌘ 1` (Eclipse), `⌘ 1` (Eclipse (macOS))）。

2.  请点击 ![新建图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.add.svg)   新建   工具栏。

3.

导航到   数据源  并选择   PostgreSQL  。

![选择 $postgresql% 数据源](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_select_new_data_source_postgresql.png)

IntelliJ IDEA 将打开一个包含新数据源设置的   数据源和驱动程序   对话框。

![新的数据源设置](https://resources.jetbrains.com/help/img/idea/2026.3/db_qsg_select_new_data_source_settings_postgresql.png)

MySQL:

1.  在 IntelliJ IDEA 中，转到   数据库  工具窗口（  `视图 | 工具窗口 |   数据库`  或 `⌘ 1` (Windows), `⌘ 1` (macOS), `⌘ 1` (IntelliJ IDEA Classic (macOS)), `⌘ 1` (macOS System Shortcuts), `⌘ 1` (XWin), `⌘ 1` (GNOME), `⌘ 1` (KDE), `⌘ 1` (Emacs), `⌘ 1` (Sublime Text), `⌘ 1` (Sublime Text (macOS)), `Ctrl+Alt+3` (Visual Studio), `⌘ ⌃ 3` (Visual Studio (macOS)), `⌘ 1` (NetBeans), `⌘ 1` (Eclipse), `⌘ 1` (Eclipse (macOS))）。

2.  请点击 ![新建图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.add.svg)   新建   工具栏。

3.

导航到   数据源  并选择   MySQL  。

![选择 mysql% 数据源](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_select_new_data_source_mysql.png)

IntelliJ IDEA 将打开一个包含新数据源设置的   数据源和驱动程序   对话框。

![新的数据源设置](https://resources.jetbrains.com/help/img/idea/2026.3/db_qsg_select_new_data_source_settings_mysql.png)

SQLite:

1.

通过从 [GitHub 仓库](https://github.com/rmitish/datagrip_demo/blob/main/SQLite_Sakila_DB.sqlite) 下载 SQLite 示例数据库文件，然后将下载的文件复制到剪贴板。

2.

在 IntelliJ IDEA 中，将 SQLite 数据库文件粘贴到 IDE 项目根目录中。

为此，在   项目  工具窗口（  `视图 | 工具窗口 |   项目`  或 `Alt+1` (Windows), `⌘ 1` (macOS), `⌘ 1` (IntelliJ IDEA Classic (macOS)), `⌘ 1` (macOS System Shortcuts), `Alt+1` (XWin), `Alt+1` (GNOME), `Alt+1` (KDE), `Alt+1` (Emacs), `Alt+1` (Sublime Text), `⌘ 1` (Sublime Text (macOS)), `Ctrl+Alt+L` (Visual Studio), `⌘ ⌥ L` (Visual Studio (macOS)), `Ctrl+1` (NetBeans), `Alt+1` (Eclipse), `Alt+1` (Eclipse (macOS))）中，点击任意区域并按下 `Ctrl+V` (Windows), `⌘ V` (macOS), `⌘ V` (IntelliJ IDEA Classic (macOS)), `⌘ V` (macOS System Shortcuts), `Ctrl+V` (XWin), `Ctrl+V` (GNOME), `Ctrl+V` (KDE), `Shift+Insert` (Emacs), `Ctrl+Shift+V` (Sublime Text), `⌘ ⇧ V` (Sublime Text (macOS)), `Ctrl+V` (Visual Studio), `⌘ V` (Visual Studio (macOS)), `Ctrl+V` (NetBeans), `Ctrl+V` (Eclipse), `⌘ V` (Eclipse (macOS))。 在出现的   复制   对话框中，点击   OK  。

![将数据库文件粘贴到项目工具窗口](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_paste_database_file_sqlite.png)

3.  转到   数据库  工具窗口（  `视图 | 工具窗口 |   数据库`  或 `⌘ 1` (Windows), `⌘ 1` (macOS), `⌘ 1` (IntelliJ IDEA Classic (macOS)), `⌘ 1` (macOS System Shortcuts), `⌘ 1` (XWin), `⌘ 1` (GNOME), `⌘ 1` (KDE), `⌘ 1` (Emacs), `⌘ 1` (Sublime Text), `⌘ 1` (Sublime Text (macOS)), `Ctrl+Alt+3` (Visual Studio), `⌘ ⌃ 3` (Visual Studio (macOS)), `⌘ 1` (NetBeans), `⌘ 1` (Eclipse), `⌘ 1` (Eclipse (macOS))）。

4.  请点击 ![新建图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.add.svg)   新建   工具栏。

5.

导航到   数据源  并选择   SQLite  。

![选择 sqlite% 数据源](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_select_new_data_source_sqlite.png)

IntelliJ IDEA 将打开一个包含新数据源设置的   数据源和驱动程序   对话框。

![新的数据源设置](https://resources.jetbrains.com/help/img/idea/2026.3/db_qsg_select_new_data_source_settings_sqlite.png)

然后，使用您的数据库连接设置配置新数据源。

Procedure:

PostgreSQL:

1.

在对话框的   名称   字段中，输入新数据源的名称。 例如，  `Demo DB` 。

2.

如果连接设置区域底部有 ![警告图标](https://resources.jetbrains.com/help/img/idea/2026.3/expui.status.warning.svg)   下载缺少的驱动程序文件   链接，请点击它以下载 JDBC 驱动程序。

![新的数据源设置](https://resources.jetbrains.com/help/img/idea/2026.3/db_qsg_select_new_data_source_download_driver_postgresql.png)

3.

在   主持人   字段中，输入以下服务器地址：

```
postgresql.datagrip-dbs.intellij.net

```

4.

确保   端口  字段包含 PostgreSQL 的默认值：  `5432` 。

5.

在   用户   字段中，输入演示用户名：  `datagrip` 。

6.

在   密码   字段中，输入密码：  `datagrip` 。

7.

在   数据库   字段中，输入数据库名称：  `datagrip` 。

8.

确保可以使用提供的详细信息建立数据库连接。 为此，请点击连接详细信息部分底部的   测试连接   链接。

![成功连接到数据库](https://resources.jetbrains.com/help/img/idea/2026.3/db_test_connection_link_qsg_postgresql.png)

9.

在   架构  选项卡中，确保选择了您将使用的  `datagrip` 数据库。

![在数据源和驱动程序对话框中选择要显示的架构](https://resources.jetbrains.com/help/img/idea/2026.3/db_qsg_select_schema_postgresql.png)

10.

点击   OK   创建数据源。

![在数据源和驱动程序对话框中新数据源的设置](https://resources.jetbrains.com/help/img/idea/2026.3/db_qsg_create_data_source_postgresql.png)

一旦创建了数据源，它将出现在   数据库  工具窗口中。

![数据库资源管理器中的新数据源](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_created_data_source_postgresql.png)

MySQL:

1.

在对话框的   名称   字段中，输入新数据源的名称。 例如，  `Demo DB` 。

2.

如果连接设置区域底部有 ![警告图标](https://resources.jetbrains.com/help/img/idea/2026.3/expui.status.warning.svg)   下载缺少的驱动程序文件   链接，请点击它以下载 JDBC 驱动程序。

![新的数据源设置](https://resources.jetbrains.com/help/img/idea/2026.3/db_qsg_select_new_data_source_download_driver_mysql.png)

3.

在   主持人   字段中，输入以下服务器地址：

```
mysql.datagrip-dbs.intellij.net

```

4.

确保   端口  字段包含 MySQL 的默认值：  `3306` 。

5.

在   用户   字段中，输入演示用户名：  `datagrip` 。

6.

在   密码   字段中，输入密码：  `datagrip` 。

7.

在   数据库   字段中，输入数据库名称：  `datagrip` 。

8.

确保可以使用提供的详细信息建立数据库连接。 为此，请点击连接详细信息部分底部的   测试连接   链接。

![成功连接到数据库](https://resources.jetbrains.com/help/img/idea/2026.3/db_test_connection_link_qsg_mysql.png)

9.

在   架构  选项卡中，确保选择了您将使用的  `datagrip` 数据库。

![在数据源和驱动程序对话框中选择要显示的架构](https://resources.jetbrains.com/help/img/idea/2026.3/db_qsg_select_schema_mysql.png)

10.

点击   OK   创建数据源。

![在数据源和驱动程序对话框中新数据源的设置](https://resources.jetbrains.com/help/img/idea/2026.3/db_qsg_create_data_source_mysql.png)

一旦创建了数据源，它将出现在   数据库  工具窗口中。

![数据库资源管理器中的新数据源](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_created_data_source_mysql.png)

SQLite:

1.

在对话框的   名称   字段中，输入新数据源的名称。 例如，  `Demo DB` 。

2.

如果连接设置区域底部有 ![警告图标](https://resources.jetbrains.com/help/img/idea/2026.3/expui.status.warning.svg)   下载缺少的驱动程序文件   链接，请点击它以下载 JDBC 驱动程序。

![新的数据源设置](https://resources.jetbrains.com/help/img/idea/2026.3/db_qsg_select_new_data_source_download_driver_sqlite.png)

3.

在   文件   字段中，输入项目根目录中数据库文件的路径：  `demo_db.sqlite` 。

或者，点击 ![打开图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.general.ellipsis.svg)   打开   并导航到该文件。

4.

确保可以使用提供的详细信息建立数据库连接。 为此，请点击连接详细信息部分底部的   测试连接   链接。

![成功连接到数据库](https://resources.jetbrains.com/help/img/idea/2026.3/db_test_connection_link_qsg_sqlite.png)

5.

在   架构  选项卡中，确保选择了您将使用的  `main` 数据库。

![在数据源和驱动程序对话框中选择要显示的架构](https://resources.jetbrains.com/help/img/idea/2026.3/db_qsg_select_schema_sqlite.png)

6.

点击   OK   创建数据源。

![在数据源和驱动程序对话框中新数据源的设置](https://resources.jetbrains.com/help/img/idea/2026.3/db_qsg_create_data_source_sqlite.png)

一旦创建了数据源，它将出现在   数据库  工具窗口中。

![数据库资源管理器中的新数据源](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_created_data_source_sqlite.png)

##  步骤 2。 编写并运行 SQL 查询 

使用 数据库工具和 SQL 插件，您可以在附加到数据源的  查询控制台s 中编写 SQL 和 NoSQL 代码。 创建新数据源时，IDE 会为该数据源创建一个  默认 查询控制台 。

查询控制台
: 查询控制台s是 SQL 文件，您可以在其中编写和执行 SQL 语句。 与普通 SQL 文件不同，它们默认附加到您的数据源。
:
:
:
: 有关查询控制台s的更多信息，请参阅 [查询控制台](query-consoles.html) 主题。

在本教程中，我们将在 IntelliJ IDEA 创建并于新数据源创建时打开的默认 查询控制台 中运行简单查询。

Procedure:

PostgreSQL:

> **Tip:**
> 如果关闭了默认 查询控制台，请将其打开。 为此，请在   数据库   工具窗口中选择数据源，点击工具栏上的 ![跳转到查询控制台图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.sqlScript.svg)   跳转到 查询控制台  ，然后从列表中选择 查询控制台。
>
>
>
> ![打开数据源的默认查询控制台](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_open_default_console_postgresql.png)

1.

在默认 查询控制台 中，输入以下 SQL 查询:

```SQL
SELECT * FROM actor;

```

2.

要运行查询，请点击编辑器工具栏上的 ![执行图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.run.run.svg)   执行  。

IntelliJ IDEA 将运行查询并在   服务  工具窗口（  `查看 | 工具窗口 | 服务`  或 `Alt+8` (Windows), `⌘ 8` (macOS), `⌘ 8` (IntelliJ IDEA Classic (macOS)), `⌘ 8` (macOS System Shortcuts), `Alt+8` (XWin), `Alt+8` (GNOME), `Alt+8` (KDE), `Alt+8` (Emacs), `Alt+8` (Sublime Text), `⌘ 8` (Sublime Text (macOS)), `Alt+8` (Visual Studio), `Alt+8` (Visual Studio (macOS)), `Alt+8` (NetBeans), `Alt+8` (Eclipse), `⌘ 8` (Eclipse (macOS))）的数据编辑器选项卡中显示查询结果集供您分析。

此步骤中，查询控制台 工具栏上的   <schema>   下拉列表中未选择任何架构作为当前架构。个别项。测试。個別項？ 不要。 wait no. 但是，查询仍然可以执行，因为 IntelliJ IDEA 将使用数据源的默认架构。

有关如何设置默认架构的更多信息，请参阅 [架构](schemas.html#set_the_default_schema)主题。

[Video](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_write_run_queries_postgresql.mp4)

MySQL:

> **Tip:**
> 如果关闭了默认 查询控制台，请将其打开。 为此，请在   数据库   工具窗口中选择数据源，点击工具栏上的 ![跳转到查询控制台图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.sqlScript.svg)   跳转到 查询控制台  ，然后从列表中选择 查询控制台。
>
>
>
> ![打开数据源的默认查询控制台](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_open_default_console_mysql.png)

1.

在默认 查询控制台 中，输入以下 SQL 查询:

```SQL
SELECT * FROM actor;

```

2.

要运行查询，请点击编辑器工具栏上的 ![执行图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.run.run.svg)   执行  。

IntelliJ IDEA 将运行查询并在   服务  工具窗口（  `查看 | 工具窗口 | 服务`  或 `Alt+8` (Windows), `⌘ 8` (macOS), `⌘ 8` (IntelliJ IDEA Classic (macOS)), `⌘ 8` (macOS System Shortcuts), `Alt+8` (XWin), `Alt+8` (GNOME), `Alt+8` (KDE), `Alt+8` (Emacs), `Alt+8` (Sublime Text), `⌘ 8` (Sublime Text (macOS)), `Alt+8` (Visual Studio), `Alt+8` (Visual Studio (macOS)), `Alt+8` (NetBeans), `Alt+8` (Eclipse), `⌘ 8` (Eclipse (macOS))）的数据编辑器选项卡中显示查询结果集供您分析。

此步骤中，查询控制台 工具栏上的   <schema>   下拉列表中未选择任何架构作为当前架构。个别项。测试。個別項？ 不要。 wait no. 但是，查询仍然可以执行，因为 IntelliJ IDEA 将使用数据源的默认架构。

有关如何设置默认架构的更多信息，请参阅 [架构](schemas.html#set_the_default_schema)主题。

[Video](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_write_run_queries_mysql.mp4)

SQLite:

> **Tip:**
> 如果关闭了默认 查询控制台，请将其打开。 为此，请在   数据库   工具窗口中选择数据源，点击工具栏上的 ![跳转到查询控制台图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.sqlScript.svg)   跳转到 查询控制台  ，然后从列表中选择 查询控制台。
>
>
>
> ![打开数据源的默认查询控制台](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_open_default_console_sqlite.png)

1.

在默认 查询控制台 中，输入以下 SQL 查询:

```SQL
SELECT * FROM actor;

```

2.

要运行查询，请点击编辑器工具栏上的 ![执行图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.run.run.svg)   执行  。

IntelliJ IDEA 将运行查询并在   服务  工具窗口（  `查看 | 工具窗口 | 服务`  或 `Alt+8` (Windows), `⌘ 8` (macOS), `⌘ 8` (IntelliJ IDEA Classic (macOS)), `⌘ 8` (macOS System Shortcuts), `Alt+8` (XWin), `Alt+8` (GNOME), `Alt+8` (KDE), `Alt+8` (Emacs), `Alt+8` (Sublime Text), `⌘ 8` (Sublime Text (macOS)), `Alt+8` (Visual Studio), `Alt+8` (Visual Studio (macOS)), `Alt+8` (NetBeans), `Alt+8` (Eclipse), `⌘ 8` (Eclipse (macOS))）的数据编辑器选项卡中显示查询结果集供您分析。

此步骤中，查询控制台 工具栏上的   <schema>   下拉列表中未选择任何架构作为当前架构。个别项。测试。個別項？ 不要。 wait no. 但是，查询仍然可以执行，因为 IntelliJ IDEA 将使用数据源的默认架构。

有关如何设置默认架构的更多信息，请参阅 [架构](schemas.html#set_the_default_schema)主题。

[Video](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_write_run_queries_sqlite.mp4)

##  步骤 3。 浏览数据库 

现在，您可以在树视图中浏览数据库及其对象，并打开这些对象以查看其数据。 使用 数据库工具和 SQL 插件，您可以在   数据库  工具窗口中执行此操作。

数据库资源管理器
: 数据库  工具窗口是一个工具窗口，它以带有节点的树形显示数据库结构。 您可以创建文件夹并将数据源移动到其中，为数据源分配颜色，筛选数据库对象等。
:
:
:
: 有关工具窗口的更多信息，请参阅 [数据库工具窗口](database-tool-window.html)主题。 有关树形图标的更多信息，请参阅 [数据源及其元素](database-tool-window.html#icons-for-data-sources-and-their-elements)章节。

例如，让我们导航到   actor   表及其列。

Procedure:

PostgreSQL:

1.  在   数据库  工具窗口中，双击   Demo_DB  数据源名称以展开已解析数据库的列表。

2.

然后，双击节点或点击其旁边的 ![展开图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.actions.arrowExpand.svg)箭头图标以展开项目列表：  `datagrip | public | tables | actor | columns` 。

3.  要查看   actor   表数据，请双击其名称。

IntelliJ IDEA 将在数据编辑器选项卡中打开   actor   表。

[Video](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_explore_database_postgresql.mp4)

MySQL:

1.  在   数据库  工具窗口中，双击   Demo_DB  数据源名称以展开已解析架构的列表。

2.

然后，双击节点或点击其旁边的 ![展开图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.actions.arrowExpand.svg)箭头图标以展开项目列表：  `datagrip | tables | actor | columns` 。

3.  要查看   actor   表数据，请双击其名称。

IntelliJ IDEA 将在数据编辑器选项卡中打开   actor   表。

[Video](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_explore_database_mysql.mp4)

SQLite:

1.  在   数据库  工具窗口中，双击   Demo_DB  数据源名称以展开已解析的列表。 架构

2.

然后，双击节点或点击其旁边的 ![展开图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.actions.arrowExpand.svg)箭头图标以展开项目列表：  `main | tables | actor | columns` 。

3.  要查看   actor   表数据，请双击其名称。

IntelliJ IDEA 将在数据编辑器选项卡中打开   actor   表。

[Video](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_explore_database_sqlite.mp4)

##  步骤 4。 查看、排序和筛选数据 

通过 数据库工具和 SQL 插件，您可以在  数据编辑器和查看器  中查看和编辑数据库表和视图的数据。

数据编辑器和查看器
: 数据编辑器和查看器 ，或  数据编辑器 ，提供了一个用于处理数据的用户界面。 在数据编辑器中，可以对数据进行排序、应用筛选器、添加、编辑和移除，并执行其他相关任务。
:
:
:
: 有关数据编辑器的更多信息，请参阅 [数据编辑器和查看器](data-editor-and-viewer.html)主题。

在本教程中，我们将按字母顺序对   名字名称   列的   actor   表进行排序，并筛选   姓氏名称   列以查看以  `JO`  开头的姓氏。

Procedure:

PostgreSQL:

1.

要对数据进行排序，请在数据编辑器选项卡中点击   名字名称   列标题中的箭头图标。 IntelliJ IDEA 将向数据库发送  `排序依据`  查询，并在编辑器中显示其结果。

有关在数据库端和客户端对数据进行排序的更多信息，请参阅 [排序数据](tables-sort.html)主题。

2.

要筛选数据，请在数据编辑器选项卡中，点击 ![筛选图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.filter.svg)   本地过滤器  ，它位于   姓氏名称   列标题中。 在搜索字段中输入  `JO`  并选中   值   复选框，然后点击数据编辑器中的任意区域。

IntelliJ IDEA 将筛选数据并显示结果。

有关在 IDE 中筛选数据的更多信息，请参阅 [使用筛选器筛选数据](tables-filter.html)主题。

[Video](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_filter_sort_data_postgresql.mp4)

MySQL:

1.

要对数据进行排序，请在数据编辑器选项卡中点击   名字名称   列标题中的箭头图标。 IntelliJ IDEA 将向数据库发送  `排序依据`  查询，并在编辑器中显示其结果。

有关在数据库端和客户端对数据进行排序的更多信息，请参阅 [排序数据](tables-sort.html)主题。

2.

要筛选数据，请在数据编辑器选项卡中，点击 ![筛选图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.filter.svg)   本地过滤器  ，它位于   姓氏名称   列标题中。 在搜索字段中输入  `JO`  并选中   值   复选框，然后点击数据编辑器中的任意区域。

IntelliJ IDEA 将筛选数据并显示结果。

有关在 IDE 中筛选数据的更多信息，请参阅 [使用筛选器筛选数据](tables-filter.html)主题。

[Video](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_filter_sort_data_mysql.mp4)

SQLite:

1.

要对数据进行排序，请在数据编辑器选项卡中点击   名字名称   列标题中的箭头图标。 IntelliJ IDEA 将向数据库发送  `排序依据`  查询，并在编辑器中显示其结果。

有关在数据库端和客户端对数据进行排序的更多信息，请参阅 [排序数据](tables-sort.html)主题。

2.

要筛选数据，请在数据编辑器选项卡中，点击 ![筛选图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.filter.svg)   本地过滤器  ，它位于   姓氏名称   列标题中。 在搜索字段中输入  `JO`  并选中   值   复选框，然后点击数据编辑器中的任意区域。

IntelliJ IDEA 将筛选数据并显示结果。

有关在 IDE 中筛选数据的更多信息，请参阅 [使用筛选器筛选数据](tables-filter.html)主题。

[Video](https://resources.jetbrains.com/help/img/idea/2026.3/tutorial_db_filter_sort_data_sqlite.mp4)

## 后续步骤

完成本教程后，您可以创建连接配置并使用其 JDBC URL 连接到数据库，浏览已连接的数据库，在查询控制台s中运行 SQL 查询，并查看查询结果。 此外，您还可以查看、排序和筛选数据库对象数据。

要了解有关 IDE 的更多信息，请参考以下主题和部分：

|     [创建数据源](managing-data-sources.html#create_a_data_source)     |     使用针对各种数据库供应商的说明为您的数据库创建数据源。     |
|  [数据编辑器和查看器](data-editor-and-viewer.html)  |  了解您可以用于查看和管理数据库对象、查询结果集和 DSV 文件数据的功能。  |
|  [查询控制台](query-consoles.html)  |  本主题介绍了 查询控制台 的概念以及如何在 IDE 中使用它。  |
|  [查询结果](viewing-query-results.html)  |  本主题描述了查看查询结果的方法。  |
|  [编写和编辑源代码](working-with-source-code.html)  |  了解可在查询控制台s、SQL 文件和临时文件中使用的代码编辑器功能的说明。  |
|  [导出](export-data.html)  |  了解如何导出数据和数据库对象。  |
|  [数据库图表](creating-diagrams.html)  |  了解如何查看数据库和架构的图表。  |

