# JPA 控制台

> For the complete documentation index, see [llms.txt](https://www.jetbrains.com/zh-cn/help/idea/llms.txt).

JPA 控制台   可让您使用以下语言编写、验证和运行查询：

* [Jakarta Persistence 查询语言](https://jakarta.ee/learn/docs/jakartaee-tutorial/current/persist/persistence-querylanguage/persistence-querylanguage.html) (JPQL)

* [Jakarta Data 查询语言](https://jakarta.ee/specifications/data/1.0/jakarta-data-1.0.html#_jakarta_data_query_language) (JDQL)

* [Hibernate 查询语言](https://docs.hibernate.org/orm/7.1/querylanguage/html_single/#basic-concepts) (HQL)

* [EclipseLink 查询语言](https://eclipse.dev/eclipselink/documentation/4.0/jpa/extensions/jpa-extensions.html#java-persistence-query-language-extensions) (EQL)

> **Note:**
> 如果项目使用 Hibernate [facet](adding-support-for-frameworks-and-technologies.html)，   JPA 控制台   将替换为 [Hibernate 控制台](working-with-the-hibernate-console.html)。

## 前提

* 以下插件已启用： * [Jakarta EE：Persistence (JPA)](https://plugins.jetbrains.com/plugin/20202)（捆绑） * 数据库工具和 SQL（捆绑） 要检查插件是否已启用，请 [打开插件设置](jetbrains://tool/settings?name=Plugins&tool=IU)。

* 项目使用 JDK 8 或更高版本。 [了解如何更改项目的 JDK](sdk.html#set-up-jdk)。

* 构建文件（ `pom.xml` 或 `build.gradle` ）至少包含以下 API 之一： * Jakarta 持久化 [了解如何将 Jakarta Persistence 添加到项目](jakarta-persistence-jpa.html#add-to-existing-project)。 * Hibernate [了解如何将 Hibernate 添加到项目](hibernate.html#add-to-existing-project)。 * EclipseLink * Spring Data JPA

* 项目文件至少包含一个实体类。

* 数据库 工具窗口至少列出一个数据源。 [了解如何创建数据源](managing-data-sources.html#create_a_data_source)。

## 打开控制台

如果想运行代码中不存在的 JPQL、JDQL、HQL 或 EQL 查询，或者希望控制台使用自定义 JVM 选项，请手动打开   JPA 控制台  。

> **Tip:**
> 如果想运行代码中已有的查询，可以 [直接从编辑器运行](#run-queries-in-the-editor)。

Procedure: 使用默认设置打开控制台

1. 打开 [Persistence](persistence-tool-window.html) 工具窗口（  `视图 | 工具窗口 | Persistence` ）。

2. 选择持久性单元。

3. 在工具窗口工具栏中，点击 ![控制台图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.database.icons.expui.consoleRun.svg)   JPA 控制台  。

![Persistence 工具窗口中 JPA 控制台图标的位置](https://resources.jetbrains.com/help/img/idea/2026.3/jpa_console_icon.png)

* 或者按 `Ctrl+Shift+F10` (Windows), `⌘ ⇧ F10` (macOS), `⌘ ⇧ F10` (IntelliJ IDEA Classic (macOS)), `⌘ ⇧ F10` (macOS System Shortcuts), `Ctrl+Shift+F10` (XWin), `Ctrl+Shift+F10` (GNOME), `Ctrl+Shift+F10` (KDE), `Ctrl+Shift+F10` (Emacs), `Ctrl+Shift+F10` (Sublime Text), `⌘ ⇧ F10` (Sublime Text (macOS)), `Ctrl+Shift+F10` (Visual Studio), `⌘ ⇧ F10` (Visual Studio (macOS)), `Ctrl+Shift+F10` (NetBeans), `Ctrl+Shift+F10` (Eclipse), `⌘ ⇧ F10` (Eclipse (macOS))。

JPA 控制台   将在专用工具窗口中打开。 现在可以 [运行查询](#run-queries)。

![JPA 控制台工具窗口](https://resources.jetbrains.com/help/img/idea/2026.3/jpa_console.png)

要了解控制台中图标的含义，请参阅 [参考：JPA 控制台](#jpa-console-reference)。

Procedure: 使用自定义 JVM 选项打开控制台

JPA 控制台   在单独的 Java 进程中运行。 可以通过创建 [运行配置](run-debug-configuration.html)，然后在打开控制台时选择该配置，使用自定义 JVM 选项运行此进程。

1. 打开   运行/调试配置  对话框：

* 在主工具栏，点击 [运行微件](guided-tour-around-the-user-interface.html#toolbar)并选择 编辑配置… 。

* 或者，转到 `运行 | 编辑配置…` 。

2. 在对话框左侧，选择  `![新增配置图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.add.svg) 新增配置 | ![应用程序图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.runConfigurations.application.png) 应用程序` 。

3. 在对话框右侧，选择  `修改选项 | 添加虚拟机选项` 。

4. 在   VM 选项   字段中，指定打开   JPA 控制台   时要传递给 JVM 的选项。

![在运行/调试配置对话框的虚拟机选项字段中填入 -Xmx512m](https://resources.jetbrains.com/help/img/idea/2026.3/run_configuration_vm_options.png)

也可以设置其他 [运行配置设置](run-debug-configuration-java-application.html)，但控制台不需要这些设置。

5. 点击   应用  ，然后   OK  。

6. 打开   持久化   工具窗口 (  `视图 | 工具窗口 | Persistence` )。

7. 选择持久性单元。

8. 在工具窗口的工具栏中，选择  `![JPA 控制台图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.database.icons.expui.consoleRun.svg) JPA 控制台 | ![应用程序图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.runConfigurations.application.svg) <您的配置名称>；` 。

![运行配置工具栏](https://resources.jetbrains.com/help/img/idea/2026.3/jpa_console_run_configuration.png)

> **Note:**
> 如果控制台已在运行，配置将在  `![工具栏 JPA 控制台图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.database.icons.expui.consoleRun.svg) JPA 控制台 | ![二级 JPA 控制台图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.java.ultimate.icons.icons.javaee.newui.jpaFacet.svg) JPA 控制台 | ![应用程序图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.runConfigurations.application.svg) <您的配置名称>；`  下可用。

9. JPA 控制台   将在应用了 JVM 选项的专用工具窗口中打开。 现在可以 [运行查询](#run-queries)。

要了解控制台中图标的含义，请参阅 [参考：JPA 控制台](#jpa-console-reference)。

## 运行查询

可以从控制台本身或从编辑器在   JPA 控制台   中运行查询。

> **Note:**
> 此功能不能用于接受实体作为形参的查询。

JPA 控制台   会针对 [数据库](database-tool-window.html)工具窗口中的数据源运行查询。 如果有多个数据源，IDE 会按以下配置（按此顺序）查找匹配项：正在运行的 [Spring 调试器](spring-debugger.html) 会话、   持久化   工具窗口中的显式赋值，或 [Spring Boot](spring-boot.html) 配置文件中的数据源 URL。 如果 IntelliJ IDEA 无法确定要使用哪个数据源，系统会提示选择一个。

> **Warning:**
> 在   JPA 控制台   中运行查询时，查询会立即执行并提交到数据库。 无法预览更改或将其回滚。 请确保使用能够安全运行查询的数据库。

Procedure: 从 JPA 控制台运行查询

1. [打开 JPA 控制台](#open-jpa-console)。

2. 键入或粘贴查询。

3. 在控制台工具栏中，点击 ![指向右侧的绿色三角形](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.run.run.svg)   执行查询  。

* 或者按 `Ctrl+Enter` (Windows), `⌘ ⏎` (macOS), `⌘ ⏎` (IntelliJ IDEA Classic (macOS)), `⌘ ⏎` (macOS System Shortcuts), `Ctrl+Enter` (XWin), `Ctrl+Enter` (GNOME), `Ctrl+Enter` (KDE), `Ctrl+Enter` (Emacs), `Ctrl+Enter` (Sublime Text), `⌘ ⏎` (Sublime Text (macOS)), `Ctrl+Enter` (Visual Studio), `⌘ ⏎` (Visual Studio (macOS)), `Ctrl+Enter` (NetBeans), `Ctrl+Enter` (Eclipse), `⌘ ⏎` (Eclipse (macOS))。

4. 如果查询接受形参，   参数   对话框将打开。 指定值，然后点击   执行  。

JPA 控制台   将执行查询，并在新选项卡中 [显示其结果](#jpa-console-reference)。

Procedure: 从编辑器运行查询

1. 将文本光标放在编辑器中的查询处。

2. 右键点击查询并选择  `![灰色灯泡图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.platform.ide.expui.codeInsight.intentionBulbGrey.svg) 显示上下文操作 | ![控制台图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.database.icons.expui.consoleRun.svg) 在控制台中运行查询` 。

* 或者，按 `Alt+Enter` (Windows), `⌥ ⏎` (macOS), `⌥ ⏎` (IntelliJ IDEA Classic (macOS)), `⌥ ⏎` (macOS System Shortcuts), `Alt+Enter` (XWin), `Alt+Enter` (GNOME), `Alt+Enter` (KDE), `Alt+Enter` (Emacs), `Alt+Enter` (Sublime Text), `⌥ ⏎` (Sublime Text (macOS)), `Alt+Enter` (Visual Studio), `⌥ ⏎` (Visual Studio (macOS)), `Alt+Enter` (NetBeans), `Ctrl+1` (Eclipse), `⌘ 1` (Eclipse (macOS)) 并选择 ![控制台图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.database.icons.expui.consoleRun.svg) 在控制台中运行查询 。

3. 如果查询接受形参，   参数   对话框将打开。 指定值，然后点击   执行  。

JPA 控制台   会执行查询并 [显示其结果](#jpa-console-reference)。

Procedure: 从装订区域运行 Jakarta Data 查询方法

如果项目使用 [Jakarta Data](jakarta-data.html) 仓库，可以直接从编辑器装订区域运行其查询方法。

> **Note:**
> 支持以下方法类型：
>
>
>
> * 查询 [从方法名称派生](https://jakarta.ee/specifications/data/1.0/jakarta-data-addendum-1.0)的方法
>
> * 带有 `@Query` 注解且定义显式 JPQL 或 JDQL 查询的方法
>
> * 带有 `@Find` 注解的方法

1. 在编辑器中打开 Jakarta Data 仓库。

2. 在装订区域中，点击查询方法旁边的 ![控制台图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.database.icons.expui.consoleRun.svg)   在控制台中运行查询  。

3. 如果查询接受形参，   参数   对话框将打开。 指定值，然后点击   执行  。

JPA 控制台   会执行查询并 [显示其结果](#jpa-console-reference)。

![使用装订区域图标在 JPA 控制台中运行 Jakarta Data 仓库方法并填写形参值](https://resources.jetbrains.com/help/img/idea/2026.3/jakarta_data_run_query_in_jpa_console.gif)

Procedure: 从装订区域运行 Spring Data 查询方法

如果项目使用 [Spring Data 仓库](https://docs.spring.io/spring-data/commons/reference/repositories.html)，可以直接从编辑器装订区域运行其查询方法。

> **Note:**
> 支持以下方法类型：
>
>
>
> * 查询 [从方法名称派生](https://docs.spring.io/spring-data/jpa/reference/repositories/query-methods-details.html#repositories.query-methods.query-creation)的方法
>
> * 带有 `@Query` 注解且定义显式 JPQL 或 SQL 查询的方法
>
> * 带有 `@NativeQuery` 注解且定义显式 SQL 查询的方法
>
> * 其名称引用仓库实体类中声明的 `@NamedQuery` 或 `@NamedNativeQuery` 的方法

1. 在编辑器中打开 Spring Data 仓库。

2. 在装订区域中，点击查询方法旁边的 ![控制台图标](https://resources.jetbrains.com/help/img/idea/2026.3/spring-data.icons.expui.springRepositoryRun.svg)   在控制台中运行查询  。

3. 如果查询接受形参，   参数   对话框将打开。 指定值，然后点击   执行  。

如果查询以 JPQL 编写或从方法名称派生，   JPA 控制台   将执行查询并 [显示其结果](#jpa-console-reference)。

![使用装订区域图标在 JPA 控制台中运行 Spring Data 仓库方法并填写形参值](https://resources.jetbrains.com/help/img/idea/2026.3/spring_data_jpa_run_query_in_jpa_console.gif)

如果查询以原生 SQL 编写，则由特定于数据库的 [查询控制台](query-consoles.html)执行该查询，并由   服务   工具窗口 [显示其结果](services-tool-window.html#db-sessions)。

## 参考：JPA 控制台

![JPA 控制台，其中 JPQL 查询检索具有指定国籍的书籍作者](https://resources.jetbrains.com/help/img/idea/2026.3/jpa-console.png)

JPA 控制台   由以下组件组成：

1.  会话选项卡：保存单个控制台 [会话](managing-connection-sessions.html)并包含其他组件。 该选项卡按持久性单元的名称命名。

2.  查询工具栏：用于执行查询、配置查询执行设置以及管理控制台会话。

3.  ![控制台图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.fileTypes.shell.svg) 控制台选项卡：显示控制台日志，并允许键入查询。 该选项卡按持久性单元的名称命名。

4.  ![数据库表图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.database.icons.expui.table.svg) 结果选项卡：显示单个已执行查询的结果，并允许自定义结果的显示方式。 每次执行查询都会打开一个新选项卡。

### 查询工具栏

![](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.run.run.svg)
: 执行查询   ( `Ctrl+Enter` (Windows), `⌘ ⏎` (macOS), `⌘ ⏎` (IntelliJ IDEA Classic (macOS)), `⌘ ⏎` (macOS System Shortcuts), `Ctrl+Enter` (XWin), `Ctrl+Enter` (GNOME), `Ctrl+Enter` (KDE), `Ctrl+Enter` (Emacs), `Ctrl+Enter` (Sublime Text), `⌘ ⏎` (Sublime Text (macOS)), `Ctrl+Enter` (Visual Studio), `⌘ ⏎` (Visual Studio (macOS)), `Ctrl+Enter` (NetBeans), `Ctrl+Enter` (Eclipse), `⌘ ⏎` (Eclipse (macOS)))
:
:
:
: 运行当前键入的查询。

![设置](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.settings.svg)
: 打开查询执行设置…
:
:
:
: 打开 [查询执行](query-execution.html) 页面（位于   设置   对话框中）。

![参数](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.nodes.parameter.svg)
: 查看参数
:
:
:
: 打开   参数   窗格，查看查询接受的形参并设置其值。

![历史记录](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.history.svg)
: 浏览查询历史   ( `Ctrl+Alt+E` (Windows), `⌘ ⌥ E` (macOS), `⌘ ⌥ E` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ E` (macOS System Shortcuts), `Ctrl+Alt+E` (XWin), `Ctrl+Alt+E` (GNOME), `Ctrl+Alt+E` (KDE), `Ctrl+Alt+E` (Emacs), `Ctrl+Alt+E` (Sublime Text), `⌘ ⌥ E` (Sublime Text (macOS)), `Ctrl+Alt+E` (Visual Studio), `⌘ ⌥ E` (Visual Studio (macOS)), `Ctrl+Alt+E` (NetBeans), `Ctrl+Alt+E` (Eclipse), `⌘ ⌥ E` (Eclipse (macOS)))
:
:
:
: 打开   历史记录   对话框，查看已为此持久性单元运行的所有查询，并可选择将选定的查询复制到控制台。

![恢复布局](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.layout.svg)
: 恢复默认布局
:
:
:
: 恢复原始控制台布局。

![终止进程](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.run.stop.svg)
: 终止进程   ( `Ctrl+F2` (Windows), `⌘ F2` (macOS), `⌘ F2` (IntelliJ IDEA Classic (macOS)), `⌃ ⇧ .` (macOS System Shortcuts), `Ctrl+F2` (XWin), `Ctrl+F2` (GNOME), `Ctrl+2` (KDE), `Ctrl+F2` (Emacs), `Ctrl+F2` (Sublime Text), `Ctrl+F2` (Sublime Text (macOS)), `Shift+F5` (Visual Studio), `⇧ F5` (Visual Studio (macOS)), `Shift+F5` (NetBeans), `Ctrl+F2` (Eclipse), `⌘ F2` (Eclipse (macOS)))
:
:
:
: 断开控制台与数据库的连接，但保持会话选项卡打开。

![关闭](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.close.svg)
: 关闭   ( `Ctrl+Shift+F4` (Windows), `⌃ ⇧ F4` (macOS), `⌘ ⇧ F4` (IntelliJ IDEA Classic (macOS)), `⌃ ⇧ F4` (macOS System Shortcuts), `Ctrl+Shift+F4` (XWin), `Ctrl+Shift+F4` (GNOME), `Ctrl+Shift+4` (KDE), `Ctrl+Shift+F4` (Emacs), `Ctrl+Shift+F4` (Sublime Text), `⌃ ⇧ F4` (Sublime Text (macOS)), `Ctrl+Shift+F4` (Visual Studio), `⌃ ⇧ F4` (Visual Studio (macOS)), `Ctrl+Shift+F4` (NetBeans), `Ctrl+W` (Eclipse), `⌘ W` (Eclipse (macOS)))
:
:
:
: 断开控制台与数据库的连接，并关闭当前打开的会话选项卡。

### Console（控制台）选项卡页

![已包装文本图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.platform.ide.expui.general.softWrap.svg)
: 自动换行
:
:
:
: 在控制台日志中对长行自动换行。

![向下滚动文本图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.platform.ide.expui.general.scrollDown.svg)
: 滚动到末尾
:
:
:
: 跳转到控制台日志底部。

![打印机图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.platform.ide.expui.general.print.svg)
: 打印…
:
:
:
: 打开 [打印](print.html)对话框。

![垃圾桶图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.platform.ide.expui.general.delete.svg)
: 全部清除
:
:
:
: 清除控制台日志。

### 结果选项卡

![表图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.platform.ide.expui.nodes.dataTables.svg)
: 切换到表
:
:
:
: 以数据库表的形式查看结果。
:
:
:
: 有关更多信息，请参阅 [探索值](tables-view-data.html#explore-values)。

![图表图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.charts.icons.chart.chart.svg)
: 切换到图表
:
:
:
: 以图表形式查看结果。
:
:
:
: 有关更多信息，请参阅 [可视化数据](tables-view-data.html#visualize_data)。

![刷新图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.platform.ide.expui.general.refresh.svg)
: 重新加载页面   ( `Ctrl+F5` (Windows), `⌘ R` (macOS), `⌃ F5` (IntelliJ IDEA Classic (macOS)), `⌘ R` (macOS System Shortcuts), `Ctrl+F5` (XWin), `Ctrl+F5` (GNOME), `Ctrl+5` (KDE), `Ctrl+F5` (Emacs), `Ctrl+F5` (Sublime Text), `⌘ R` (Sublime Text (macOS)), `Ctrl+Alt+R` (Visual Studio), `⌘ ⌥ R` (Visual Studio (macOS)), `Ctrl+F5` (NetBeans), `Ctrl+F5` (Eclipse), `Ctrl+F5` (Eclipse (macOS)))
:
:
:
: 重新加载数据。

![时钟图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.platform.ide.expui.general.history.svg)
: 表结果自动刷新
:
:
:
: 选择数据自动刷新的频率。

![固定图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.platform.ide.expui.general.pin.svg)
: 固定选项卡
:
:
:
: 固定当前打开的结果选项卡。

![放大镜图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.platform.ide.expui.general.search.svg)
: 在当前页查找
:
:
:
: 在当前显示的页面上搜索特定值的数据。

![筛选器图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.grid.core.impl.icons.expui.columnFilter.svg)
: 表结果本地筛选器
:
:
:
: 为所有列启用筛选或清除所有筛选器。
:
:
:
: 有关更多信息，请参阅 [使用本地过滤器](tables-filter.html#use_the_local_filter)。

![单条记录图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.grid.core.impl.icons.expui.singleRecordView.svg)
: 记录视图
:
:
:
: 打开侧边窗格以查看所选记录中的数据。
:
:
:
: 有关更多信息，请参阅 [单记录视图](tables-view-data.html#single_record_view)。

![单条记录图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.grid.core.impl.icons.expui.tableHeatmap.svg)
: 表着色选项
:
:
:
: 配置表单元格的颜色映射。
:
:
:
: 有关更多信息，请参阅 [应用热力图](tables-view-data.html#apply_a_heatmap)。

![Web 图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.platform.ide.expui.nodes.ppWeb.svg)
: 显示地理位置查看器
:
:
:
: 打开交互式地图，以查看结果中的地理坐标。
:
:
:
: > **Note:**
: > 仅当结果包含纬度和经度列时，此图标才可用。
:
:
:
: 有关更多信息，请参阅 [查看地理数据](tables-view-data.html#view_geographical_data)。

![数据提取工具](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.platform.ide.expui.general.chevronDown.svg)
: 数据提取器
:
:
:
: 选择数据的输出格式。
:
:
:
: 有关更多信息，请参阅 [数据提取工具](data-extractors.html)。

![下载图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.platform.ide.expui.general.download.svg)
: 导出数据  （表视图）
:
:
:
: 打开 [导出数据](export-data.html#methods-for-exporting-data)对话框。
:
:
:
: 导出为 PNG  （图表视图）
:
:
:
: 将图表下载为 PNG 图像。

![上传图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.platform.ide.expui.general.upload.svg)
: 导入
:
:
:
: 打开 [导入](import-data.html#import_dialogs)对话框。

![差异图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.platform.ide.expui.vcs.diff.svg)
: 比较数据
:
:
:
: 将此结果与 [查询控制台](query-consoles.html)中的结果进行比较。

![眼睛图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.platform.ide.expui.general.show.svg)
: 视图方式
:
:
:
: 选择数据视图模式。
:
:
:
: 有关更多信息，请参阅 [数据视图模式](tables-view-data.html#data_view_modes)。

![齿轮图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.platform.ide.expui.general.settings.svg)
: 显示选项菜单  （表视图）
:
:
:
: 打开包含以下选项的列表：
:
:
:
: * 显示值编辑器 ：打开 [值编辑器](tables-view-data.html#value-editor)，查看所选单元格中的数据。
:
: * 显示汇总视图 ：打开 [聚合视图](tables-view-data.html#aggregate-view)。
:
: * 管理列… ：显示表中的所有列列表。
:
: * 粘贴格式设置 ：选择如何对从剪贴板粘贴的文本进行格式设置。
:
: * 重置视图 ：恢复初始表布局。
:
: * 视图查询 ：查看生成结果的查询。
:
: * 将查询复制到控制台 ：将查询复制到控制台。
:
: * 将查询复制到剪贴板 ：将查询复制到剪贴板。
:
: * 打开数据视图设置 ：打开 [数据编辑器和查看器设置](settings-tools-database-data-views.html)。
:
: * 打开数据视图外观设置 ：打开 [数据编辑器和查看器外观设置](settings-appearance-and-behavior-data-editor-and-viewer.html)。
:
:
:
: 显示系列设置  （图表视图）
:
:
:
: 打开 [系列设置](tables-view-data.html#configure_a_chart_chunk)窗格以配置图表显示选项。

## 效率提示

Procedure: 从实体的表中检索所有记录

可以通过在其实体类中调用专用操作，快速检索数据库表中的所有记录。 这会在   JPA 控制台  中执行  `SELECT entity FROM <ClassName> entity` 语句。

1. 在编辑器中打开一个实体类。

2. 在装订区域中，选择  `![右下角带有蓝色表格图标的数据库图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.platform.ide.expui.javaee.persistenceEntity.svg) 显示实体操作 | ![控制台图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.database.icons.expui.consoleRun.svg) 在 JPA 控制台中运行查询` 。

* 或者，将文本光标放在类名称处，按 `Alt+Enter` (Windows), `⌥ ⏎` (macOS), `⌥ ⏎` (IntelliJ IDEA Classic (macOS)), `⌥ ⏎` (macOS System Shortcuts), `Alt+Enter` (XWin), `Alt+Enter` (GNOME), `Alt+Enter` (KDE), `Alt+Enter` (Emacs), `Alt+Enter` (Sublime Text), `⌥ ⏎` (Sublime Text (macOS)), `Alt+Enter` (Visual Studio), `⌥ ⏎` (Visual Studio (macOS)), `Alt+Enter` (NetBeans), `Ctrl+1` (Eclipse), `⌘ 1` (Eclipse (macOS))，然后选择 ![控制台图标](https://resources.jetbrains.com/help/img/idea/2026.3/intellij.database.icons.expui.consoleRun.svg) 在 JPA 控制台中运行查询 。

Procedure: 从查询导航到实体类

可以从任何 JPQL、JDQL、HQL 或 EQL 查询快速导航到实体类声明或实体字段声明。 这适用于   JPA 控制台   和编辑器中的查询。

* 按住 `Ctrl` (Windows), `Ctrl` (macOS), `Ctrl` (IntelliJ IDEA Classic (macOS)), `Ctrl` (macOS System Shortcuts), `Ctrl` (XWin), `Ctrl` (GNOME), `Ctrl` (KDE), `Ctrl` (Emacs), `Ctrl` (Sublime Text), `Ctrl` (Sublime Text (macOS)), `Ctrl` (Visual Studio), `Ctrl` (Visual Studio (macOS)), `Ctrl` (NetBeans), `Ctrl` (Eclipse), `Ctrl` (Eclipse (macOS)) 并点击查询中的实体名称或字段名称。

* 将文本光标放在查询中的实体名称或字段名称处，然后按 `Ctrl+B` (Windows), `⌘ B` (macOS), `⌘ B` (IntelliJ IDEA Classic (macOS)), `⌘ B` (macOS System Shortcuts), `Ctrl+B` (XWin), `Ctrl+B` (GNOME), `Ctrl+B` (KDE), `Ctrl+Alt+G` (Emacs), `F12` (Sublime Text), `F12` (Sublime Text (macOS)), `F12` (Visual Studio), `F12` (Visual Studio (macOS)), `Ctrl+B` (NetBeans), `F3` (Eclipse), `F3` (Eclipse (macOS))。

* 将文本光标放在查询中的实体名称或字段名称处。 从主菜单中选择  `导航 | 声明或用法` 。

