# 查询结果

> For the complete documentation index, see [llms.txt](https://www.jetbrains.com/zh-cn/help/idea/llms.txt).

在 IntelliJ IDEA 中，您可以 [在查询控制台s中运行查询](run-a-query.html#run_statements_in_a_query_console)，然后使用 IDE 界面查看并处理结果集数据。

## 显示

通常，运行查询时，会以表格格式收到结果。 IntelliJ IDEA 会在  data editor 中显示结果。

数据编辑器和查看器 ，或  数据编辑器 ，提供了一个用于处理数据的用户界面。 在数据编辑器中，可以对数据进行排序、应用筛选器、添加、编辑和移除，并执行其他相关任务。

默认情况下，IntelliJ IDEA 会 [在

服务

工具窗口的单独选项卡中](#result_tabs)显示带有查询结果的 数据编辑器。 还可以使用 [编辑器内结果功能](#in_editor_results)将结果设置为显示在 查询控制台 中。

查询结果集：Services 工具窗口:

![结果选项卡中的数据编辑器](https://resources.jetbrains.com/help/img/idea/2026.3/db_data_editor_query_result_tab_glossary.png)

查询结果集：In-Editor Results:

![编辑器内结果中的数据编辑器](https://resources.jetbrains.com/help/img/idea/2026.3/db_data_editor_query_result_ineditor_glossary.png)

Procedure: 选择查询输出和结果的显示位置

可以配置 IDE，以便在   数据库输出   工具窗口、编辑器内联位置或   服务   工具窗口中显示输出和结果。

1. 按 `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS)) 打开设置，然后选择  `工具 | 数据库 | 查询执行 | 输出和结果` 。

2. 在   在以下位置显示结果   中，选择位置。

3. 点击   OK  以应用更改。

有关 查询控制台s 和工具窗口的更多信息，请参阅 [查询控制台](query-consoles.html)、 [数据库输出工具窗口](database-output-tool-window.html) 和 [“服务”工具窗口](services-tool-window.html)。

Procedure: 查看、格式化并处理输出

* 有关如何查看结果、更改输出格式并处理其中的数据的更多信息，请参阅 [数据编辑器和查看器](data-editor-and-viewer.html) 部分：

* [查看数据](tables-view-data.html)

* [比较数据](compare-data.html)

* [排序数据](tables-sort.html)

* [使用筛选器筛选数据](tables-filter.html)

* [行](rows.html)

* [单元](cells.html)

### Services 工具窗口中的结果选项卡

默认情况下，包含结果的数据编辑器会显示在   服务   的   结果   选项卡中。

Procedure: 运行查询并在 Services 工具窗口中查看结果

1. 在 查询控制台 中，输入或粘贴要运行的查询。

2. 请点击 ![“执行”按钮](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.run.run.svg)   执行   工具栏。 或者，按 `Ctrl+Enter` (Windows), `⌘ ⏎` (macOS), `⌘ ⏎` (IntelliJ IDEA Classic (macOS)), `⌘ ⏎` (macOS System Shortcuts), `Ctrl+Enter` (XWin), `Ctrl+Enter` (GNOME), `Ctrl+Enter` (KDE), `Ctrl+Enter` (Emacs), `Ctrl+Enter` (Sublime Text), `⌘ ⏎` (Sublime Text (macOS)), `Ctrl+Enter` (Visual Studio), `⌘ ⏎` (Visual Studio (macOS)), `Ctrl+Enter` (NetBeans), `Ctrl+Enter` (Eclipse), `⌘ ⏎` (Eclipse (macOS))。

IntelliJ IDEA 会在   服务   工具窗口选项卡中显示查询结果集。

[Video](https://resources.jetbrains.com/help/img/idea/2026.3/db_query_results_in_services_tool_window.mp4)

Procedure: 为每个新查询打开一个新标签页

默认情况下，IntelliJ IDEA 每次在您运行新查询后都会使用结果更新同一个选项卡。 您可以更改此行为，并在每次运行新查询时创建一个选项卡。

1. 在 IDE 设置 `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS))中，转到  `工具 | 数据库 | 查询执行` 。

2. 选中   在新选项卡中打开结果   复选框并点击   OK  。

[Video](https://resources.jetbrains.com/help/img/idea/2026.3/db_open_new_tab_for_each_new_query.mp4)

Procedure: 使用自定义标题显示结果标签

您可以在查询前的注释部分定义一个标签标题。 在   将文本作为标题处理后   字段中，您可以保留符号或字符组合，其后任何文本将被视为标签标题。 默认情况下，不使用任何组合，因此  `--`  或  `/*`  之后的任何文本都会被视为选项卡标题。

1. 通过按下 `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS))打开设置，导航到  `工具 | 数据库 | 查询执行 | 输出和结果` 。

2. 在   将文本作为标题处理后   字段中，为标签标题定义一个组合。

若要禁用此功能，请打开设置 `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS))，导航至  `工具 | 数据库 | 查询执行 | 输出和结果` ，并取消选中   从查询前的注释生成结果标题  复选框。

有关自定义选项卡标题的更多示例，请参考 [Name the result tabs at youtube.com](https://www.youtube.com/watch?v=U5SOD-eeK50&t=795s)。

![使用自定义标题显示结果标签](https://resources.jetbrains.com/help/img/idea/2026.3/db_use_custom_titles_for_result_tabs.png)

Procedure: 将包含查询结果的选项卡固定

如果同一个选项卡用于显示查询结果，并且您得到了想要保留的结果，您可以将选项卡固定到工具窗口。

* 右键点击选项卡页眉并选择   固定选项卡  。

![固定结果选项卡](https://resources.jetbrains.com/help/img/idea/2026.3/db_pin_the_result_tab.png)

### 查询控制台中的 In-Editor Results

您还可以在编辑器中查看查询结果。 要做到这一点，请使用   在编辑器中查看结果   功能。

Procedure:

* 要切换当前文件的   在编辑器中查看结果  功能，请点击工具栏上的 ![编辑器内结果图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.editorOutput.svg)   在编辑器中查看结果  。

* 要在整个 IDE 中切换   在编辑器中查看结果  功能，请按 `Ctrl+Alt+S` (Windows), `⌘ Comma` (macOS), `⌘ Comma` (IntelliJ IDEA Classic (macOS)), `⌘ Comma` (macOS System Shortcuts), `Ctrl+Alt+S` (XWin), `Ctrl+Alt+S` (GNOME), `Ctrl+Alt+S` (KDE), `Ctrl+Alt+S` (Emacs), `Ctrl+Alt+S` (Sublime Text), `⌘ Comma` (Sublime Text (macOS)), `Ctrl+Alt+S` (Visual Studio), `⌘ Comma` (Visual Studio (macOS)), `Ctrl+Alt+S` (NetBeans), `Ctrl+Alt+S` (Eclipse), `⌘ Comma` (Eclipse (macOS))打开设置，然后导航到  `工具 | 数据库 | 查询执行 | 输出与结果 | 输出与结果` 。 在   在以下位置显示结果   中，选择   编辑器  。

已启用:

![在编辑器中启用当前文件的结果](https://resources.jetbrains.com/help/img/idea/2026.3/db_toggle_in_editor_results_on.png)

已禁用:

![禁用当前文件的编辑器内结果](https://resources.jetbrains.com/help/img/idea/2026.3/db_toggle_in_editor_results_off.png)

Procedure: 在编辑器选项卡中打开结果集

可以在单独的编辑器选项卡中打开结果集，以便在主编辑器区域中处理。

1. 在   数据库输出   工具窗口中选择结果集。

2. 在结果工具栏上，点击 ![“在编辑器选项卡中打开”图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.openNewTab.svg)   在编辑器标签页中打开  。

结果集会在编辑器选项卡中打开，类似于数据库表。

[Video](https://resources.jetbrains.com/help/img/idea/2026.3/db_open_query_result_set_in_main_editor_tab.mp4)

对于查询结果集，可以在单独的弹出窗口中查看原始查询。

Procedure: 查看生成结果集的查询

1. 在   数据库输出   工具窗口中选择结果集。

2. 在 数据编辑器 工具栏上，点击   SQL  。

查询   弹出窗口会显示生成所选结果集的查询。

![包含原始查询的对话框](https://resources.jetbrains.com/help/img/idea/2026.3/db_database_output_tw_sql_button_popup.png)

原始查询弹出对话框提供以下操作：

![“复制到剪贴板”图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.general.copy.svg) 复制到剪贴板
: 将查询文本复制到剪贴板。

![“执行查询”图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.consoleRun.svg) 执行查询
: 执行查询。

![“在编辑器中高亮显示”图标](https://resources.jetbrains.com/help/img/idea/2026.3/app-client.expui.general.locate.svg) 在编辑器中高亮显示
: 导航到源文件中的查询，并将文本光标放置在第一行。

## 编辑与探索

Procedure: 在编辑器中查看两个结果集

* 点击工具栏上的 ![编辑器内结果图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.editorOutput.svg)   在编辑器中查看结果  以上下排列查看结果集。

![在编辑器中查看两个结果集](https://resources.jetbrains.com/help/img/idea/2026.3/db_view_two_result_sets_in_the_editor.png)

Procedure: 编辑结果集中的值

1. 在结果集内，点击您要编辑的单元格值。

2. 请指定一个新值然后按 `Enter` (Windows), `⏎` (macOS), `⏎` (IntelliJ IDEA Classic (macOS)), `⏎` (macOS System Shortcuts), `Enter` (XWin), `Enter` (GNOME), `Enter` (KDE), `Enter` (Emacs), `Enter` (Sublime Text), `⏎` (Sublime Text (macOS)), `Enter` (Visual Studio), `⏎` (Visual Studio (macOS)), `Enter` (NetBeans), `Enter` (Eclipse), `⏎` (Eclipse (macOS))。

3. 要提交对数据库的更改，请点击工具栏上的 ![Submit 图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.submitDB.svg)   提交  ，或按 `Ctrl+Enter` (Windows), `⌘ ⏎` (macOS), `⌘ ⏎` (IntelliJ IDEA Classic (macOS)), `⌘ ⏎` (macOS System Shortcuts), `Ctrl+Enter` (XWin), `Ctrl+Enter` (GNOME), `Ctrl+Enter` (KDE), `Ctrl+Enter` (Emacs), `Ctrl+Enter` (Sublime Text), `⌘ ⏎` (Sublime Text (macOS)), `Ctrl+Enter` (Visual Studio), `⌘ ⏎` (Visual Studio (macOS)), `Ctrl+Enter` (NetBeans), `Ctrl+Enter` (Eclipse), `⌘ ⏎` (Eclipse (macOS))。

有关提交数据库更改的完整教程，请参阅 [将更改提交到数据库](submitting-and-reverting-changes.html)主题。

![修改结果集中值](https://resources.jetbrains.com/help/img/idea/2026.3/db_change_data_in_result_set.png)

Procedure: 编辑多表 JOIN 结果

1. 在网格中，双击单元格，或选择该单元格并按 `Enter` (Windows), `⏎` (macOS), `⏎` (IntelliJ IDEA Classic (macOS)), `⏎` (macOS System Shortcuts), `Enter` (XWin), `Enter` (GNOME), `Enter` (KDE), `Enter` (Emacs), `Enter` (Sublime Text), `⏎` (Sublime Text (macOS)), `Enter` (Visual Studio), `⏎` (Visual Studio (macOS)), `Enter` (NetBeans), `Enter` (Eclipse), `⏎` (Eclipse (macOS))

2. 进行更改。

3. 按 `Enter` (Windows), `⏎` (macOS), `⏎` (IntelliJ IDEA Classic (macOS)), `⏎` (macOS System Shortcuts), `Enter` (XWin), `Enter` (GNOME), `Enter` (KDE), `Enter` (Emacs), `Enter` (Sublime Text), `⏎` (Sublime Text (macOS)), `Enter` (Visual Studio), `⏎` (Visual Studio (macOS)), `Enter` (NetBeans), `Enter` (Eclipse), `⏎` (Eclipse (macOS))，或点击任何其他区域。

4. 要提交对数据库的更改，请点击工具栏上的 ![Submit 图标](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.submitDB.svg)   提交  ，或按 `Ctrl+Enter` (Windows), `⌘ ⏎` (macOS), `⌘ ⏎` (IntelliJ IDEA Classic (macOS)), `⌘ ⏎` (macOS System Shortcuts), `Ctrl+Enter` (XWin), `Ctrl+Enter` (GNOME), `Ctrl+Enter` (KDE), `Ctrl+Enter` (Emacs), `Ctrl+Enter` (Sublime Text), `⌘ ⏎` (Sublime Text (macOS)), `Ctrl+Enter` (Visual Studio), `⌘ ⏎` (Visual Studio (macOS)), `Ctrl+Enter` (NetBeans), `Ctrl+Enter` (Eclipse), `⌘ ⏎` (Eclipse (macOS))。

5. 在出现的   DML 预览   对话框中查看生成的脚本。

6. 点击   提交   将更改提交到数据库。

为确保此功能正常工作，每一行都必须有一个可唯一标识它的字段或一组字段。

此功能不支持 SQL  `联合`  运算符、表自联接操作结果、包含计算结果列的结果集（例如  `CONCAT` ）或 NoSQL 数据库。

![包含生成语句的 DML 预览对话框](https://resources.jetbrains.com/help/img/idea/2026.3/db_editable_results_select_with_join_rn.png)

Procedure: 比较两个结果集

1. 运行查询来比较您想要比较的表。

2. 在   服务  工具窗口中，点击 ![与图标比较](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.vcs.diff.svg)   比较数据  ，并选择您想要添加到差异中的结果集。

3. 如果有需要，请在比较对话框中更改   容差   参数的值。   容差   参数定义了两个结果集之间允许的最大差异数量。 例如，如果您希望将两行视为相等，只要它们的数据仅在单个列中有所不同，请在  `1` 字段中输入   容差  。

请参见在 [youtube.com 上比较数据](https://www.youtube.com/watch?v=U5SOD-eeK50&t=834s) 的另一个比较两个结果集的示例。

[Video](https://resources.jetbrains.com/help/img/idea/2026.3/db_result_sets_diff.mp4)

## 输出选项卡

Procedure: 查看查询日志

在   服务   工具窗口的   输出   选项卡上，可以看到用户查询和内部查询的日志。

1. 在   数据库   工具窗口中，右键点击数据源并导航到  `新建 | 查询控制台` ，打开 查询控制台。

或者，选择一个数据源并按下 `F4` (Windows), `⌘ ↓` (macOS), `F4` (IntelliJ IDEA Classic (macOS)), `F4` (macOS System Shortcuts), `F4` (XWin), `F4` (GNOME), `F4` (KDE), `F4` (Emacs), `F4` (Sublime Text), `F4` (Sublime Text (macOS)), `F4` (Visual Studio), `⌘ ↓` (Visual Studio (macOS)), `F4` (NetBeans), `F12` (Eclipse), `F3` (Eclipse (macOS))。

2. 运行查询。

3. 在打开的   服务   工具窗口中，点击   输出   选项卡。

[Video](https://resources.jetbrains.com/help/img/idea/2026.3/db_query_output.mp4)

## 服务工具窗口参考

有关工具窗口控件和选项卡的更多信息，请参阅 [Services 工具窗口](services-tool-window.html#db-sessions)主题。

![“服务”工具窗口中的数据库服务](https://resources.jetbrains.com/help/img/idea/2026.3/db_services_tool_window_database_services.png)

## See also

### 过程

[数据编辑器和查看器](data-editor-and-viewer.html) [表](working-with-the-data-editor.html) [注入的 SQL 语句](running-injected-sql-statements.html)

### 参考

[查询控制台](query-consoles.html#reference) [Data editor and viewer](data-editor-and-viewer.html#reference)

