# 表

> For the complete documentation index, see [llms.txt](https://www.jetbrains.com/zh-cn/help/idea/llms.txt).

数据库表  是一种将数据组织成行和列的结构。 表格中的数据存储在垂直列和水平行的交叉单元格中。 该表具有指定数量的列，但可以有任意数量的行。 使用 IntelliJ IDEA，您可以对表执行数据操作和数据定义操作。

[Video](https://www.youtube.com/v/hEg40WdXsDg)

在 IntelliJ IDEA，您可以在 [数据编辑器](data-editor-and-viewer.html) 中处理表格。 当您在   数据库  工具窗口（  `视图 | 工具窗口 |   数据库` ）中双击一个表时，该表将在数据编辑器的   表   [查看模式](data-editor-and-viewer.html#data_view_modes_list)中打开。

> **Note:**
> 数据库表格数据仅在 Ultimate 订阅中可用。 如果没有订阅，点击两次会打开表 DDL 定义。

表（ ![表](https://resources.jetbrains.com/help/img/idea/2026.3/database-plugin.icons.expui.table.svg)）可以在   数据库  工具窗口中找到。

* 有关其他节点和对象图标的参考信息，请参阅 [数据库工具窗口](database-tool-window.html) 主题中的 [数据源及其元素](database-tool-window.html#icons-for-data-sources-and-their-elements) 章节。

* 关于表列图标，请参阅 [栏目可能的图标组合](database-tool-window.html#possible-icon-combinations-for-columns) 章节。

* 使用 [视图选项](database-tool-window.html#view_options) 菜单中的树对象视图选项隐藏、排序、过滤和分组树对象。

![数据库中的表](https://resources.jetbrains.com/help/img/idea/2026.3/database_object_table.png)

在 IntelliJ IDEA 中，每个表都会在一个单独的选项卡中打开。 以下规则适用于长标签标题：

* 默认情况下， 始终显示数据库对象的限定名称 选项现在已关闭。 如果打开两个同名对象的选项卡，对象的选项卡名称将被限定。 例如，如果您打开两个来自不同 schema 的 `actor` 表格，schema 名称会添加到标签名称中。

* 如果数据源的名称超过 20 个字符，则名称将被截断。

* 如果您只有一个数据源，IntelliJ IDEA 不会在标签名中显示数据源名称。

* 如果限定对象名称超过 36 个符号，则会被截断。

![使用表](https://resources.jetbrains.com/help/img/idea/2026.3/working_with_tables.png)

## 创建

Procedure:

1. 在   数据库   工具窗口中，展开数据源树，直到数据库或架构的节点。

2. 右键点击数据库或架构节点，然后选择  `新建 | 表格` 。

3. 在打开的   创建  对话框中，在   名称  字段中输入您的表名。

4. 指定表设置（列、键、索引、外键、权限）。

5. 在   预览   窗格中，您可以查看和更改生成的 SQL 代码。

6. 点击   OK  以添加您的表。

> **Note:**
> 可用字段和选项取决于 DBMS。 有关更多详细信息，请参阅 DBMS 的官方文档。

![创建新表](https://resources.jetbrains.com/help/img/idea/2026.3/db_create_new_table.png)

## 删除

Procedure:

1. 右键点击表格并选择  `对象操作 | 删除…` 。 或者按 `Delete` (Windows), `⌦` (macOS), `⌦` (IntelliJ IDEA Classic (macOS)), `⌦` (macOS System Shortcuts), `Delete` (XWin), `Delete` (GNOME), `Delete` (KDE), `Delete` (Emacs), `Delete` (Sublime Text), `⌦` (Sublime Text (macOS)), `Delete` (Visual Studio), `⌦` (Visual Studio (macOS)), `Delete` (NetBeans), `Delete` (Eclipse), `⌦` (Eclipse (macOS))。

2. 点击   OK   以保存您的更改并关闭对话框。

有关对话框选项的更多信息，请参阅 [确认删除对话框](confirm-drop-dialog.html)。

![删除表格](https://resources.jetbrains.com/help/img/idea/2026.3/db_confirm_drop_dialog.png)

> **Tip:**
> 如需编写   使用架构名称限定对象   语句并稍后使用，请使用  `DROP`  选项。 如果您计划立即执行  `DROP` 语句，请忽略此选项，因为表已经被识别。

## 修改

Procedure: 修改表格

从 IntelliJ IDEA 2022.1 开始，您可以更改表的特定数据库参数。 IDE 会根据内省期间收到的属性，自动为   修改   对话框生成字段。 例如，在 PostgreSQL 中使用此对话框，可以添加和编辑列检查约束。

1. 在   数据库   工具窗口中，右键点击表并选择   修改表格  。

2. 在   修改   对话框中，指定所需的对象设置。

> **Note:**
> 列设置取决于数据库供应商。 例如，   自动递增   复选框仅适用于 SQLite、MySQL 以及其他允许将其用于整数数据类型主键列的供应商。

3. 点击   OK   保存更改。

![修改表格](https://resources.jetbrains.com/help/img/idea/2026.3/db_modify_table.png)

Procedure: 检查同一系列对象的表格

1. 在   数据库   工具窗口中，右键点击表并选择   修改表格  。

2. 在   修改  对话框中，双击 family 节点。

![“修改”对话框的系列节点中包含相似数据库对象的表](https://resources.jetbrains.com/help/img/idea/2026.3/similar_objects_table_in_family_nodes.png)

Procedure: 启用表格的只读模式

为了在数据编辑器中保护表格不被意外修改，您可以将表格设置为只读。

* 要启用只读模式，请点击编辑器右下角的   点击切换只读属性   图标 ( ![点击以切换只读属性图标](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.locked.svg))。

若要关闭只读模式，请再次点击   点击切换只读属性  图标。

![启用表格的只读模式](https://resources.jetbrains.com/help/img/idea/2026.3/db_enable_read_only_mode_for_table.png)

> **Note:**
> 在数据编辑器中处于只读状态的表，仍可使用 查询控制台s 或在   数据库   工具窗口中进行修改。

### 效率提示

Procedure: 从数据编辑器修改表

在编辑表格数据时，您可以修改表格。

1. 双击表格以在数据编辑器中打开。

2. 按下 `Ctrl+F6` (Windows), `⌘ F6` (macOS), `⌘ F6` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ S` (macOS System Shortcuts), `Ctrl+F6` (XWin), `Ctrl+F6` (GNOME), `Ctrl+6` (KDE), `Ctrl+F6` (Emacs), `Ctrl+F6` (Sublime Text), `Ctrl+F6` (Sublime Text (macOS)), `Ctrl+R, S` (Visual Studio), `⌘ R, S` (Visual Studio (macOS)), `Ctrl+F6` (NetBeans), `Alt+Shift+C` (Eclipse), `⌘ ⌥ C` (Eclipse (macOS))。

3. 修改数据并点击   OK  。

4. 按 `Ctrl+F5` (Windows), `⌘ R` (macOS), `⌃ F5` (IntelliJ IDEA Classic (macOS)), `⌘ R` (macOS System Shortcuts), `Ctrl+F5` (XWin), `Ctrl+F5` (GNOME), `Ctrl+5` (KDE), `Ctrl+F5` (Emacs), `Ctrl+F5` (Sublime Text), `⌘ R` (Sublime Text (macOS)), `Ctrl+Alt+R` (Visual Studio), `⌘ ⌥ R` (Visual Studio (macOS)), `Ctrl+F5` (NetBeans), `Ctrl+F5` (Eclipse), `Ctrl+F5` (Eclipse (macOS)) 重新加载页面。

## 复制

您可以复制当前架构中的表数据或将其复制到另一个架构或数据源。

Procedure: 复制表格数据

* 将表格拖到您要创建副本的节点中。 在   导入 <table_name> 表  对话框中，确保映射正确，然后点击   导入  。

[Video](https://resources.jetbrains.com/help/img/idea/2026.3/create_table_copy_by_dragging.mp4)

* 右键点击表格并选择  `导入/导出 | 复制表到…`  ( `F5` (Windows), `F5` (macOS), `F5` (IntelliJ IDEA Classic (macOS)), `⌘ ⌥ Y` (macOS System Shortcuts), `F5` (XWin), `F5` (GNOME), `F5` (KDE), `F5` (Emacs), `F5` (Sublime Text), `F5` (Sublime Text (macOS)), `F5` (Visual Studio), `F5` (Visual Studio (macOS)), `F5` (NetBeans), `F5` (Eclipse), `F5` (Eclipse (macOS)))。 在   导入 <table_name> 表  对话框中，选择您想要创建副本的模式，确保映射正确，然后点击   导入  。

![使用上下文菜单创建表复制件](https://resources.jetbrains.com/help/img/idea/2026.3/create_table_copy_context_menu.png)

* 在 [数据编辑器](data-editor-and-viewer.html)中，点击   复制到数据库…  图标 ( ![复制到数据库](https://resources.jetbrains.com/help/img/idea/2026.3/app.expui.general.upload.svg))，然后选择您希望复制表的模式。

查看 [youtube.com 上的视频](https://www.youtube.com/watch?v=U5SOD-eeK50&t=1374s) 以观看实时示例。

![使用数据编辑器工具栏创建表副本](https://resources.jetbrains.com/help/img/idea/2026.3/db_create_table_copy_toolbar_copy_to_database.png)

Procedure: 复制表结构

* 您可以使用   SQL Generator   复制表结构。 为此，请在   数据库  工具窗口（  `视图 | 工具窗口 |   数据库` ）中右键点击该表并选择  `SQL 脚本 | SQL 生成器…` 。 或者，按下。

有关   SQL 生成器…   控件的更多信息，请参阅 [生成数据库对象的 DDL 定义](export-data.html#generate-ddl-definitions-for-dat)。

![复制表结构](https://resources.jetbrains.com/help/img/idea/2026.3/copy_table_structure.png)

## 快速文档

[快速文档](viewing-reference-information.html#inline-quick-documentation)（ `Ctrl+Q` (Windows), `F1` (macOS), `⌃ J` (IntelliJ IDEA Classic (macOS)), `⌘ I` (macOS System Shortcuts), `Ctrl+Q` (XWin), `Ctrl+Q` (GNOME), `Ctrl+Q` (KDE), `Ctrl+Q` (Emacs), `Ctrl+Q` (Sublime Text), `Ctrl+Q` (Sublime Text (macOS)), `Ctrl+K, I` (Visual Studio), `⌘ K, I` (Visual Studio (macOS)), `Ctrl+Q` (NetBeans), `Alt+Middle-Click` (Eclipse), `⌥ Middle-Click` (Eclipse (macOS))）显示有关表的信息：数据源、数据库、架构、名称、自动生成的定义和表预览。 若要查看表格预览，请点击   显示表预览  。

* 在编辑器中： ![编辑器中快速文档弹出窗口中的表格信息](https://resources.jetbrains.com/help/img/idea/2026.3/db_quick_doc_table_preview_in_editor.png)

* 在 数据库 工具窗口中： ![数据库工具窗口中的快速文档弹出窗口中的表信息](https://resources.jetbrains.com/help/img/idea/2026.3/quick_doc_table_preview.png)

对于 PostgreSQL 和 MySQL 数据库，表预览还包含有关表大小的信息。

### 参考

[数据编辑器和查看器](data-editor-and-viewer.html#reference) [创建和修改对话框](create-and-modify-dialogs.html#table_structure_editor) [栏目可能的图标组合](database-tool-window.html#possible-icon-combinations-for-columns) [数据源及其元素](database-tool-window.html#icons-for-data-sources-and-their-elements) [导入表对话框](import-data.html#import_dialogs)

### 相关

[查看数据](tables-view-data.html)

### 工具 Windows

[数据库工具窗口](database-tool-window.html)

### 导航

### 语言和框架特定指南

[数据库工具和 SQL](relational-databases.html)

