CLion 2022.3 Help

Troubleshooting

The Remote Development feature for JetBrains IDEs is still in its active development stage, so that some issues may occur. This page is aimed to help you with an initial troubleshooting during the setup or later work.

Setup

Question

Answer

Is there a difference between JetBrains Gateway from Toolbox, the one downloaded separately, or the one from an IDE?

Standalone JetBrains Gateway supports an option to "Open in IDE" your Space-based project If you don't use it, there are no other differences in installers and workflows.

Check the installation scenarios.

Can I point Remote Development to an existing IDE on my remote server? Is it possible to install IDE manually?

Since version 221.5481, you can manually register an existing backend IDE on the remote server and make it visible for JetBrains Gateway. Installed IDE will appear in the list of available builds:

  1. Enter remote server by SSH.

  2. Locate the folder with unpacked IDE, enter bin folder.

  3. In the command line, execute the following command:

    remote-dev-server.sh registerBackendLocationForGateway

    For example,

    sh CLion-221.5591.52/bin/remote-dev-server.sh registerBackendLocationForGateway

The JetBrains Gateway installation itself doesn't finish successfully

  • Ensure your system user has permissions to install a software or contact a system administrator in your organization.

Why does the SSH connection to a remote server fail during the setup?

  • Firewall on the remote server side or the virtual machine provider prohibits incoming connection. In the case of AWS, don't forget to adjust "Security groups"

  • On the remote side, your SSH listens to a non-standard port

  • Password or key file is incorrect or your connection was blocked due to several failures

JetBrains Gateway hangs on the Retrieving IDE versions step and doesn't load available IDEs

  • JetBrains Gateway can't connect to JetBrains' site to fetch the list of existing builds

JetBrains Gateway tries to connect but fails. Credentials are 100% correct.

  • Ensure AllowТcpForwarding in sshd_config on the remote server is enabled as it's required for redirecting remote IDE process' traffic to your local machine.

I select an IDE installer from the local machine, but the process of uploading fails

  • The remote server doesn't have enough available space on the disk. The available space on your remote server must be at least 4xIDE.tar.gz in size.

    Since version 2022.1.1, you can select a custom path on the remote server as the deployment target location.

  • You uploaded not .tar.gz installer archive, so it can't be unpacked on the remote side

  • SFTP subsystem is not enabled on the remote machine

On local machine, process fails with the Failed to download JetBrains Client error

The fully offline development scenario is not yet supported.

Your local computer must have a network connection to the following JetBrains URLs:

  • https://code-with-me.jetbrains.com

  • https://download.jetbrains.com

  • https://download-cf.jetbrains.com

  • https://download-cdn.jetbrains.com

  • https://cache-redirector.jetbrains.com

Work with remote project

Question

Answer

Failed to get IDE status in 60 seconds. Probably IDE backend is stuck

  • Backend server's shell is interactive or has config errors, so deployment commands don't finish correctly.

    Try to replace it with a default config or simple bash

  • Backend IDE hangs due to lack of resources and doesn't respond:

    1. Enter the remote server by ssh and terminate IDE processes manually.

    2. Add memory to the remote IDE by editing JVM options file. Default deploy settings can be not suitable for average or big projects.

    3. Locate remote IDE JVM settings file:

    $IDE_BIN_DIR/${IDE_PRODUCT_VM_OPTIONS}.vmoptions

    Check the following example:

    ./.cache/JetBrains/RemoteDev/dist/a17ad99f7faf8_ideaIU-2021.3.1/bin/idea64.vmoptions

    4. Edit -Xmx value and repeat the deploy/connection with new settings

  • Backend IDE can't process your project in general (lack of resources, wrong configuration, broken dependencies).

    Enter the remote server by ssh and launch the project manually as described on this page and check the output.

    If the project started successfully, copy the generated link and try connect from the local Gateway (also described in the article).

CPU or resources usage looks abnormal

  • To diagnose performance problems, support needs logs (Help -> Collect Host and Client logs), CPU snapshot from the server (Help -> Diagnostic Tools -> Start CPU Usage Profiling), and heap dumps (files like java_error_in_idea*.hprof)

    For more information about diagnosing performance problems, refer to Reporting performance problems

IDE hangs and doesn't respond

  • When IDE hangs and doesn't respond so that you can't use the menu to capture the snapshot, provide us with the thread dumps

The remote IDE worked but stopped responding

  • Enter the remote server and terminate IDE processes or reboot the server, then re-test. In future versions, we plan to support a self-healing restart.

Collecting logs and submitting reports

If the solutions above don't help, and you need our assistance, please provide a detailed description. Besides the IDE version, logs, and thread dumps, which are a must, we appreciate a code/project sample, screenshot, or screencast/gif that illustrates the problem.

Attach them to your issue when submitting a report.

To make the issue visible only to the JetBrains team, you can set its visibility to the jetbrains-team group. With the exception of images, all attachments are visible only to the JetBrains team by default.

Collect logs from UI

  1. From JetBrains Gateway: Welcome (start) screen - left bottom corner - gear icon - "Collect All Logs".

  2. From the main IDE you use as Remote Development starting point: top menu - "Help" - "Collect Logs and Diagnostic Data".

  3. From launched JetBrains Client session (connected to your remote server): top menu - "Help" - "Collect Host and Client Logs"

Collect logs manually

  1. On local workstation side: the location depends on the OS of your local computer.

    We recommend collecting and sending the whole logs' folder from directories used by the IDE.

  2. On the remote server: logs are located per-project in the IDE installation folder.

    Default installation path is ~/.cache/JetBrains/RemoteDev-IDE_NAME/PROJECT_PATH/log

    For example, ~/.cache/JetBrains/RemoteDev-IU/_home_ec2-user_intellij-samples/log/

Last modified: 30 November 2022