DataGrip 2019.2 Help

Database console

Overview

Database consoles are SQL files that are already associated with a data source.

For example, if you open a database console for MySQL, a connection session to the MySQL data source is automatically created. When you open an SQL file from your hard drive, you need to specify the connection session first.

In the following example, the MySQL concole is attached to the production session. You can change the production session to default or create a new session. Read more about managing sessions in Managing connection sessions.

Console file

The input pane of a database console opens as a separate editor tab. The input pane is where you compose your SQL statements.

When you execute a statement, the Services tool window opens. The Services tool window displays available connection sessions, Output and Result tabs. For more information about the Services tool windows, see Services Tool Window.

If the executed statement retrieves data (for example, SELECT), results are displayed in the Result tab that has a title of a qualified table name. For more information about creating custom titles for result tabs, see Use custom titles for tabs with results.

Use custom titles for tabs with results

If the executed statement does not retrieve data, results are displayed in the Output tab.

Results in the Output tab

Before execution of a parametrized statement, you see the Parameters window where you can specify values for the parameters.

Run a statement with parameters

Input pane

Use the input pane to compose and execute your SQL statements as well as to perform other associated tasks.

To access available functions, use toolbar icons, keyboard shortcuts, and context menu commands.

Toolbar icons and shortcuts

Item

Shortcut

Description

the Execute button Execute

Ctrl+Enter Execute the selected (highlighted) SQL statement or statements.

If nothing is selected, the current statement is executed.

Browse Console History Browse Console History

Ctrl+Alt+E

Open a dialog that shows all the statements that you have run for the corresponding data source.

See also, View history of executed statements.

View Parameters View Parameters

Open or close the Parameters dialog.

Settings Settings

Open the Database page of the Settings dialog to view or edit the settings for your database consoles, data editors, and the Database tool window.

Tx:Auto
Tx:Auto

Select the isolation level for database transactions and the way the transactions are committed.

  • Auto: each statement is executed in its own transaction that is implicitly committed.

  • Manual: transactions are committed or rolled back explicitly by means of Commit button or Rollback button on the toolbar.

Commit button Commit

Commit the current transaction.

Rollback button Rollback

Roll back the current transaction.

Cancel Query Cancel Running Statements

Ctrl+F2

Terminate execution of the current statement or statements.

<schema>

Select the default schema or database. For PostgreSQL and Redshift, use the <schema> list to form the schema search path.

Select a search path for PostgreSQL

Productivity tips

Item

Shortcut

Description

Edit as Table

In INSERT statements, opens the editor for working with the data in a table format.

Edit data in INSERT statements as a table

For more information about using Edit as Table in INSERT statements, Edit data in INSERT statements as a table.

Change Dialect (<CurrentDialect>)

Use this command to change the SQL dialect being used. Select the necessary dialect from the list.

See also, Change the SQL dialect in a console.

Explain Plan

Show an execution plan (or explain plan) for the current statement. The result is shown in a mixed tree/table format on a dedicated Plan tab.

Example of Explain Plan

Explain Plan (Raw)

Show an execution plan (or explain plan) for the current statement. The result is shown in table format. Technically, EXPLAIN <CURRENT_STATEMENT> or similar statement is executed.

Example of Explain Plan

Execute

Ctrl+Enter

Execute the current statement or the sequence of selected statements.

Execute to File

Execute the current statement and save the result in a text file. Select the output format, and specify the file location and name.

Run 'console [data_source]'

Ctrl+Shift+F10

Use this command or shortcut to execute all the statements contained in the console.

Toolbar of the Database Console tool window

To hide or show the toolbar, click icons general gearPlain svg on the title bar and select Show Toolbar.

Item

Shortcut

Description

Settings Settings

Open the Database page of the Settings dialog to view or edit the settings for your database consoles, data editors, and the Database tool window.

View Parameters View Parameters

Open or close the Parameters dialog.

Browse Console History Browse Console History

Ctrl+Alt+E

Open a dialog that shows all the statements that you have run for the corresponding data source.

See also, View history of executed statements.

Restore Layout Restore Layout

Restore the original tool window layout after layout changes.

Cancel Query Cancel Running Statements

Ctrl+F2

Terminate execution of the current statement or statements.

Close Close

Ctrl+Shift+F4

Close the tool window.

Output pane

Use the Output tab to view information about SQL statements and other operations that you performed in a database console. Also, the Output tab displays information about errors, timestamps, affected rows, query duration, the autocommit mode, and other operations.

The Ouput tab

Right toolbar

Item

Description

Soft-wrap

Wrap long lines of text.

Scroll to end

Scroll the output log to the end.

Print

Print a database console file, a selected text, or all the files in a directory.

Clear all

Clear the Output tab.

Context menu

Item

Description

Copy Copy

Copy the selected text.

Copy as Plain Text

Copy the selected text as plain text (without formatting).

Copy Reference

Copy a reference link to a file or a line.

Compare with clipboard Compare with clipboard

Open the Clipboard vs Editor dialog where you can see the diff between the selected text and the text that you copied to a clipboard.

Search with Google

Open a browser and run a search on Google for the selected text.

Fold Lines Like This

Fold the lines that include the selected text.

Pause Output

Pause the output logging.

Clear All

Clear the output log.

Result pane

This pane shows the data retrieved from the database in table format. You can sort, add, edit and remove the data as well as perform other, associated tasks.

Main functions

Most of the functions in the Result pane are accessed by using controls on the toolbar, context menu commands for the data cells, and associated keyboard shortcuts. You can see what other actions with tables you can perform in Working with tables.

Item

Shortcut

Description

First page, Previous page, Next page, Last page

Use navigation icons and corresponding commands for switching between pages that show the retrieved data.

A number of rows that you see simultaneously on the Result tab are referred to as a result set page. If this number is less than the number of rows that satisfy the query, only a subset of all the rows is shown at a time. If all the rows are currently shown, navigation icons and the corresponding commands are inactive.

  • First page: jump to the first page of results.

  • Previous page: go to the previous page of results.

  • Next page: go to the next page of results.

  • Last page: jump to the last page of results.

To change the size of a result set page, open settings (Ctrl+Alt+S) and navigate to Database | Data Views. In the Limit page size to field, type a new size of a result set page. Alternatively, to disable the page size restriction, clear the Limit page size to checkbox.

Reload page Reload Page

Ctrl+F5

Reload data for the table view to synchronize the data that you see in the editor with the contents of the database. Also, use the Reload Page button when you want to apply a new page size limit setting after its change.

Add New Row Add New Row

Alt+Insert

Add a row to the table.

To save a new row, click Submit the Submit button.

The Add New Row button is disabled in the inappropriate context. For example, if the current table does not permit adding rows.

For more information about working with rows, see Rows.

Delete Row Delete Row

Ctrl+Y

Delete the selected row or rows.

To select rows, click numbers in the gutter. To select multiple rows, press Ctrl and click the necessary rows.

The Remove Row button is disabled in the inappropriate context. For example, if the current table does not permit removing rows.

Tx isolation
Tx and Tx Isolation

Select the isolation level for database transactions and the way the transactions are committed.

  • Auto The current transaction is committed automatically when you submit your local changes to the database server.

  • Manual The changes submitted to the database server are accumulated in a transaction that can either be committed or rolled back.

iconDBSubmit Submit

Ctrl+Enter

Submit local changes to the database server. See .

iconDBCommitTransaction Commit

Commit the current transaction. See also, Tx.

iconDBRollbackTransaction Rollback

Roll back the current transaction. See also, Tx.

Cancel Query Cancel Query

Ctrl+F2

Terminate execution of the current query.

Compare with Compare With

Compare the current table with the table in the Database Console tool window. For more information about comparing tables, see Compare table data.

Pin button Pin Tab

Pin the tab to the tool window to keep the query result.

For more information about pinning tabs, see Pin the tab with query results.

Data Extractor Data Extractor

Select an output format for your data.

Also, you can configure the following options:

  • Skip Computed Columns (SQL): do not include virtual columns that are not physically stored in the table (for example, the identity column).

  • Skip Generated Columns (SQL): for INSERT and UPDATE statements, do not include auto-increment fields when copying or saving data.

  • Add Table Definition (SQL): for INSERT and UPDATE statements, add the table definition when copying or saving data.

  • Configure CSV Formats: open the CSV Formats dialog where you can manage your delimiter-separated values formats (for example, CSV, TSV).

  • Go to Scripts Directory: open a directory with scripts that convert table data into different output formats.

Dump Data Dump Data

Copy the table data to the clipboard or save to a file.

Dump Data Dump Data | To File

Use this command to save the table data in a file. In the dialog that opens, specify the location and name of the file.

iconExportToDB Export to Database

Export the data to another table, schema or database. Select the target schema (a new table will be created) or table (the data will be added to the selected table). In the dialog that opens, specify the data mapping info and the settings for the target table.

View Query

Use this button to view the query which was used to generate the table. To close the pane where the query is shown, press Escape.

Show Options Menu

The Show Options Menu list includes the following options:

  • Transpose: toggle the transposed table view. In the transposed view, the rows and columns are interchanged.

  • Reset View: restore the initial table view if you customized the table view before (for example, hid columns or sorted data).

  • Settings: open the Database page of the Settings dialog to view or edit the settings for your database consoles, data editors, and the Database tool window.

Edit

F2

Edit a value in the selected cell or cells. Alternatively, you can double-click the cell and start typing a value. The Edit command is unavailable for read-only values. For read-only values, use the View command.

  • To open the auto-completion list, press Ctrl+Space.

  • To enter the modified value, press Enter.

  • To cancel editing, press Escape.

For more information about editing cells, see Cells.

Edit Maximized

F2

Expand the selected cell to edit a value in the cell.

In a maximized cell, press Enter to start a new line. To enter the value, press Ctrl+Enter. To restore an initial value and quit the editing mode, press Escape.

For more information about editing cells, see Cells.

Set DEFAULT

Ctrl+Alt+D

Set the default value or values that you specified for the column. To view the default column value, right-click a table in the Database tool window (View | Tool Windows | Database) and select Modify Table. Double-click the column entry and see the value in the Default field.

Set NULL

Ctrl+Alt+N

Replace the value or values with NULL. To ensure that the column accepts NULL values, right-click a table in the Database tool window (View | Tool Windows | Database) and select Modify Table. Double-click the column entry and see if the Not null checkbox is cleared.

Load File

Load a file into the field.

Revert

Ctrl+Z

Revert changes within the selection. For more information about reverting changes, see Submitting changes to a database.

Clone Row

Ctrl+D

Create a copy of the selected row.

Quick Documentation

Ctrl+Q

Open the quick documentation view. To close the view, press Escape. For more information about quick documentation, see Using the quick documentation view.

Transpose

Toggle the transposed table view. In the transposed view, the rows and columns are interchanged.

Go To | Row

Ctrl+G

Jump to a specified row. In the Go to Row dialog, specify the column and row number (use the column:row pattern).

Go To | Related Data

F4

Jump to a related record. The command options are a combination of those for Go To | Referenced Data and Go To | Referencing Data. Read more about related data in Navigate to a related object.

The command is not available if there are no related records.

Go To | Referenced Data

Ctrl+B

Switch to a record that the current record references. If more than one record is referenced, select the target record in the popup that appears. Read more about related data in Navigate between related data.

The command is not available if there are no referenced records.

Go To | Referencing Data

Alt+F7

Use this command or shortcut to see the records that reference the current record. Read more about related data in Navigate between related data. In the popup that appears there are two categories for the target records:

  • First Referencing Row: all the rows in the corresponding table are shown, and the first of the rows that references the current row is selected.

  • All Referencing Rows: only the rows that reference the current row are shown.

The command is not available if there are no records that reference the current one.

Copy

Ctrl+C

Copy the selection to the clipboard.

Paste

Ctrl+V

Paste the contents of the clipboard into the table.

Save LOB

Save a binary large object (LOB) currently selected in the table in a file.

Alt+J, Shift+Alt+J, Ctrl+W

See Work with query results.

Sorting data

To sort table data in a column, click the cell in the header row.

State

Description

No sorting

Indicates that the data is not sorted in this column. The initial state of the sorting marker.

Ascending order

The data is sorted in the ascending order. The number to the right of the marker (1 on the picture) is the sorting level. You can sort by more than one column. In such cases, different columns will have different sorting levels.

Descending order

The data is sorted in the descending order.

Here is an example of a table where data are sorted by two of its columns.

TableEditorSortedTable

To restore the initial "unsorted" state for the table, click IconDBToolbarMenu and select Reset View.

Reordering columns

To reorder columns, use drag-and-drop for the corresponding cells in the header row.

Hiding and showing columns

To hide a column, right-click the corresponding header cell and select Hide column.

To show a hidden column:

  1. Do one of the following:
    • Right-click any of the cells in the header row and select Column List.

    • Press Ctrl+F12.

    In the list that appears, the names of hidden columns are shown struck through.

    TableResultPaneHideColumn
  2. Select (highlight) the column name of interest and press Space.

  3. Press Enter or Escape to close the list.

To show all the columns, click IconDBToolbarMenu and select Reset View.

See also, Operations with columns in the structure view.

Parameters pane

The Parameters pane shows the parameters detected in the input pane and lets you edit their values. To open or close this pane, use property yellow on the toolbar.

To start editing a value, switch to the corresponding table cell and start typing. To indicate that you have finished editing a value, press Enter or switch to a different cell. To quit the editing mode and restore an initial value, press Escape.

When you select a row in the table, the corresponding parameter is highlighted in the input pane.

See also, Executing parameterized statements.

Last modified: 11 November 2019