Inspectopedia Help

Kotlin Gradle and IDE plugins versions are different

Reports that Gradle plugin version isn't properly supported in the current IDE plugin.

This can cause inconsistencies between IDE and Gradle builds in error reporting or code behavior.

Example:

dependencies { classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:0.0.1" }

To fix the problem change the kotlin gradle plugin version to match the version of kotlin that is bundled into the IDE plugin.

Inspection Details

By default bundled with:

IntelliJ IDEA 2024.1, Qodana for JVM 2024.1,

Can be installed with plugin:

Kotlin, 241.16690-IJ

Last modified: 29 April 2024