Inspectopedia Help

Receiver has a generic name

Reports receiver names like me, this, self, or names that differ from other receiver names for this type.


func (self *MeterSnapshot) Rate5() float64 { return math.Float64frombits(self.rate5) }

According to Receiver Names at, you should not use generic names such as "me", "this", or "self". These identifiers are typical for object-oriented languages and might give the method a special meaning.

Inspection Details

By default bundled with:

GoLand 2024.1, Qodana for Go 2024.1,

Can be installed with plugin:


Last modified: 29 April 2024