Inspectopedia Help

Vulnerable API usage

Reports usages of Vulnerable APIs of imported dependencies.

Fixing the reported problems helps prevent your software from being compromised by an attacker.

To solve a problem, you can update to a version where the vulnerability is fixed (if available) or switch to a dependency that doesn't have the vulnerability.

Vulnerability data provided by Checkmarx (c).

Inspection Details

By default bundled with:

GoLand 2024.1, IntelliJ IDEA 2024.1, PhpStorm 2024.1, PyCharm 2024.1, Qodana for Go 2024.1, Qodana for JS 2024.1, Qodana for JVM 2024.1, Qodana for PHP 2024.1, WebStorm 2024.1

Can be installed with plugin:

Package Checker, 241.SNAPSHOT

Last modified: 12 March 2024