Inspectopedia Help

RuboCop

Reports issues from the RuboCop linter. Requires the rubocop gem to be installed in the project SDK. If supported, all RuboCop commands run in server mode.

Use the Use 'standard' gem checkbox to enable linting with standard.

Use the RuboCop Severities Mapping fields to customize the highlight levels.

Use the Run `rubocop -a` on save checkbox to run RuboCop in safe autocorrect mode on save.

Inspection Details

By default bundled with:

Qodana for Ruby 2024.1, RubyMine 2024.1,

Can be installed with plugin:

Ruby, 241.SNAPSHOT

Last modified: 29 April 2024