AppCode 2020.2 Help

CocoaPods

Use this page to view the list of available pods and update CocoaPods gem and local CocoaPods repositories.

For more details on how to work with CocoaPods, refer to the CocoaPods article and the Use CocoaPods in your project tutorial.

ItemDescription
Add Ruby SDK

Click this button to select a Ruby SDK from the list, by default, /usr/bin/ruby:

Specify Ruby SDK

After the Ruby SDK is selected, you can install CocoaPods gem by clicking the corresponding button that becomes available:

Install CocoaPods gem
Remove Ruby SDK Click this button to remove the specified Ruby SDK.
Update CocoaPods/Install CocoaPods Click Update CocoaPods to install the latest CocoaPods gem version. If CocoaPods gem is not installed yet, the button is called Install CocoaPods — click it to install CocoaPods gem.
Pods This table displays names of the available pods with short descriptions. Scroll down to see all pods. Select a pod in the table to view more details in the Description pane.
Update Repositories Click this button to update local pod repositories.
Last modified: 26 June 2020