PyCharm 2021.1 Help

Data editor

From the Database tool window (for any table within a DB data source):

  • the Data Editor button on the toolbar (if the toolbar is not currently hidden)

  • Open Editor from the context menu

  • F4

Overview

The data editor provides a user interface for working with table data. In the data editor, you can sort, filter, add, edit and remove the data as well as perform other, associated tasks.

For more information about operations with tables, columns, rows, and cells, see the following articles:

Data editor with tool windows

Toolbar controls, context menu commands for data cells and keyboard shortcuts

Most of the available functions are accessed by means of controls on the toolbar, context menu commands for the data cells, and associated keyboard shortcuts.

ItemShortcutDescription
First page, Previous page, Next page, Last page

Use navigation icons and corresponding commands for switching between pages that show the table data.

A number of rows that you see on the Result tab are referred to as a result set page. If this number is less than the number of rows in the table, only a subset of all the rows is shown at a time. If all the rows are currently shown, navigation icons and the corresponding commands are inactive. You can see the limit between the navigation buttons. You can change it here by clicking and selecting the necessary limit or in settings.

  • First page: jump to the first page of results.

  • Previous page: go to the previous page of results.

  • Next page: go to the next page of results.

  • Last page: jump to the last page of results.

To change the size of a result set page, open settings (Ctrl+Alt+S) and navigate to Tools | Database | Data Views. In the Limit page size to field, type a new size of a result set page. Alternatively, to disable the page size restriction, clear the Limit page size to checkbox.

Reload page

Reload Page

Ctrl+F5

Reload data for the table view to synchronize the data that you see in the editor with the contents of the database. Also, use the Reload Page button when you want to apply a new page size limit setting after its change.

Cancel Query

Cancel Query

Ctrl+F2Terminate execution of the current query.

Add New Row

Add Row

Alt+Insert

Add a row to the table.

To save a new row, click Submit the Submit button.

For more information about working with rows, see Tables.

Delete Row

Delete Row

Ctrl+Y

Delete the selected row or rows.

To select multiple rows, click numbers in the gutter. Also, you can press Ctrl and click the necessary rows.

the Revert Selected button

Revert Selected

Alt+InsertReverts changes that you made to a cell value. You can select a scope of different cells and revert values in this scope.

the Preview pending changes button

Preview pending changes

Preview DML of changes that you made to the table.

Preview pending changes

the Submit button

Submit

Ctrl+EnterSubmit local changes to the database server. See Submit changes to a database.

Transaction mode

Transaction Mode and Transaction Isolation

Select the isolation level for database transactions and the way the transactions are committed.

  • Auto: the current transaction is committed automatically when you submit your local changes to the database server.

  • Manual: the changes submitted to the database server are accumulated in a transaction that can either be committed or rolled back.

the Commit button

Submit and Commit

Submit and commit the current transaction. This button is available only for the manual transaction mode. See also, transaction mode and isolation.

Rollback

Roll back changes. This button is available only for the manual transaction mode.

Go to DDL

Go to DDL

Open DDL of the object in the editor.

Open DDL of the object in the editor

the Find on Current Page button

Find on Current Page

Ctrl+F

Opens a search field for the current page of results.

Data Extractor

Data Extractors

Select an output format for your data.

Also, you can configure the following options:

  • Skip Computed Columns (SQL): do not include virtual columns that are not physically stored in the table (for example, the identity column).

  • Skip Generated Columns (SQL): for INSERT and UPDATE statements, do not include auto-increment fields when copying or saving data.

  • Add Table Definition (SQL): for INSERT and UPDATE statements, add the table definition when copying or saving data.

  • Configure CSV Formats: open the CSV Formats dialog where you can manage your delimiter-separated values formats (for example, CSV, TSV).

  • Go to Scripts Directory: open a directory with scripts that convert table data into different output formats.

Compare with

Compare With

Compare the current table with the table in the Services tool window. For more information about comparing tables, see Compare table data.

Export Data

Export Data

Export the table data to the clipboard or save to a file.

the Export button

Copy to Database

Copy the data to another table, schema or database. Select the target schema (a new table will be created) or table (the data will be added to the selected table). In the dialog that opens, specify the data mapping info and the settings for the target table.

Show Options Menu

Show Options Menu

The Show Options Menu list includes the following options:

  • Show Geo Viewer: enable a graphic viewer to explore geospatial data in your database.

  • Sort via ORDER BY: sort data on a database level. The Sort via ORDER BY option is available only for tables in the data editor but not for table result sets in the Services tool window.

    If the Sort via ORDER BY option is on, data for the whole table is sorted according to the corresponding database system. In the Output tab, you can see all the corresponding sorting operations.

    Sort via ORDER BY is on

    Do not turn this option on if you want to keep interactions with the database to a minimum. For example, when the table is large or the database connection is slow. If you want to use sorting on the client side, clear the Sort via ORDER BY checkbox.

    If this option is off, the data is sorted locally and only for the rows that are currently shown.

    Sort via ORDER BY is off
  • Row Filter: show or hide the filter box.

  • Reset View: restore the initial table view if you customized the table view before (for example, hid columns or sorted data).

  • Paste Format: select how you want to treat the text from the clipboard on paste.

  • View Query: view the query that generated the table.

  • Open Database Settings: open the Database section in settings. In the Database section, you can view or edit the settings for your database consoles, data editors, and the Database tool window.

EditF2

Edit a value in the selected cell or cells. Alternatively, you can double-click the cell and start typing a value. The Edit command is unavailable for read-only values.

  • To open the auto-completion list, press Ctrl+Space.

  • To enter the modified value, press Enter.

  • To cancel editing, press Escape.

For more information about editing cells, see Cells.

MaximizeF2

Expand the selected cell to edit a value in the cell.

In a maximized cell, press Enter to start a new line. To enter the value, press Ctrl+Enter. To restore an initial value and quit the editing mode, press Escape.

For more information about editing cells, see Cells.

Set DEFAULTCtrl+Alt+DSet the default value or values that you specified for the column. To view the default column value, right-click a table in the Database tool window (View | Tool Windows | Database) and select Modify Table. Double-click the column entry and see the value in the Default field.
Set NULLCtrl+Alt+NReplace the value or values with NULL. To ensure that the column accepts NULL values, right-click a table in the Database tool window (View | Tool Windows | Database) and select Modify Table. Double-click the column entry and see if the Not null checkbox is cleared.
Load FileLoad a file into the field.
RevertCtrl+ZRevert changes within the selection. For more information about reverting changes, see Submit changes to a database.
Clone RowCtrl+DCreate a copy of the selected row.
Quick DocumentationCtrl+QOpen the quick documentation view. To close the view, press Escape. For more information about quick documentation, see Using the quick documentation view.
View as | Transpose

Toggle the transposed table view. In the transposed view, the rows and columns are interchanged.

To make this mode a default for tables and views, open settings by pressing Ctrl+Alt+S and navigate to Tools | Database | Data Views and select the Automatically transpose tables. When this option is enabled, query results are not transposed.

Go To | RowCtrl+GJump to a specified row. In the Go to Row dialog, specify the column and row number (use the column:row pattern).
Go To | Related DataF4

Jump to a related record. The command options are a combination of those for Go To | Referenced Data and Go To | Referencing Data. Read more about related data in Navigate between related data.

The command is not available if there are no related records.

Go To | Referenced DataCtrl+B

Switch to a record that the current record references. If more than one record is referenced, select the target record in the popup that appears. Read more about related data in Navigate between related data.

The command is not available if there are no referenced records.

Go To | Referencing DataAlt+F7

Use this command or shortcut to see the records that reference the current record. Read more about related data in Navigate between related data. In the popup that appears there are two categories for the target records:

  • First Referencing Row: all the rows in the corresponding table are shown, and the first of the rows that references the current row is selected.

  • Referencing Rows Only: only the rows that reference the current row are shown.

The command is not available if there are no records that reference the current one.

Filter byUse this command to access quick filtering options. The options include those for the current column name and depend on the value in the current cell.
CopyCtrl+CCopy the selection to the clipboard.
PasteCtrl+VPaste the contents of the clipboard into the table.
Save LOBSave a binary large object (LOB) currently selected in the table in a file.
Last modified: 06 April 2021