PhpStorm 2026.3 Help

サービスツールウィンドウ

サービス ツールウィンドウを使用すると、実行 / デバッグ構成、データベースセッション、Kubernetes クラスタおよび Docker への接続など、開発ワークフローで使用されるさまざまなサービスを管理できます。 プラグイン開発者は、IntelliJ プラットフォーム API を介して他のサービスを追加できます。

メインツールバーには、すべてのサービスタイプに共通の次のボタンとメニューが含まれています。

「サービスの追加」メニュー

サービスの追加 Alt+Insert

追加するサービスタイプを選択します。

The Group By menu

Group By

サービスのリストを整理する方法を選択します。

  • サービスをタイプ別にグループ化: 実行ダッシュボード、 Docker、 データベース などのタイプごとにサービスを整理します。

The Open in New Tab button

新規タブで開く

選択した項目を別のタブに移動します。

The Expand All button

Expand All Ctrl+NumPad +

リスト内のすべての項目を展開します。

「すべて折りたたむ」ボタン

Collapse All Ctrl+NumPad -

リスト内のすべての項目を折りたたみます。

サービスを別のツールウィンドウに表示する

サービス ツールウィンドウのレイアウトは、サービスをそれぞれ別のツールウィンドウに移動することで調整できます。

サービスを右クリックしてコンテキストメニューから「別のツールウィンドウで開く 」を選択すると、サービスが専用のツールウィンドウに移動します。 サービスを元の「サービス 」ツールウィンドウに戻すには、サービスを右クリックして「サービスツールウィンドウに追加 」を選択します。

別の方法として、専用のダイアログで 1 つまたは複数のサービスのレイアウトを設定することもできます。

  1. サービス ツールウィンドウで をクリックし、 Configure Services Tool Window を選択します。

    または、 Ctrl+Shift+A を押して Configure Services Tool Window と入力し始めてください。

  2. 除外 ボタンと 含める ボタンを使用して、 サービス ツールウィンドウから別のツールウィンドウにサービスを移動したり、元に戻したりできます。

    実行/デバッグセクションの構成には独自のツールウィンドウがありません。代わりに、 実行 または デバッグ ツールウィンドウに表示されます。ただし、 サービス ツールウィンドウに含まれていない場合です。

  3. 変更を保存するには、 OK をクリックします。

実行 / デバッグ構成

実行 / デバッグ構成は、デフォルトでは サービス ツールウィンドウにリストされていません。 使用可能にする構成のタイプを明示的に指定し、対応する構成を作成する必要があります。

サービスウィンドウに実行 / デバッグ構成を追加する

  1. メインメニューから 表示 | ツールウィンドウ | サービス を選択するか、 Alt+8 を押します。

  2. サービス ツールウィンドウで、 サービスの追加 をクリックし、次に 実行構成 を選択します。

    サービスツールウィンドウ: 実行構成を追加する
  3. リストから実行 / デバッグ構成タイプを選択して、このタイプのすべての構成をウィンドウに追加します。

    選択したタイプの構成をすでに 1 つ以上作成している場合は、PhpStorm はそれらを専用のノードに表示します。 選択したタイプの構成がまだない場合は、IDE は 新規構成の追加 ダイアログを開き、そこで 新しい実行 / デバッグ構成を作成するを行うことができます。

ツールバーのボタンは、選択した実行 / デバッグ構成のタイプに応じて異なり、次のものが含まれます。

実行ボタン

実行 Ctrl+Shift+F10

選択した設定を実行します。

「デバッグ」ボタン

デバッグ ⌃ ⇧ D

選択した構成をデバッグモードで実行します。

The Stop button

停止 Ctrl+F2

選択した設定を停止します。

The Rerun button

再実行 Ctrl+Shift+F10

選択した構成を再実行します。

The Rerun in Debug Mode button

デバッグモードで再実行 ⌃ ⇧ D

選択した構成をデバッグモードで再実行します。

The Filters menu

フィルター

選択した構成の出力をフィルターします。 例: 警告と成功した手順を表示するように選択できます。

The More menu

詳細

構成に関連する追加のアクション。 例: 選択した構成の設定を開いて変更できます。

データベース

サービスツールウィンドウのデータベースサービス
  1. メインツールバー。

  2. 左ツールバー。

  3. コンテキストメニュー。

  4. 出力タブ。

  5. 結果タブ。

  6. 右ツールバー。

左ツールバー

ツールバー上のボタンは選択した項目によって異なり、次のものが含まれます。

アイコン

アクションとショートカット

説明

クエリコンソールへの移動アイコン

クエリコンソールに移動 Ctrl+Shift+F10

クエリコンソール ポップアップを開きます。 クエリコンソール ポップアップで、 エディターで開く クエリコンソールを選択できます。

the Deactivate icon

非アクティブにする Ctrl+F2

選択した 1 つまたは複数のデータソースのデータベース接続を閉じます。 (セッションが接続されているデータソースは、アイコンの隅に緑色の点で示されます。)

Tx

トランザクションモード

および

トランザクションの分離

データベーストランザクションの 分離レベル(英語)とトランザクションのコミット方法を選択します。

  • 自動: データベースサーバーにローカルの変更を送信すると、現在のトランザクションが自動的にコミットされます。

  • マニュアル: データベースサーバーに送信された変更はトランザクションに蓄積され、ツールバーの the Submit and Commit icon送信とコミット または the Roll Back buttonロールバック ボタンを使用して明示的にコミットまたはロールバックできます。

データベースのトランザクションモードと分離の詳細については、 変更をデータベースに送信するを参照してください。

the Commit icon

コミット

(マニュアル トランザクションモードの場合) 現在のトランザクションをコミットします。 このボタンは手動トランザクションモードでのみ使用できます。 「トランザクションモードと分離」も参照してください。

the Roll back icon

Roll back

(マニュアル トランザクションモードの場合) 変更をロールバックします。 このボタンは手動トランザクションモードでのみ使用できます。 「トランザクションモードと分離」も参照してください。

the Cancel Running Statements icon

実行中ステートメントのキャンセル

Ctrl+F2

現在のステートメントの実行を終了します。

コンテキストメニュー

コンテキストメニューのアクションは選択した項目によって異なり、次のようなものがあります。

アイコン

アクションとショートカット

説明

クエリコンソールへの移動アイコン

クエリコンソールに移動 Ctrl+Shift+F10

クエリコンソール ポップアップを開きます。 クエリコンソール ポップアップで、 エディターで開く クエリコンソールを選択できます。

the Deactivate icon

非アクティブにする Ctrl+F2

選択した 1 つまたは複数のデータソースのデータベース接続を閉じます。 (セッションが接続されているデータソースは、アイコンの隅に緑色の点で示されます。)

すべてのセッションを閉じる

データソースに対して開かれているすべてのセッションを閉じます。

新規タブで開く

選択した項目を別のタブに移動します。

新規タブでそれぞれを開く

選択した項目を別々のタブに分割します。

新規タブでそれぞれのタイプを開く

サービスの種類ごとに別々のタブを作成します。

削除 Delete

データソースに対して開かれているすべてのセッションを閉じます。 すべてのセッションを閉じる と同じです。

Tx

トランザクションモード

および

トランザクションの分離

データベーストランザクションの 分離レベル(英語)とトランザクションのコミット方法を選択します。

  • 自動: データベースサーバーにローカルの変更を送信すると、現在のトランザクションが自動的にコミットされます。

  • マニュアル: データベースサーバーに送信された変更はトランザクションに蓄積され、ツールバーの the Submit and Commit icon送信とコミット または the Roll Back buttonロールバック ボタンを使用して明示的にコミットまたはロールバックできます。

データベースのトランザクションモードと分離の詳細については、 変更をデータベースに送信するを参照してください。

the Commit icon

コミット

(マニュアル トランザクションモードの場合) 現在のトランザクションをコミットします。 このボタンは手動トランザクションモードでのみ使用できます。 「トランザクションモードと分離」も参照してください。

the Roll back icon

Roll back

(マニュアル トランザクションモードの場合) 変更をロールバックします。 このボタンは手動トランザクションモードでのみ使用できます。 「トランザクションモードと分離」も参照してください。

the Cancel Running Statements icon

実行中ステートメントのキャンセル

Ctrl+F2

現在のステートメントの実行を終了します。

セッションを閉じる

選択したセッションを閉じます。

セッションの切り替え

選択したファイルを利用可能なセッションの 1 つに添付します。

新規タブで開く

選択した項目を別のタブに移動します。

新規タブでそれぞれを開く

選択した項目を別々のタブに分割します。

新規タブでそれぞれのタイプを開く

サービスの種類ごとに別々のタブを作成します。

削除 Delete

データソースに対して開かれているすべてのセッションを閉じます。 すべてのセッションを閉じる と同じです。

the Jump to Source button

ソースに移動 F4

エディターでファイルを開きます。

出力タブ

サービス ツールウィンドウの 出力 タブを使用して、クエリコンソールで実行した SQL ステートメントやその他の操作に関する情報を表示します。 また、 出力 タブには、エラー、タイムスタンプ、影響を受ける行、クエリ期間、自動コミットモード、その他の操作に関する情報が表示されます。

出力タブ

右ツールバー

項目

ツールチップ

説明

the Soft-wrap icon

ソフトラップ

テキストの長い行を折り返します。

the Scroll to End icon

末尾までスクロール

出力ログを最後までスクロールします。

the Print icon

印刷…

コンソールファイル、選択したテキスト、ディレクトリ内のすべてのファイルを印刷します。

the Clear All icon

すべてを削除

出力 タブをクリアします。

コンテキストメニュー

項目

説明

コピー コピー

選択したテキストをコピーします。

パス / 参照のコピー

参照リンクをファイルまたは行にコピーします。

Compare with clipboard クリップボードと比較

クリップボードとエディター ダイアログを開き、選択したテキストとクリップボードにコピーしたテキストの差分を確認できます。

Google 検索

ブラウザーを開き、選択したテキストを Google で検索します。

同様の行を折りたたむ

選択したテキストを含む行を折ります。

出力の一時停止

出力ログを一時停止します。

削除 すべてをクリア

出力ログを消去します。

結果タブ

サービス ツールウィンドウの 結果 タブを使用して、データベースから取得したデータを表形式で表示します。 データを並べ替え、追加、編集、削除したり、その他の関連するテーブルタスクを実行したりできます。 テーブル、行、列、およびセルの操作に関する詳細については、 テーブル を参照してください。

サービスツールウィンドウの結果タブ

ツールバーコントロール

アイコン

アクションとショートカット

説明

表に切り替えるアイコン

テーブルに切り替え

クエリ結果を データエディターでテーブルとして表示します。

チャートに切り替えるアイコン

チャートに切り替え

クエリ結果を グラフとして表示します。

First page

Previous page

the Change page size button

Next page

Last page

最初のページ

前のページ Ctrl+Alt+Up

ページサイズの変更

次のページ Ctrl+Alt+Down

最後のページ

IDE 設定 (Ctrl+Alt+S) の データベース | データエディターとビューアー | コントロールのカスタマイズ | グリッドページネーションツールバーの位置 で位置が選択されている場合、ツールバーで使用できます。

ナビゲーションアイコンと対応するコマンドを使用して、取得したデータを表示し、ページサイズを変更するページを切り替えます。

結果 タブに表示されるいくつかの行は、 結果セットページと呼ばれます。 この数がクエリを満たす行の数より少ない場合、一度にすべての行のサブセットのみが表示されます。 現在すべての行が表示されている場合、ナビゲーションアイコンと対応するコマンドは非アクティブです。 ナビゲーションボタン間の制限を確認できます。 ここで、必要な制限をクリックして選択するか、 設定で変更できます。

  • First page最初のページ: 結果の最初のページに移動します。

  • Previous page前のページ: 結果の前のページに移動します。

  • Next page次のページ: 次の結果ページに進みます。

  • Last page最後のページ: 結果の最後のページに移動します。

結果セットページのサイズを変更するには、 ページサイズの変更 ボタンをクリックしてサイズを選択します。 または、設定 (Ctrl+Alt+S) を開き、 ツール | データベース | データエディターとビューアー に移動します。 ページサイズの制限 フィールドに、結果セットページの新しいサイズを入力します。 または、ページサイズの制限を無効にするには、 ページサイズの制限 チェックボックスをオフにします。

ページの再読み込みアイコン

ページの再ロード

Ctrl+F5

テーブルビューの データの再ロードは、エディターに表示されるデータをデータベースの内容と同期させます。 また、変更後に新しい ページ サイズ制限 設定を適用する場合は、 ページの再ロード ボタンを使用します。

the Update Interval icon

更新間隔

現在のテーブルの更新間隔を選択、一時停止、無効にします。 カスタムのものを設定することもできます。

the Cancel Running Statements icon

実行中ステートメントのキャンセル

Ctrl+F2

現在のステートメントの実行を終了します。

「行を追加」アイコン

行の追加

Alt+Insert

テーブルに行を追加します。

新しい行を保存するには、ツールバーの 送信ボタンサブミット をクリックします。

不適切なコンテキストでは、 行の追加 ボタンは無効になります。 例: 現在のテーブルで行の追加が許可されていない場合。

行の操作の詳細については、 行 を参照してください。

「行の削除」アイコン

行の削除

Ctrl+Y

選択した行を削除します。

複数の行を選択するには、ガターの数字をクリックします。 また、 Ctrl を押して、必要な行をクリックすることもできます。

不適切なコンテキストでは、 行の削除 ボタンは無効になります。 例: 現在のテーブルで行の削除が許可されていない場合。

the Revert Selected button

選択項目の復元

Ctrl+Alt+Z

セル値に加えた変更を元に戻します。 異なるセルのスコープを選択して、このスコープの値を元に戻すことができます。

変更を元に戻す方法の詳細については、「変更をデータベースに送信する 」を参照してください。

the Preview Pending Changes icon

保留中の変更をプレビュー

テーブルに加えた変更の DML をプレビューします。

送信ボタン

サブミット

Ctrl+Enter

ローカルの変更をデータベースサーバーに送信します。 変更の送信と元に戻す方法の詳細については、「変更をデータベースに送信する 」を参照してください。

Transaction mode

トランザクションモード

および

トランザクションの分離

データベーストランザクションの 分離レベル(英語)とトランザクションのコミット方法を選択します。

  • 自動: データベースサーバーにローカルの変更を送信すると、現在のトランザクションが自動的にコミットされます。

  • マニュアル: データベースサーバーに送信された変更はトランザクションに蓄積され、ツールバーの the Submit and Commit icon送信とコミット または the Roll Back buttonロールバック ボタンを使用して明示的にコミットまたはロールバックできます。

データベースのトランザクションモードと分離の詳細については、 変更をデータベースに送信するを参照してください。

the Submit and Commit icon

送信とコミット Ctrl+Alt+Shift+Enter

(マニュアル トランザクションモードの場合) 現在のトランザクションを送信してコミットします。 このボタンは手動トランザクションモードでのみ使用できます。 「トランザクションモードと分離」も参照してください。

the Roll Back icon

ロールバック

(マニュアル トランザクションモードの場合) 変更をロールバックします。 このボタンは手動トランザクションモードでのみ使用できます。 「トランザクションモードと分離」も参照してください。

現在のページを検索アイコン

現在のページで検索

現在のページのクライアント側テキスト検索。

the Enable Local Filter icon

ローカルフィルターの有効化

グリッドのすべての列に対してローカルフィルターを有効にします。

ローカルフィルターの詳細については、 データをフィルタリングするトピックを参照してください。

レコードビューを表示アイコン

レコードビュー

サイドパネルで特定のレコードの値を表示および編集します。

アクションの詳細については、 データを表示するトピックを参照してください。

ジオビューアーアイコンを表示

Geo ビューアーの表示

グラフィックビューアーを使用して、データベース内の地理空間データを探索できるようにします。

Geo ビューアーの詳細については、 PostgreSQL の地理データに Geo ビューアーを使用するを参照してください。

the Show Chart icon

チャートの表示

データの視覚化を開きます。

チャートの詳細については、「データの視覚化 」を参照してください。

Data Extractor

データ抽出

データの出力形式を選択します。 使用可能な形式のリストとデータエクストラクターに関する完全な情報については、 データ抽出トピックを参照してください。

また、次のオプションを構成できます。

  • 計算列のスキップ: テーブルに物理的に格納されていない仮想列(ID 列など)は含めないでください。

  • 生成列のスキップ: INSERT および UPDATE ステートメントの場合、データをコピーまたは保存するときに自動増分フィールドを含めないでください。

  • CSV 形式の構成: 区切り文字区切り値フォーマット (例: CSV、TSV) を管理できる CSV フォーマット ダイアログを開きます。

  • スクリプトディレクトリに移動: テーブルデータを異なる出力形式に変換するスクリプトでディレクトリを開きます。

データ抽出の詳細については、 データ抽出 トピックを参照してください。

データのエクスポートアイコン

データのエクスポート

テーブルデータをクリップボードにエクスポートするか、ファイルに保存します。

the Copy to Database icon

Copy to Database

データを別のテーブル、スキーマ、データベースにコピーします。 ターゲットスキーマ(新しいテーブルが作成されます)またはテーブル(データは選択したテーブルに追加されます)を選択します。 開いたダイアログで、データマッピング情報とターゲットテーブルの設定を指定します。

the Compare Data icon

データの比較

現在のテーブルとリストのテーブルを比較します。

テーブルの比較の詳細については、「テーブルデータを比較する 」を参照してください。

the View as icon

指定形式で表示

テーブルデータを参照および編集するためのモードを選択します。

  • 入れ替え: 行と列が 入れ替わる表示モード。 このチェックボックスを他の表示モードと組み合わせることができます。

    このモードをテーブルとビューのデフォルトにするには、 Ctrl+Alt+S を押して設定を開き、 ツール | データベース | データエディターとビューアー に移動します。 テーブルを自動的に転置する リストから 常に実行 を選択します。 このオプションを有効にすると、クエリ結果は転置されません。

  • テーブル :テーブルデータのデフォルト表示モード。 テーブル内のデータは、垂直列と水平行の交差部分であるセルに格納されます。

  • ツリー: キー値テーブルにデータが表示される表示モード。 子ノードが含まれている場合はキーセルを展開できます。 展開された子ノードからのデータは、キー列と値列に分配されます。

  • Text: データがテキストとして表示される表示モードです。 このモードでは、データエクストラクターを使用してデータを表します。 例: ツールバーの データ抽出 リストで CSV データエクストラクターを選択した場合、データベースオブジェクトデータは CSV 形式で表示されます。

    データ抽出の詳細については、 データ抽出 トピックを参照してください。

データの表示の詳細については、 データを表示するを参照してください。

the Show Options Menu icon

オプションメニューを表示

オプションメニューを表示 リストには、次のオプションが含まれます。

  • 値エディターの表示: セルに保存されているデータを編集できる別のエディターを開きます。

    エディターの詳細については、 値エディターを参照してください。

  • 集計ビューの表示: 複数のセルの値を選択して単一の集計値を取得できる集計ビューを開きます。

    ビューの詳細については、 集計ビューを参照してください。

  • 貼り付け形式: クリップボードのテキストを貼り付ける方法を選択します。

  • ビューのリセット: 以前にテーブルビューをカスタマイズした場合(たとえば、非表示の列や並べ替えられたデータ)、最初のテーブルビューを復元します。

  • クエリの表示: テーブルを生成した クエリを表示します。

  • クエリをコンソールにコピー: テーブルを生成したクエリをクエリコンソールにコピーします。

  • クエリをクリップボードにコピー :テーブルを生成したクエリをクリップボードにコピーします。

  • データビュー設定を開く ... :設定の データエディターとビューアー セクションを開くと、クエリコンソールおよびデータエディターでテーブルデータの表示と変更方法を定義できます。

    データエディターとビューアー の設定セクションの詳細については、 データエディターとビューアーを参照してください。

コンテキストメニュー

セルを操作するためのすべての基本アクションは、コンテキストメニューにあります。 コンテキストメニューを呼び出すには、変更するセルを右クリックします。 次の表に、すべてのアクションを示します。

データエディターのセルのコンテキストメニュー

Action

ショートカット

説明

Edit

Enter

選択した 1 つまたは複数のセルの値を編集します。 または、セルをダブルクリックして値の入力を開始することもできます。 Edit コマンドは、読み取り専用の値には使用できません。

  • 自動補完リストを開くには、 Ctrl+Space を押します。

  • 変更を確認するには、 Enter を押します。

  • 編集をキャンセルするには、 Escape を押します。

セルの編集の詳細については、「セル 」を参照してください。

レコードビューを表示アイコン 記録表示ビュー

サイドパネルで特定のレコードの値を表示および編集します。

アクションの詳細については、 データを表示するトピックを参照してください。

値エディターで開く

Shift+Enter

セルに保存されているデータを編集できる別の値エディターで開きます。

エディターの詳細については、 値エディターを参照してください。

集計ビューの表示

複数のセルの値を選択して単一の集計値を取得できる集計ビューを開きます。

ビューの詳細については、 集計ビューを参照してください。

the Revert Selected button 選択を元に戻す

Ctrl+Alt+Z

セル値に加えた変更を元に戻します。 異なるセルのスコープを選択して、このスコープの値を元に戻すことができます。

変更を元に戻す方法の詳細については、「変更をデータベースに送信する 」を参照してください。

ハイライトする言語の設定

IDE がセル内のデータをハイライトするために使用する言語を選択します。

表示タイプの変更

IDE が列にバイナリデータを表示する方法を選択します。 デフォルトでは、16 バイトのデータは UUID として表示されます。

DEFAULT を設定

Ctrl+Alt+D

現在のセル値をデフォルト値または列に指定した値に設定します。

デフォルト値の表示または設定に関する詳細については、 セルのデフォルト値と NULL 値を管理するを参照してください。

NULL

Ctrl+Alt+N

現在のセル値を NULL に設定します。

NULL 値を許可する方法の詳細については、 セルの既定値と NULL 値の管理を参照してください。

UUID の生成

選択したセルの UUID を生成します。

ファイルのロード…

ファイルをフィールドにロードします。

LOB の保存…

バイナリラージオブジェクト (LOB(英語)) を含むセルの場合。 セルの内容をファイルに保存します。

the Copy icon コピー

Ctrl+C

クリップボードへ選択をコピー。

データエクストラクターの変更

ツールバーの データ抽出 リストから現在選択されている データ抽出プログラムを変更します。

the Copy Aggregation Result (SUM) icon コピー集計結果 (SUM)

セル範囲の要約値をコピーします。 デフォルトでは、PhpStorm は SUM 集計結果をコピーします。 デフォルトを変更するには、ステータスバーを右クリックして、 アグリゲーター オプションが選択されていることを確認します。 ステータスバーのアグリゲーターウィジェットをクリックし、デフォルトとして使用するアグリゲーターを選択します。

the Paste icon ペースト

Ctrl+V

クリップボードの内容をテーブルに貼り付けます。

行追加

テーブルの最後に行を追加します。

行削除

Alt+Delete

選択した行の削除。

行のクローン

選択した行の複製を作成し、その複製をテーブルの最後に追加します。

移動

ナビゲーションバー

Alt+Home

ナビゲーションバーに移動します。

データベース

Alt+Shift+B

選択したオブジェクトを データベース ツールウィンドウで開きます。

関連シンボル…

Ctrl+Alt+Home

関連オブジェクトの 1 つに移動します。

DDL

Ctrl+Alt+Home

オブジェクト定義 (DDL) を開きます。

行…

Ctrl+G

指定した行に移動します。

行に移動 ダイアログで、列番号と行番号を指定します (column:row パターンを使用)。

the Related Rows icon 関連行

F4

関連レコードに移動します:

  • 現在のレコードが参照するレコード。

  • 現在のレコードを参照するレコード。

複数のレコードが参照されている場合、または現在のレコードを参照している場合は、表示されるポップアップでターゲットレコードを選択します。

関連するレコードがない場合、このアクションは使用できません。

関連データの詳細については、 関連する行間を移動する を参照してください。

アクション動作オプションの詳細については、 詳細設定 を参照してください。

the Open URL icon URL を開く

F4

OS のデフォルトブラウザーで URL を開きます。

ツール | データベース | データエディターとビューアー 設定ページ Ctrl+Alt+S で URL クリック設定 を開くリンクを有効にする必要があります。

the Open File icon ファイルを開く

F4

OS のデフォルトのファイルブラウザーでファイル URI を開きます。 例: file:///Users/Username/image.png。

ツール | データベース | データエディターとビューアー 設定ページ Ctrl+Alt+S で URL クリック設定 を開くリンクを有効にする必要があります。

フィルター

列にするフィルターを選択します。

全文検索…

Ctrl+Alt+Shift+F

データベースまたはデータベースのグループ内のデータを検索できる検索ウィンドウを開きます。 全文検索の詳細については、「データベースでの全文検索 」を参照してください。

テーブルをクリップボードにエクスポート

テーブル全体をクリップボードにコピーします。 このアクションは、 ページサイズの制限 設定に依存しません。

セッションの切り替え

ウィンドウを開いて別のセッションを選択するか、新しいセッションを作成します。 セッションの詳細については、 セッション を参照してください。

クイックドキュメント

Ctrl+Q

選択したオブジェクトに関する情報を表示します。 さまざまなデータベースオブジェクトについて、クイックドキュメントに対応する情報が表示されます。 例: セルのグループの場合、選択の概要が表示されます。 通常のビューまたは転置ビューでプレビューでき、関連するレコードを外部キーで表示することもできます。

クエリプランタブ

サービス ツールウィンドウの クエリプラン タブでは、PhpStorm に クエリ実行プランが表示されます。 各プラン行の詳細は、タブの右側にある別のパネルで確認できます。

テーブル名を含むセルについては、カーソルをそのセルに重ねると、ポップアップで クイックドキュメントが表示されます。

左ツールバー

アイコン

アクションとショートカット

説明

the Copy Original Query Plan icon

元のクエリプランをコピー

クエリプランをデータベースのネイティブ形式(JSON や XML など)でコピーします。

生データアイコン

Raw

Raw 内部タブで未加工の実行プランを開きます。

the Show Diagram icon

ダイアグラムの表示…

別のエディタータブでダイアグラムを開きます。

the Flame Graph icon

フレームグラフ

以下の グラフのいずれかを開きます。

  • 合計コスト: すべての行を返すのにかかる時間。

  • 開始コスト: 最初の行が処理されるまでにかかる時間。

AI による SQL プラン分析アイコン

AI で SQL プランを解析

AI Assistant に クエリプランの説明を依頼してください。

Docker

このタイプのサービスは、少なくとも 1 つの Docker インスタンスの接続設定を構成している場合に利用できます。 詳細は、 Karma を参照してください。

Docker 接続を追加する

  1. 「サービスの追加」メニューサービスの追加 をクリックし、 Docker | 接続… を選択します。

  2. Docker の接続設定を構成し、 OK をクリックします。

    詳細は、 Karma を参照してください。

メイン Docker ノード

選択した Docker 接続を操作するための主なアクションは次のとおりです。

The Connect button接続 Ctrl+Enter

選択した Docker デーモンに接続し、利用可能なすべてのイメージとコンテナーを一覧表示します。

The Disconnect button切断すると

選択した Docker デーモンを切断します。

The Edit Configuration button構成の編集 Shift+F4

選択した Docker 接続設定を編集します。

The Delete Connections buttonDelete Connections

選択した Docker デーモンへの接続を削除します。

The Pull Image buttonイメージのプル…

Docker レジストリからイメージを取得する. 詳細は、 Karma を参照してください。

Delete Connectionsクリーンアップ

停止中のすべてのコンテナー、未使用のボリュームとネットワーク、ダングリングイメージ、すべてのビルドキャッシングを削除します。

コンテナー

このノードには、対応する Docker デーモンによって管理されているすべてのコンテナーがリストされます。

Delete Connectionsクリーンアップ

停止中のすべてのコンテナーを除去します。

コンテナーを選択すると、次のアクションを使用できます。

The Start button開始

選択したコンテナーを実行します。

The Open Project buttonプロジェクトを開く

選択したプロジェクトを Docker コンテナーで開きます。

詳細については、 コンテナー内のプロジェクトファイルを操作する を参照してください。

The Restart button再開

選択したコンテナーを再起動します。

The Stop button停止

選択したコンテナーを停止します。

The Terminal buttonターミナル

選択したコンテナーでターミナルのタブを開きます。

現在のコンテナーユーザー権限でターミナルを作成するか、 root ユーザー権限でログインするかを選択できます。

More actions メニューでは、さらに多くのアクションが利用できます。

ファイルの表示

ファイル タブを開いて、コンテナーのファイルシステムを参照します。

詳細は、 Karma を参照してください。

The Inspect buttonインスペクション

コンテナーの詳細情報 (JSON 形式) を含む インスペクション タブを開きます。

詳細は、 Karma を参照してください。

The Copy Image ID buttonイメージ ID のコピー

このコンテナーの実行に使用されたイメージの ID をコピーします。

The Copy Container ID buttonコンテナー ID をコピー

コンテナーの ID をコピーします。

コンテナーダッシュボード

ダッシュボード タブには、選択したコンテナーに関する重要な情報が表示されます。

  • コンテナーの名前とハッシュ ID。 イメージ名をクリックすると、選択したコンテナーの実行に使用されたイメージをハイライトできます。

  • コンテナーで定義されている環境変数の名前と値。

  • コンテナーとホスト間のポートマッピング。

  • コンテナーとホスト間のボリュームバインディング。

追加… をクリックして、新しい変数、ポートバインディング、ボリュームバインディングを追加し、コンテナーを再作成します。

the More button をクリックして、いくつかの追加アクションを含むメニューを開きます。

イメージ

このノードには、対応する Docker デーモンによって管理されているすべてのイメージが一覧表示されます。

プルするイメージ フィールドにイメージ名を入力し、 The Pull buttonプル をクリックして、構成された Docker レジストリから新しいイメージを取得します。 詳細については、「デプロイ 」を参照してください。

イメージを選択すると、次のアクションを使用できます。

The Create Container buttonコンテナーの作成

選択したイメージから Docker コンテナーを作成します。

The Show Layers buttonレイヤーの表示

選択したイメージを構成するレイヤー (中間の内部タグなしイメージ) を表示する レイヤー タブを開きます。

The Push Image buttonイメージのプッシュ

イメージを Docker レジストリにプッシュする. 詳細は、 Karma を参照してください。

More actions メニューでは、さらに多くのアクションが利用できます。

The Copy Image ID buttonイメージ ID のコピー

選択したイメージのハッシュ ID をコピーします。

The Inspect buttonインスペクション

JSON 形式でイメージの詳細情報を含む インスペクション タブを開きます。

詳細については、 docker inspect(英語) コマンドリファレンスを参照してください。

The Show Labels buttonShow Labels

ラベル タブを開いて、イメージの ラベル を表示します。

イメージダッシュボード

ダッシュボード タブには、選択したイメージに関する重要な情報が表示されます。

  • 名前、ハッシュ ID、最新の変更日、イメージのサイズ。

  • イメージを指すタグのリスト。

  • このイメージから作成された既存のコンテナーのリスト。

ネットワーク

このノードには、対応する Docker デーモンによって管理されているすべてのネットワークが一覧表示されます。

The Create Network buttonネットワーク作成

コンテナーが動作する Docker ネットワークを作成します。

The Clean Up buttonクリーンアップ

未使用のネットワークをすべて除去します。

ネットワークダッシュボード

ダッシュボード タブには、選択したネットワークに関する重要な情報が表示されます。

  • ネットワークの名前とハッシュ ID。

  • このネットワークに接続されているコンテナーのリスト。

  • このネットワークに割り当てられているラベルのリスト。

インスペクション をクリックして、選択したネットワークで docker inspect を実行し、別のタブに出力します。

ボリューム

このノードには、対応する Docker デーモンによって管理されているすべてのボリュームが一覧表示されます。

The Create Volume buttonボリューム作成

コンテナーが使用する Docker ボリュームを作成します。

The Clean Up buttonクリーンアップ

未使用のボリュームをすべて除去します。

ボリュームを選択すると、次のアクションを使用できます。

The Inspect buttonインスペクション

ボリュームの詳細情報 (JSON 形式) を含む インスペクション タブを開きます。

詳細については、 docker inspect(英語) コマンドリファレンスを参照してください。

The Delete Volume button除去

選択したボリュームを除去します。

ボリュームダッシュボード

ダッシュボード タブには、選択したボリュームに関する重要な情報が表示されます。

  • ボリュームの名前またはハッシュ ID。

  • このボリュームを使用するコンテナーのリスト。

  • この巻の ラベル(英語)のリスト。

Docker Compose

The Start All buttonすべて起動

関連付けられた実行/デバッグ構成を使用して、選択した Docker Compose サービスをデプロイします。 詳細は、 Karma を参照してください。

The Stop button停止

選択した Docker Compose サービス内のすべてのコンテナーを停止します。

The Down buttonDown

関連するすべてのネットワーク、ボリューム、イメージを含めて、選択した Docker Compose サービス内のすべてのコンテナーを停止して除去します。

Kubernetes

このタイプのサービスは、 Kubernetes プラグイン(英語)がインストールされ、有効化されている場合に利用可能です。 PhpStorm における Kubernetes 統合の詳細については、 Kubernetes を参照してください。

The Connect Cluster buttonクラスターの接続

選択したクラスターに接続します。

The Disconnect button切断すると

選択したクラスターから切断します。

The Set Cluster as Current buttonクラスターを現在のものとして設定

選択したクラスターを現在のクラスターとして設定します。

The Open Cluster Logs Tab buttonクラスターログのタブを開く または 'ログ' タブを開く

クラスターまたはリソースのログを新しいエディタータブで開きます。 詳細については、 ログの表示 を参照してください。

The Namespace button名前空間

クラスターで利用可能なリソースをフィルターする名前空間を選択します。

The Open Kubeconfig buttonエディターで Kubeconfig ファイルを開く

Kubernetes クラスター構成ファイルを開きます。 デフォルトでは、 config という名前のファイルで、 $HOME/.kube ディレクトリ内にあります。 詳細については、 kubeconfig の編集 を参照してください。

The Add Cluster buttonコンテキストの追加

Kubernetes クラスターを追加して、 サービス ツールウィンドウに追加します。

The Show Cluster Settings buttonクラスター設定の表示

設定 | ビルド、実行、デプロイ | Kubernetes に移動します。

the Connect Telepresence buttonConnect Telepresence

Telepresence を使用してクラスターに接続します。

The View YAML buttonYAML の表示

以下の操作が可能なリソース YAML ファイルを開きます。

  • the Apply icon: 現在のコンテキストと名前空間に変更を適用します。

  • the Delete icon: 現在のコンテキストと名前空間からリソースを削除します。

  • the Refresh icon: クラスターからファイルの内容を再ロードします

  • Diff アイコン: 開いているファイルと対応するクラスターリソースの違いを差分ビューアーで表示します。

詳細については、 リソース構成ファイル を参照してください。

The Describe Resource buttonリソース情報の取得

kubectl describe コマンドと同様に、選択したリソースに関する詳細情報を表示します。

The Delete Resource buttonリソースの削除

選択したリソースをクラスターから削除します。

The Download Log buttonログのダウンロード

選択した pod のコンテナーログを 一時ファイルに保存し、エディターで開きます。

一時ファイルを使用する代わりに、ログを保存するデフォルトのパスを設定するか、毎回場所を選択できます。 pod ログのダウンロード場所を設定するには、 The Show Settings button をクリックするか、 設定 | ビルド、実行、デプロイ | Kubernetes を開きます。

The Open Console buttonコンソールを開く

選択したポッド内のコンテナーで実行されているプロセスのコンソールに接続します。

The Run Shell buttonシェルの実行

選択した pod のコンテナーに対してインタラクティブシェルを実行します。

デフォルトでは、PhpStorm は /bin/bash を実行します。 別のシェルを実行するには、 設定 | ビルド、実行、デプロイ | Kubernetes を開き、 Pod シェル フィールドに pods が使用するシェルを指定してください。

The Ephemeral Debug Containers buttonEphemeral デバッグコンテナー

現在のポッドを再起動せずに、一時デバッグコンテナーをアタッチします。 詳細については、 一時的なコンテナー を参照してください。

The Forward Ports buttonポートの転送

単一または複数のローカルポートをリモートポートに転送します。 詳細については、 ポートの転送 を参照してください。

The Stop Port Forwarding buttonポート転送の停止

選択したポート転送セッションを停止します。

The Restart Port Forwarding buttonポート転送の再開

選択したポート転送セッションを再起動します。

Dev Container

このサービスは、開いている IDE から Dev Container を起動すると使用可能になります。 詳細は、 Karma を参照してください。

通常の サービス ツールウィンドウアクションに加えて、Dev Container 固有のアクションを使用してコンテナーを管理できます。

Action

説明

接続

Dev Container が構築されたら、このアクションを使用して、作成または既存のコンテナーに接続できます。

再開

このアクションを使用して、Dev Container を再構築します。

停止

このアクションを使用して、Dev Container の実行を停止します。

the More button をクリックして、いくつかの追加アクションを含むメニューを開きます。

Action

説明

ターミナル

このオプションを使用して、選択した Dev Container 内でターミナルセッションを開きます。

ファイルの表示

このオプションを使用すると、選択した Dev Container にあるファイルとディレクトリのリストが表示されます。

インスペクション

このオプションを使用して、選択した Dev Container の情報を表示します。

イメージ ID のコピー

このオプションは、選択した Dev Container イメージの ID をコピーします。

コンテナー ID をコピー

このオプションは、選択した Dev Container の ID をコピーします。

生産性のヒント

タブを使用する

サービス ツールウィンドウには多数のサービスを含めることができ、種類ごとにグループ化したり、独自のカスタムグループ用に別個のタブを作成したりできます。 たとえば、開発中のアプリケーションの実行構成、アプリケーションのバックエンドとして使用されるデータベースを実行する Docker コンテナー、データベースにアクセスするためのコンソールを含むタブを作成できます。

サービスツリーを非表示にする

サービス ツールウィンドウのツールバーの右側にある The Show Options Menu button をクリックし、次に サービスツリーの表示 をクリックしてチェックボックスを外します。 Ctrl+Shift+T を押してサービスツリーを切り替えることもできます。

サービスツリーを非表示にすると、サービスナビゲーションバーに置き換えられます。 Alt+Home を押してサービスナビゲーションバーにフォーカスを合わせます。

サービスを非表示、除去、削除する

任意のサービスを右クリックし、 削除 Delete を選択して、対応する実行構成、Docker 接続などを完全に削除します。

特定のタイプの実行 / デバッグ構成を サービス ツールウィンドウに表示したくない場合は、対応する構成を右クリックして サービスから構成タイプを除去 を選択します。 これは実際の構成を削除しません。

サービス ツールウィンドウから特定の実行構成を非表示にするには、対応する構成を右クリックして 構成を非表示 を選択します。 すべての非表示の実行構成を表示するには、 the Add Service menu をクリックして 非表示の構成を復元 を選択します。

2026 年 11 月 9 日