PhpStorm 2026.3 Help

Vite

PhpStorm は、フロントエンド開発エクスペリエンスを向上させる Vite ビルドツールと統合されています。 Vite は開発サーバーとビルドコマンドで構成されています。 開発サーバーは、ネイティブ ES モジュールを介してソースファイルを提供します。 ビルドコマンドは、事前構成済みで本番環境向けに高度に最適化された静的アセットを出力する Rollup でコードをバンドルします。

PhpStorm は、Vue style タグで tsconfig.json および jsconfig.json パスマッピングをサポートし、 Vite エイリアス(英語)を認識します。

異なる Vite 構成を持つ複数のモジュールで構成されるプロジェクトでは、PhpStorm は各モジュールに関連する構成ファイルを自動的に検出し、そこからモジュール解決ルールを使用できます。以下の 使用する Vite 構成ファイルの指定を参照してください。

始める前に

  1. Node.js をダウンロードしてインストールします。

  2. JavaScript and TypeScript と Vite の必須プラグインが 設定 | プラグイン ページで有効化されていることを確認してください。 詳細については、 プラグインの管理を参照してください。

新しい Vite アプリケーションを作成する

新しい Vite アプリケーションを開始するための推奨方法は create-vite パッケージで、PhpStorm が npx を使用してダウンロードおよび実行します。 その結果、開発環境は Vite と、 React、 Vue.js、 Svelte などの一般的なフレームワークのいずれか向けの基本テンプレートを使用するように事前構成されます。

もちろん、自分で create-vite をダウンロードしたり、空の PhpStorm プロジェクトを作成してそこに Vite をインストールしたりすることもできます。

create-vite で Vite アプリケーションを生成する

  1. ようこそ 画面で 新規プロジェクト をクリックするか、メインメニューから ファイル | 新規 | プロジェクト を選択します。 新規プロジェクトダイアログが開きます。

  2. 左側のペインで、 Vite を選択します。

  3. 右側のペインで:

    1. プロジェクト関連ファイルが保存されるフォルダーへのパスを指定します。

    2. ノードランタイム フィールドで使用する Node.js ランタイムを指定します。 リストから設定済みのランタイムを選択するか、 追加 を選択して新しいランタイムを設定してください。

    3. Vite リストから npx create-vite を選択してください。

      または、npm バージョン 5.1 以前の場合、 ターミナル Alt+F12 で npm install --g create-vite を実行して、 create-vite パッケージを自分でインストールします。 アプリケーションを作成するときに、 create-vite パッケージが保存されているフォルダーを選択します。

    4. テンプレート リストから、アプリケーションで使用する予定のフレームワークを対象とする、 コミュニティが管理する Vite テンプレート(英語)を選択します。

    5. オプション:

      JavaScript の代わりに TypeScript を使用するには、 TypeScript テンプレートの使用 チェックボックスを選択します。 PhpStorm は、アプリケーション用の .ts ファイルと tsconfig.json 構成ファイルを生成します。

  4. 作成 をクリックすると、PhpStorm は必要なすべての構成ファイルを含む Vite-specific プロジェクトを生成し、必要な依存関係をダウンロードします。 PhpStorm は、アプリケーションを実行するためのデフォルト設定を含む npm dev 構成も作成します。

空の PhpStorm プロジェクトに Vite をインストールする

この場合、ビルドパイプラインを自分で構成する必要があります。 Vite オフィシャル Web サイト(英語)からプロジェクトに Vite を追加する方法については、こちらを参照してください。

空の PhpStorm プロジェクトを作成する

  1. ようこそ 画面で 新規プロジェクト をクリックするか、メインメニューから ファイル | 新規 | プロジェクト を選択します。 新規プロジェクトダイアログが開きます。

  2. 左側のペインで、 PHP 空プロジェクト を選択します。 右側のウィンドウで、アプリケーションフォルダーを指定し、 作成 をクリックします。

空のプロジェクトに Vite をインストールする

  1. Vite を使用する空のprojectを開きます。

  2. コマンドライン シェルまたは組み込みの ターミナル (Alt+F12 )で、次のように入力してください:

    npm install --save-dev vite

既存の Vite アプリケーションから始める

既存の Vite アプリケーションの開発を継続するには、IntelliJ IDEA で開き、必要な依存関係をダウンロードします。

すでにマシン上にあるアプリケーションソースを開く

  • ようこそ 画面で 開く をクリックするか、メインメニューから ファイル | ディレクトリを開く を選択します。 開いたダイアログで、ソースが保存されているフォルダーを選択します。

バージョン管理からアプリケーションのソースをチェックアウト

  1. ようこそ 画面で リポジトリのクローン をクリックします。

    あるいは、メインメニューから ファイル | 新規 | バージョン管理からプロジェクト…、 Git | クローン…、 VCS | バージョン管理から取得 を選択します。

    メインメニューの Git の代わりに、プロジェクトに関連付けられている他のバージョン管理システムが表示される場合があります。 例: Mercurial または Perforce。

  2. 表示されるダイアログで、リストからバージョン管理システムを選択し、アプリケーションソースをチェックアウトするリポジトリを指定します。 詳細については、 プロジェクトをチェックアウトする (クローン) を参照してください。

依存関係をダウンロードする

  • ポップアップで 'npm install' の実行 または 実行 'yarn install' をクリックします。

    アプリケーションを開いて依存関係をダウンロードする

    npm、 Yarn 1 、または Yarn 2 を使用できます。詳細については、 npm と Yarn を参照してください。

  • または、エディターの package.json のコンテキストメニュー、または Project ツールウィンドウ (Alt+1) で 'npm install' の実行 または 実行 'yarn install' を選択します。

プロジェクトのセキュリティ

IntelliJ IDEA の外部で作成され、そこにインポートされたプロジェクトを開くと、IntelliJ IDEA は、未知ソースコードを使用してこのプロジェクトを処理する方法を決定できるダイアログを表示します。

次のいずれかのオプションを選択します。

  • セーフモードでプレビュー: この場合、PhpStorm はプロジェクトをプレビューモードで開きます。 これは、プロジェクトのソースを参照することはできますが、タスクやスクリプトを実行したり、プロジェクトを実行 / デバッグしたりすることはできないことを意味します。

    PhpStorm はエディター領域の上部に通知を表示し、 プロジェクトを信頼する… リンクをクリックして、いつでもプロジェクトをロードできます。

  • プロジェクトを信頼: この場合、PhpStorm はプロジェクトを開いてロードします。 これは、プロジェクトが初期化され、プロジェクトのプラグインが解決され、依存関係が追加され、すべての PhpStorm 機能が使用可能になることを意味します。

  • 開かない: この場合、PhpStorm はプロジェクトを開きません。

プロジェクトのセキュリティ の詳細を参照してください。

PhpStorm で Vite を構成する

Vite 構成ファイルを作成する

  • プロジェクト構造に応じて、単一または複数の構成ファイルを作成します。 Project ツールウィンドウ (Alt+1) で親フォルダーを選択し、コンテキストメニューから 新規 | JavaScript ファイル を選択します。

    Vite 構成ファイルを作成する

    受け入れ可能な名前は vite.config.js / vite.config.ts 、 vite.config.mjs または vite.config.cjs です。

    Vite オフィシャル Web サイト(英語)の詳細を参照してください。

  • 必要に応じて、後で import ステートメントで認識される alias を使用します。 エイリアスの定義では必ず絶対パスを指定してください。 Vite オフィシャル Web サイト(英語)から詳細を参照してください。

    Completing alias in import statements

使用する Vite 構成ファイルを指定する

Vite 構成ファイルの分析に基づいて、IntelliJ IDEA は Vite 構成を理解し、モジュールを解決し、JavaScript および TypeScript ファイルのコーディング支援を提供します。

IntelliJ IDEA では、自動と手動の 2 つの構成モードから選択できます。

自動構成では、PhpStorm は各 JavaScript または TypeScript ファイルに関連する Vite 構成ファイルを自動検出します。

手動構成では、プロジェクトで使用する Vite 構成ファイルを指定します。 手動構成は、Vite 構成ファイルの名前が PhpStorm に認識されない場合に便利です。以下の 認識される Vite 構成名のリストを参照してください。

Vite 構成を検出する方法を選択する

  1. 設定 ダイアログ(Ctrl+Alt+S )を開き、 言語 & フレームワーク | JavaScript | Vite に進みます。

  2. モジュール解決のための Vite 構成ファイルの検出 領域で、次のいずれかのオプションを選択します。

    • 自動:: このモードでは、JavaScript または TypeScript ファイルの場合、PhpStorm は最初にこの JavaScript または TypeScript ファイルが配置されているフォルダーで Vite 構成ファイルを探し、次にその親フォルダーで探します。

      その結果、プロジェクトが異なる Vite 構成の複数のモジュールで構成されている場合、各モジュールは独自の Vite 構成ファイルのモジュール解決ルールを使用します(そのような構成が見つかった場合)。

      IntelliJ IDEA は、次の名前の JavaScript または TypeScript Vite 構成ファイルを次の順序で認識します。

      • vite.config.js / vite.config.ts

      • vite.config.mjs

      • vite.config.cjs

    • 手動: 構成ファイル フィールドで、使用する Vite 構成の場所を指定します。

      このモードでは、指定された構成ファイルの解決ルールがプロジェクト内のすべてのモジュールに適用されます。

      Vite 構成ファイルの名前が PhpStorm で認識されない場合は、このオプションを選択します。上記の 認識される Vite 構成名のリストを参照してください。

      vite 構成ファイルを手動で選択する

Vite アプリケーションを実行する

  1. package.json の dev スクリプトの横にあるガターで the Run icon をクリックするか、 ターミナル Alt+F12 で npm run dev コマンドを実行するか、 npm ツールウィンドウ (表示 | ツールウィンドウ | npm )で dev タスクをダブルクリックします。

    Run a Vite app in the development mode from package.json
  2. アプリケーションがコンパイルされ、開発サーバーの準備ができるまで待ちます。

    実行 ツールウィンドウまたは ターミナル には、アプリケーションが実行されている URL が表示されます。 アプリケーションが create-vue で生成された場合、デフォルトの URL は http://localhost:5173/ です。 このリンクをクリックすると、アプリケーションが表示されます。

    Vue.js アプリは開発モードで実行されています

実行 / デバッグ構成を介して Vite アプリケーションを実行する

上記のように、PhpStorm 新規プロジェクト ウィザードで create-vite を使用して作成されたアプリケーションの場合、PhpStorm はデフォルト名 npm dev で npm 構成を生成します。 この構成は、開発サーバーを起動し、開発モードでアプリケーションを起動する vite コマンドを実行します。

それ以外の場合は、ホスト、ポートなどの実際の設定を手動で 実行 / デバッグ構成を作成するする必要があります。

npm 実行 / デバッグ構成を作成する

  1. 実行 | 実行構成の編集 に進みます。 または、ツールバーの 実行 ウィジェットから 実行構成の編集 を選択します。

    構成の編集を開くダイアログ

    開いた 実行構成の編集 ダイアログで、ツールバーの 追加 ボタン (追加ボタン) をクリックし、リストから npm を選択します。

  2. 開いた 実行 / デバッグ構成: npm ダイアログの 構成 タブで、 package.json の場所、Node.js ランタイム、および使用するパッケージマネージャーを指定します。

    Command フィールドで、リストから run を選択し、次に スクリプト リストから実行するスクリプトを選択します。 ほとんどの場合、デフォルトの dev スクリプトになりますが、カスタムポートでアプリケーションを実行するなど、 package.json で別のスクリプトを構成することもできます。

    npm 実行 / デバッグ構成
  3. オプション:

    ブラウザーでアプリケーションを開くには、構成を次のように更新します: ブラウザー / Live Edit タブで、 起動後 チェックボックスをオンにし、アプリケーションを開くブラウザーを選択して、アプリケーションが実行される URL アドレスを指定します。

    アプリケーションをデバッグする場合は、 Google Chrome(英語) または別の Chromium ベースのブラウザー(英語)を選択します。

    ブラウザー / ライブ編集タブ: ブラウザーを選択

アプリケーションの実行

  1. ツールバーのリストから npm dev run 構成を選択し、その横にある 実行 をクリックします。

    実行 / デバッグ構成を介して開発モードで Vite アプリを実行する
  2. アプリケーションがコンパイルされ、開発サーバーの準備ができるまで待ちます。

    実行 ツールウィンドウまたは ターミナル には、アプリケーションが実行されている URL が表示されます。 このリンクをクリックすると、アプリケーションが表示されます。

    Vite アプリの実行: 開発サーバーの準備ができました

    または、 上記のように、 PhpStorm が起動時にアプリケーションを開くようにします。

Vite アプリケーションをデバッグする

デバッグセッションは、 実行 / デバッグ構成を起動するから開始することも、開発モードでアプリケーションが実行されている URL を表示する 実行ツールウィンドウから開始することもできます。

実行 / デバッグ構成を介してデバッグを開始する

Vite アプリケーションをデバッグするには、二つの実行/デバッグ構成が必要です:

  • 上記のように、開発モードでアプリケーションを起動するための npm 構成。

  • 開発モードで実行されているアプリケーションにデバッガーを接続するための JavaScript Debug 構成。

npm 実行 / デバッグ構成を使用して Vite アプリケーションを実行およびデバッグするに従って、 npm 構成内に JavaScript Debug 構成を作成して、一度に起動することができます。

または、 JavaScript デバッグ実行 / デバッグ構成でデバッグを開始するに従って、 npm と JavaScript Debug の実行/デバッグ構成を個別に作成して起動します。

単一の npm 実行 / デバッグ構成で Vite アプリケーションを実行およびデバッグする

  1. コードに ブレークポイントを設定します。

  2. 上記の説明に従ってnpm 構成を作成します。

    create-vite を使用してアプリケーションを生成した場合、PhpStorm は npm dev というデフォルト名の npm 構成をすでに作成しています。 この構成は、 実行 ウィジェットおよび 実行 / デバッグ構成 ダイアログから利用できます。

    自動生成された npm 実行 / デバッグ構成
  3. 開いた 実行 / デバッグ構成: npm ダイアログの 構成 タブで、 package.json の場所、Node.js ランタイム、および使用するパッケージマネージャーを指定します。

    Command フィールドで、リストから run を選択し、次に スクリプト リストから実行するスクリプトを選択します。 ほとんどの場合、デフォルトの dev スクリプトになりますが、カスタムポートでアプリケーションを実行するなど、 package.json で別のスクリプトを構成することもできます。

    npm 実行 / デバッグ構成
  4. ブラウザー / Live Edit タブで、 起動後 チェックボックスを選択し、リストから Google Chrome(英語) または別の Chromium ベースのブラウザー(英語)を選択し、 JavaScript デバッガーを使用 チェックボックスを選択して、アプリケーションを実行する URL を指定します。

    ブラウザー / ライブ編集タブ: ブラウザーを選択
  5. 実行 をクリックします。

    構成を再実行するには、 実行 ウィジェットのリストから構成を選択し、その横にある 実行 をクリックします。

    IntelliJ IDEA はアプリケーションを開発モードで実行し、同時にデバッグセッションを起動します。

    セッションのデバッグ
  6. 最初のブレークポイントに到達したら、 デバッグツールウィンドウに切り替えて、通常どおり続行します: プログラムをステップ実行し、プログラムの実行を 一時停止および再開し、 中断時に調査し、コールスタックと変数を確認し、ウォッチを設定し、変数を評価し、 実際の HTML DOM を表示するなどです。

    ソースマップを無視して実際に実行されているコードをステップ実行するには、 ソースマップ無効化トグルボタン を デバッグ ツールウィンドウのツールバーで押してください。

JavaScript デバッグ実行 / デバッグ構成でデバッグを開始する

  1. コードに ブレークポイントを設定します。

  2. 上記のように開発モードでアプリケーションを起動し、アプリケーションがコンパイルされて開発サーバーの準備ができるまで待ちます。

    実行 ツールウィンドウまたは ターミナル には、アプリケーションが実行されている URL が表示されます。 この URL をコピーして、 後で JavaScript デバッグ構成で指定します。

    アプリケーションは開発モードで実行されています
  3. JavaScript Debug 構成を作成します。 これを行うには、メインメニューの 実行 | 実行構成の編集 に移動し、 追加アイコン をクリックして、リストから JavaScript デバッグ を選択します。

  4. 開いた 実行 / デバッグ構成: JavaScript デバッグ ダイアログで、構成の名前と、開発モードでアプリケーションが実行されている URL アドレスを指定します。 この URL は、 上記のように、 実行 ツールウィンドウまたは ターミナル にコピーできます。

    JavaScript デバッグ構成を作成する: URL を指定する
  5. デバッグ をクリックします。

    構成を再実行するには、 実行 ウィジェットのリストから構成を選択し、その横にある デバッグ をクリックします。

    実行ウィジェットから JavaScript デバッグ構成を実行する
  6. 最初のブレークポイントに到達したら、 デバッグツールウィンドウに切り替えて、通常どおり続行します: プログラムをステップ実行し、プログラムの実行を 一時停止および再開し、 中断時に調査し、コールスタックと変数を確認し、ウォッチを設定し、変数を評価し、 実際の HTML DOM を表示するなどです。

    ソースマップを無視して実際に実行されているコードをステップ実行するには、 ソースマップ無効化トグルボタン を デバッグ ツールウィンドウのツールバーで押してください。

実行ツールウィンドウまたは組み込みのターミナルからデバッグを開始する

アプリケーションが localhost の開発モードで実行されている場合、特に create-vite で生成された場合は、 >実行 ツールウィンドウまたは組み込みの ターミナル から直接デバッグセッションを開始できます。

  1. コードに ブレークポイントを設定します。

  2. 上記のように開発モードでアプリケーションを起動し、アプリケーションがコンパイルされて開発サーバーの準備ができるまで待ちます。

  3. 実行 ツールウィンドウまたは ターミナル には、アプリケーションが実行されている URL が表示されます。 Ctrl+Shift を押したまま、この URL リンクをクリックします。 PhpStorm は、タイプ JavaScript デバッグの自動生成された 構成でデバッグセッションを開始します。

    Starting a debugging session from the Run tool window, the application is running on localhost

    新しいターミナルから開発モードでアプリケーションを起動した場合は、リンクの横にある ブラウザーでデバッグを開始する ボタンをクリックするだけです。

    新しいターミナル: ブラウザーでデバッグを開始ボタン

    デフォルトでは、ボタンは表示されません。 ボタンを表示するには、 設定 ダイアログ(Ctrl+Alt+S )を開き、 詳細設定 に移動して、 JavaScript and TypeScript 領域で ターミナルの localhost リンクに 'ブラウザでデバッグを開始' ボタンを表示する チェックボックスを選択します。

最初のブレークポイントに到達したら、 デバッグツールウィンドウに切り替えて、通常どおり続行します: プログラムをステップ実行し、プログラムの実行を 一時停止および再開し、 中断時に調査し、コールスタックと変数を確認し、ウォッチを設定し、変数を評価し、 実際の HTML DOM を表示するなどです。

ソースマップを無視して実際に実行されているコードをステップ実行するには、 ソースマップ無効化トグルボタン を デバッグ ツールウィンドウのツールバーで押してください。

Node.js 17 以降のトラブルシューティング

Node.js バージョン 17 以降を使用している場合、デバッグセッション中にネットワーク接続の問題が発生し、デバッガーの接続やソースマップのロードで問題が発生する可能性があります。

回避策は、 --host 127.0.0.1 をサーバーに渡すことです。 これは、次のいずれかの方法で行うことができます。

  • package.json の dev スクリプトを更新します。

    "dev": "vite --host=127.0.0.1"
  • あるいは、 dns.setDefaultResultOrder('ipv4first') を vite.config.ts に追加します。

2026 年 11 月 9 日