PyCharm 2020.3 Help

Welcome screen

PyCharm displays the Welcome screen when no project is opened. For example, when you run PyCharm for the first time, or when you close the only open instance of a project. From this screen, you can create a new project, start you learning path with PyCharm Edu,import,open, or check out an existing project from version control.

The Welcome screen

Use the Customize tab to configure your working environment and the Plugins tab to manage the IDE plugins.

Open the Learn PyCharm tab to find numerous resources to get acquainted with the IDE. Expand the list of available interactive courses to choose the one that you would like to try. PyCharm will open a specific learning project to study the topic step-by-step in a real environment. Follow the instructions in the Learn view to test your new skills on actual coding samples.

If you have previously opened projects in PyCharm, you will see a list of them in the right-hand pane. You can start typing to find a project, click to open it, or remove any project from the list using the context menu or the screw nut icon.

Recent projects on the Welcome screen

From the Help menu, you can open help pages, tips of the day, and the default keymap reference, edit platform properties, collect logs and diagnostic data, and check for updates:

Help menu on the Welcome screens

Last modified: 23 November 2020