PyCharm 2021.2 Help

Open, reopen, and close projects

If you open your project for the very first time, you see the Welcome Screen. You can either open your project from the disk, or download it from the version control system.

Opening a project

Open your project from disk

  1. Do one of the following:

    • On the Welcome Screen, click the Open link.

    • From the main menu, select File |Open.

  2. In the Open File or Project dialog that opens, find location of the desired project directory. The PyCharm project are marked with JB IDE project and projects created in other IDEs or in a dedicated editor are marked with a directory icon.

    If you select a non-PyCharm directory, PyCharm creates a new IDE project and sets up a Python interpreter.

  3. Click OK.

Open a project from Git

  1. Do one of the following:

    • On the Welcome Screen, click the Get from Version Control link.

    • From the main menu, select VCS | Get from Version Control.

  2. Select the version control system where your project is stored. Here it is Git:

    Open a project from VCS

  3. Specify the path to the repository and select the directory to which a project will be cloned. Alternatively, you can select GitHub on the left, login using your credentials, and select any project you want to work with.

  4. Click Clone.

Open a project from the command line

Once you have opened the project, you should configure Python interpreter for it (in particular, create a virtual environment), and set up your project.

If your project was previously configured with any interpreter that is not currently available, PyCharm shows a warning and provides two options: select an interpreter that fits the previous configuration or configure another Python interpreter:

A warning message with the options to configure a project interpreter

Note, when you open a project configured for the outdated version of the Python interpreter, the following message appears: notification on the unsupported version of the Python interpreter Click Configure Python interpreter to set up a valid one.

You can close a project that has been added to the currently opened one (primary project).

Managing multiple projects

PyCharm suggests the following alternatives to work with several projects simultaneously:

  1. Each project is opened in its own window. The projects are independent, and cannot share information, except for the Clipboard operations. All the projects run in the same instance of PyCharm and use the same memory space.

  2. A newly opened project shares the same window as the already opened one. The project that has already been opened, is considered the primary project, and is always shown first in the Project tool window. All the other projects are added to the primary project. You can import classes and methods from dependent projects

Open multiple projects

  • Open a project, while another one is already opened.

    Then, depending on the option selected in the Project Opening section of the System Settings page of the Settings/Preferences dialog Ctrl+Alt+S, PyCharm can ask you for the following alternatives:

    • If the New Window option is selected, the new project silently opens in a new window. The Attach option appears in the File menu.

    • If the This Window option is selected, the new project silently opens in the same window, replacing the currently opened project. The Attach Project command appears in the File menu.

    • If the Attach option is selected, PyCharm attaches the new project to the currently opened project. The project that has already been opened is the primary project.

      Open the project in the current window, new window, or attach it to the existing project

Manage project dependencies

  1. Press Ctrl+Alt+S to open IDE settings and select Project <project name> | Project Dependencies.

  2. Select a project in the Projects pane, than select the checkboxes to the left of the names of the desired projects to add them as dependencies.

    Managing project dependencies
  3. Use the arrow buttons Icons actions previous occurence Icons actions next occurence to change the order of the dependent projects, in which they appear in the PYTHONPATH variable.

Some settings (such as Django, Buildout, Google App Engine, template languages, Python interpreters, content roots) can be configured separately for each project.

You can close a project that has been added to the currently opened one (primary project).

Delete a project from view

  1. In the Project tool window, right-click the project to be deleted.

  2. From the context menu of the selection, choose Remove from Project View, or press Delete:

    Remove from the project view

When PyCharm starts, the most recent project reopens by default (unless this option is disabled on the System Settings page of the Settings/Preferences dialog Ctrl+Alt+S.

Reopening recent projects

PyCharm keeps the history list of the recent projects, from which you can select the desired one.

When PyCharm starts, the most recent project reopens by default (unless this option is disabled on the System Settings page of the Settings/Preferences dialog Ctrl+Alt+S.

Open a recent project

  • Call File | Open Recent from the main menu and select the desired project from the list.

    Note that the list also contains the projects that share one window.

    Specify whether you want to open the project in a new window, reuse the current window, or attach it to the currently opened project.

  • On the Welcome screen, click Projects on the left-hand pane and then select the project of interest in the right-hand pane where the list of your recent projects is shown. Start typing in the Search projects field to filter the list of recent projects.

Closing projects

If you need to close only one project, you can either close the project window or select File | Close Project from the main menu.

If you work with multiple projects, use the following actions to close many projects at once:

Close all projects

  • From the main menu, select File | Close All Projects.

    This action closes all projects that are currently opened in PyCharm.

Close all but the current project

  • From the main menu, select File | Close Other Projects.

    This action closes all opened projects except the current one.

When you have only one open project and you close it, PyCharm displays the Welcome screen. In case of multiple projects, each one is closed with its frame.

Remove a project from the list of recent projects

  • Click Open Recent on the File menu, then click Manage Projects at the very bottom of the recent project list.

  • Click the closing icon for the project to remove.

    Remove a recent project from the list of the recent projects
    The selected project will be removed from the list of the recent project in the Project window and on the Welcome screen.

To remove a project only from the list on the Welcome Screen, right-click the target project and select Remove Selected from Welcome Screen.

Remove a project from the list of the recent projects on the Welcome Screen

Switching between projects

To switch between open projects, you can use the following commands of the Window menu:

  • Window | Next Project Window Ctrl+Alt+]

  • Window | Previous Project Window Ctrl+Alt+[

  • Window | <ProjectNameOrLocation>
Last modified: 16 July 2021