PyCharm 2023.3 Help

Index of Menu Items

PyCharm menu structure doesn't align with PyCharm help structure. This page lists PyCharm menu items, linked to the corresponding help topics.

File

Menu item

Keyboard shortcut

Description

New Project

Use this command to create a new project.

New...

Alt+Insert

Use this command to create a new element in a project. This command is only available in the corresponding context.

New Scratch File

Control+Alt+Shift+Insert

Choose this command to create a new scratch file.

Open...

Use this command to open the specified directory, or an existing PyCharm project. A directory that contains a project is marked with Project icon icon.

This command is duplicated with the Open icon on the main toolbar.

Open URL...

Use this command to open source code of a web page in the editor.

Learn and Teach

This group of commands enables basic learning operations.

Browse courses

Opens the list of the available courses. To see more courses, you need to login to Stepik.

Start Coursera Assignment

Select and initiate working with Coursera assignment.

Import Course

Open any course that is located in your file system.

Start Stepik Course

Begin working with the Stepik course.

Create New Course

Use this command to creating a new learning course. The item is available only when you explicitly select Enable Course Creator Features in the Help menu.

Save as...

Use this command to save a file currently opened in the editor, in the specified directory. This operation produces the same result, as copy refactoring.

Attach Project

This command appears on the File menu, ONLY when the options Open project in a new window or Open project in the same window have been selected in the Project opening section of the System Settings page of Settings. It allows attaching projects to the already opened one. See Managing multiple projects.

Open Recent

Use this command to open one of the recent projects.

Close Project in Current Window

Use this command to close all the projects opened in the current window .

Course Creator

Point to this node to reveal the nested commands:

Change Course Information

Choose this command to change the course information (course title, author name, description text) and the Python version used.

Generate Course Archive

Choose this command to create a zip archive of the current project. The archive resides in the specified location.

This action is available for the educator's course projects.

Unpack Course Archive

Choose this command to create a course based on the existing zip archive.

Upload Course to Stepic

Choose this command to upload your course to Stepic.

Preview Course

Choose this command to quickly create a students’ course from the current educators’ course.

This node is duplicated from the context menu of the Project tool window.

Settings... on Windows/Linux, PyCharm | Preferences on macOS

Control+Alt+S

Use this command to change the project and IDE configurations in the Settings dialog. See also the section Configuring PyCharm settings.

This command is duplicated with Settings icon on the main toolbar.

This command in available on Windows/Linux. On macOS, it appears on the PyCharm menu and has the name Preferences.

Settings for New Projects...

Choose this command to change settings that will apply to all newly created projects. For more information, refer to Configure default project settings.

Import Settings...

Choose this command to import settings from an archive.

Export Settings...

Choose this command to export settings to an archive.

Settings Repository...

Choose this command to invoke the Settings Repository dialog.

Sync Settings to JetBrains Account

Choose this command to synchronize the settings across all IDE installations where you log in with your JetBrains account.

Save All

Control+S

Choose this command to save all changes, when editing is over.

This command is duplicated with Save all icon on the main toolbar.

Reload All from Disk

Control+Alt+Y

Choose this command to check the PyCharm caches and bring them up-to-date by keeping in sync with external changes.

This command is duplicated with Reload All from Disk icon on the main toolbar.

Invalidate Caches...

Choose this command to clean the system cache.

Save File as Template

Choose this command to save the current file as a template file.

Files or Selection to HTML

Use this command results to save selected files in HTML format.

Print...

Choose this command to print selected file on the default printer. For more information, refer to the Print dialog description.

File Encoding

Use this command to change encoding of an individual file.

Line Separators

Use this command to select the desired line separator style. Learn more from Configure line separators.

Make File Read-Only / Make File Writable

Use these toggle commands to change read-only status of a file selected in the Project tool window, or currently active in the editor. If a file is made read-only, it is marked with Make File Read-Only / Make File Writable, and doesn't allow editing.

You can also toggle read-only attribute of a file in the Status bar.

Power Save Mode

Use this mode if you are working with a laptop. If Power-Save mode is on, then the background processes are turned off, to minimize the power consumption.

Exit

Select this command to quit PyCharm.

This command in available on Windows/Linux. On macOS, it appears on the PyCharm menu and has the name Quit PyCharm.

Edit

Menu item

Keyboard shortcut

Description

Undo <action>

Control+Z

Use this command to roll actions back.

This command is duplicated with Undo action icon on the main toolbar.

Redo <action>

Control+Shift+Z

Use this command to repeat the last actions.

This command is duplicated with Redo action icon on the main toolbar.

Cut

Control+X

Choose this command to take the selected characters to the clipboard and delete them. For more information, refer to Select code constructs.

This command is duplicated with Cut icon on the main toolbar.

Copy

Control+C

Choose this command to take the selected characters to the clipboard. For more information, refer to Cutting, Copying, and Pasting.

This command is duplicated with Copy icon on the main toolbar.

Copy Path/Reference

Control+Shift+C

Choose this command to take the path to the selected symbol to the clipboard. For more information, refer to Cutting, Copying, and Pasting.

Copy as Rich Text

Control+Shift+C

Choose this command to take the selected fragment to the clipboard without formatting. For more information, refer to Settings | Editor | General.

Copy Relative Path

Control+Alt+Shift+C

Choose this command to take a reference to a symbol to the clipboard. For more information, refer to Cutting, Copying, and Pasting.

Paste

Control+V

Choose this command to place the latest entry from the Clipboard at the insertion point. For more information, refer to Cutting, Copying, and Pasting.

This command is duplicated with the Paste icon on the main toolbar.

Paste from History...

Control+Shift+V

Choose this command to place at the insertion point the selected entry from the Clipboard. For more information, refer to Cutting, Copying, and Pasting.

Paste Simple

Control+Alt+Shift+V

Choose this command to place the last entry from the Clipboard at the insertion point as plain text. For more information, refer to Select code constructs.

Delete

Delete

Choose this command to delete the selected files, or folder from the project tool window, or selected fragment of text from the active editor.

Find

Point to this node to reveal the sub-menu of search commands:

Find/Replace

Control+F/Control+R

Find or replace text in a current file.

These commands are duplicated by Find and Rename favorites icons on the main toolbar.

Find Next/Find Previous (Move to Next/Previous Occurrence)

F3/Shift+F3

Use these commands to navigate through the search results in a file. For more information, refer to Find and replace in file.

Next Occurrence of the Word at Caret

Control+F3

Use this command to jump to the next occurrence of the word where the caret rests. For more information, refer to Find and replace in file.

Select All Occurrences

Control+Alt+Shift+J

Use this command to find and select all the occurrences of an item.

Add Selection for Next Occurrence

Alt+J

Use this command to select the next occurrence of an item.

Unselect Occurrence

Alt+Shift+J

Use this command to remove selection from the last selected occurrence of an item.

Find in Files/Replace in Path

Control+Shift+F/Control+Shift+R

Use these commands to search for, and replace a text fragment in a whole project. For more information, refer to Finding and Replacing text in Project.

Search/Replace Structurally

Use these commands to perform structural search or replace. For more information, refer to Structural search and replace.

Find Usages

Alt+F7

Use this command to search for the usages of a symbol across an entire project. For more information, refer to Find usages in a project.

Find Usages Settings

Control+Alt+Shift+F7

Use this command to search for the usages of a symbol across an entire project, after setting the desired search options. For more information, refer to Find usages in a project.

Show Usages

Control+Alt+F7

Use this command to bring up a list of the usages of a symbol across the whole project. For more information, refer to View usages of a symbol.

Find Usages in a File

Control+F7

For more information, refer to Find usages in the current file.

Highlight Usages in a File

Control+Shift+F7

Use this command to visualize usage of a symbol in the current file. For more information, refer to Highlight usages.

Recent Find Usages

Control+E

Choose this command to view the recent search results. For more information, refer to View recent find usages.

Macros

Point to this node to reveal the sub-menu of the macros-related commands. For more information, refer to Macros.

Column Selection Mode

Alt+Shift+Insert

Use this command to toggle between column selection and line selection modes. For more information, refer to Work with source code.

Select All

Control+A

Choose this command to select all contents of the current file. For more information, refer to Work with source code.

Extend Selection

Control+W

Choose this command to select the current word. Use this command successively to extend selection. For more information, refer to Work with source code.

Shrink Selection

Control+Shift+W

Choose this command to unselect the currently selected word. Use this command successively to shrink selection. For more information, refer to Work with source code.

Join Lines

Control+Shift+J

Choose this command to join lines or literals.

Fill Paragraph

Choose this command to create soft wraps in a paragraph.

Duplicate Lines

Control+D

Choose this command to duplicate a line or fragment of text. For more information, refer to Lines of code.

Indent Selection/Unindent Line or Selection

Tab/Shift+Tab

Choose this command to change indentation of the line at caret. For more information, refer to Reformat and rearrange code.

Toggle Case

Control+Shift+U

Choose this command to change case of the selection. For more information, refer to Lines of code.

Convert Indents

Point to this node to reveal the sub-menu of the possible indentation and toggle indentation style. For more information, refer to Reformat and rearrange code.

Encode XML/HTML Special Characters

Choose this command to convert the selected special character to its HTML name in the format &char;.

Edit as Table...

Choose this command to invoke the data editor for the current documents.

View

Menu item

Keyboard shortcut

Description

Tool Windows

Point to this node to reveal the list of the available tool windows. For more information, refer to Arrange tool windows.

Appearance

Use the commands from this group to configure the apearance of the PyCharm user interface. For more information, refer to User interface.

Enter/Exit Presentation Mode

Choose this command to enter or exit presentation mode.

Enter/Exit Distraction Free Mode

Choose this command to enter or exit distraction-free mode.

Enter/Exit Full Screen

Choose this command to enter or exit full screen mode.

Toolbar

Enable or disable this option to show or hide the main toolbar.

Tool Windows Bar

Enable or disable this option to show or hide the tool window buttons.

Status Bar

Enable or disable this option to show or hide the Status toolbar.

Navigation Bar

Enable or disable this option to show or hide the Navigation bar.

Main menu

Enable or disable this option to show or hide the Main menu.

Main menu

Enable or disable this option to show or hide the Main menu.

Descriptions in Tree Views

Alt + Shift + \

Enable or disable this option to show or hide specific details in the tree views, for example, date and time of file modification and the size of the file.

Quick Definition

Control+Shift+I

Choose this command to open the quick definition popup. For more information, refer to Definition and type definition.

Quick Documentation

Control+Q

Choose this command to view quick documentation popup.

External Documentation

Shift+F1

Choose this command to view external documentation for a symbol in the default system browser.

Parameter Info

Control+P

Choose this command to .

Context Info

Alt+Q

Choose this command to show the current caret position, if it runs out of the visible editor pane.

Jump to Source

F4

Choose this command to edit a file selected in a tool window. The file opens in the editor.

Recent Files

Control+E

Choose this command to show the list of recently opened files and tool windows, and navigate to them.

Recently Changed Files

Choose this command to show the list of recently changed files and navigate to them.

Recent Changes

Alt+Shift+C

Choose this command to open the list of recent changes.

Compare with...

Choose this command to compare the file currently opened in the editor with the contents of another file Compare files, folders, and text sources.

Compare with Clipboard

Choose this command to compare the file currently opened in the editor with the contents of the system clipboard. For more information, refer to Compare files, folders, and text sources.

Quick Switch Scheme

Control+`

Choose this command to switch between schemes.

Active Editor

Point to this node to reveal the list of nested options. These commands apply to the active editor and is only available when it exists.

Show Whitespaces

Enable or disable this option to show or hide the whitespaces in the text.

Show Line Numbers

Enable or disable this option to show or hide line numbers.

Show Gutter Icons

Enable or disable this option to show or hide the icons in the left gutter.

Show Indent Guides

Enable or disable this option to show or hide vertical indent markers.

Use Soft Wraps

Enable or disable this option to show or hide soft wrap markers in the text.

Show Import Popups

Enable or disable this option to show or hide auto-import tooltips.

BiDi Text Direction

Point to this node to select the direction of text in the string literals containing RTL strings and tokens. For more information, refer to Text direction.

Menu item

Keyboard shortcut

Description

Class/File/Symbol

Control+N / Control+Shift+N

Control+Alt+Shift+N

Choose these commands to find and jump to a class, file, or symbol by name.

Custom Folding...

Control+Alt+.

Choose this command to navigate between custom regions.

Line/Column...

Control+G

Choose this command to navigate to the specified line of code.

Back/Forward

Control+Alt+ArrowLeft/Control+Alt+ArrowRight

Choose these commands to go through the history of the recently navigated items. These commands are duplicated with Back and Forward buttons on the main toolbar.

Search Everywhere

Press Shift twice

Use this command to find an item in the project or outside of it by its name. You can search for files, actions, classes, symbols, settings, and UI elements from a single entry point. Learn more from Search for a target by name (Search everywhere).

Last/Next Edit Location

Control+Shift+Backspace

Choose these commands to jump to the latest edit location and back.

Bookmarks

Point to this node to reveal the sub-menu of commands related to using bookmarks.

Select In...

Alt+F1

Choose this command to select the desired component from the list of possible targets.

Jump to Navigation Bar

Alt+Home

Choose this command to navigate across your project using the Navigation Bar.

Declaration

Control+B

Choose this command to jump to a declaration of a symbol.

Implementation(s)

Control+Alt+B

Choose this command to jump to an implementation of a method.

Type Declaration

Control+Shift+B

Choose this command to jump to the type declaration of a symbol.

Super Method

Control+U

Choose this command to jump to a super method of the method at caret.

Test

Control+Shift+T

Choose this command to navigate to an existing test, or create a test. For more information, refer to Create tests.

Related Symbol...

Control+Alt+Home

See Navigate between templates and views

File Structure

Control+F12

Choose this command to navigate through the source code using the File Structure view.

File Path

Control+Alt+F12

For more information, refer to Find a file path.

Type/Method/Call Hierarchy

Control+H/Control+Shift+H/Control+Alt+H

Choose these commands to navigate using the hierarchy views. For more information, refer to Source code hierarchy.

Next/Previous Highlighted Error

F2Shift+F2

Use these shortcuts to navigate between the highlighted errors.

Next/Previous Change

Control+Alt+Shift+ArrowDownControl+Alt+Shift+ArrowUp

Choose these commands to navigate through the change markers (when VCS integration is enabled).

Next/Previous Method

Alt+ArrowDownAlt+ArrowUp

Choose these commands to go up and down through the methods and tags.

Code

Menu item

Keyboard shortcut

Description

Override Methods...

Control+O

Choose this command to override a method. For more information, refer to Override methods of a superclass.

Implement Methods...

Control+I

Choose this command to implement a method.

Implement Functions...

Control+I

Choose this command to implement a method.

Generate...

Alt+Insert

Choose this command to create a new element. For more information, refer to Populate projects, Generate code.

Surround With...

Control+Alt+T

Choose this command to surround a logical fragment with code construct.

Unwrap/Remove...

Control+Shift+Delete

Choose this command to unwrap an expression from enclosing statements.

Code Completion

Point to this node to reveal the nested auto-completion commands.

Folding

Point to this node to reveal the nested folding commands.

Insert Live Template...

Control+J

Choose this command to create code constructs by live templates.

Surround with Live Template...

Control+Alt+J

Choose this command to create code constructs using surround templates.

Comment with Line Comment

Control+/

Choose this command to comment an entire line of code. For more information, refer to Lines of code.

Comment with Block Comment

Control+Shift+/

Choose this command to comment out a block of code. For more information, refer to Lines of code.

Reformat Code

Control+Alt+L

Choose this command to perform code reformatting. For more information, refer to Reformat and rearrange code.

Auto-Indent Lines

Control+Alt+I

Choose this command to change indentation.

Optimize Imports

Control+Alt+O

Choose this command to optimize import statements. For more information, refer to Auto import.

Rearrange Code

Choose this command to rearrange code according to the arrangement rules. This action is not supported for Python.

Move Statement Up/Down

Control+Shift+ArrowUp/Control+Shift+ArrowDown

Choose this command to Code statements.

Move Element Left/Right

Control+Alt+Shift+ArrowLeft / Control+Alt+Shift+ArrowRight

Choose this command to move element at caret left or right.

Move Line Up/Down

Alt+Shift+ArrowUp/Alt+Shift+ArrowDown

Choose this command to move a line at caret up or down.

Inspect Code...

Choose this command to run an inspection.

Code Cleanup

Choose this command to open the Specify Code Cleanup Scope dialog.

Run Inspection by Name...

Control+Alt+Shift+I

Choose this command to run the specified inspection.

Configure Current File Analysis...

Control+Alt+Shift+H

Choose this command to change highlighting level of the current file.

View Offline Inspection Results...

Choose this command to see inspection results stored on your computer.

Locate Duplicates...

Choose this command to find code duplicates. For more information, refer to Analyze duplicates.

Refactor

Menu item

Keyboard shortcut

Description

Refactor This...

Control+Alt+Shift+T

Choose this command to open a popup menu of the refactorings available in the current context. For more information, refer to Refactor code.

Rename...

Shift+F6

Choose this command to rename an element.

Change Signature...

Control+F6

Choose this command to perform the change signature refactoring. For more information, refer to Change signature.

Move...

F6

Choose this command to move a symbol to the specified location.

Copy...

Control+C

Choose this command to create a copy of an element in the specified location. For more information, refer to Copy refactoring.

Safe Delete

Alt+Delete

Choose this command to delete a symbol, performing search for its usages.

Extract

Choose this command to perform one of the extract refactorings.

Inline...

Control+Alt+N

Choose this command to perform inline refactoring.

Pull Members Up...

Choose this command to perform pull members up refactoring.

Push Members Down

Choose this command to perform push members down refactoring.

Invert Boolean

Choose this command to perform invert boolean refactoring.

Run

Menu item

Keyboard shortcut

Description

Run <current run/debug configuration>

Shift+F10

Choose this command to run the current script with the corresponding temporary run/debug configuration.

This command is duplicated with the Run button icon on the main toolbar.

Debug <current run/debug configuration>

Shift+F9

Choose this command to debug the current script with the corresponding temporary run/debug configuration.

This command is duplicated with Run the debugger icon on the main toolbar.

Run <current run/debug configuration> with Coverage

Choose this command to run with coverage the current script with the corresponding temporary run/debug configuration.

This command is duplicated with Run with coverage icon on the main toolbar.

Profile <current run/debug configuration>

Choose this command to perform profiling of the current script.

This command is duplicated by Profile a Run/Debug configuration icon on the main toolbar.

Concurrency Diagram for <current script>

Choose this command to explore the multi-threaded applications. For more information, refer to Thread Concurrency Visualization.

This command is duplicated by Thread concurrency visualiztion icon on the main toolbar.

Run...

Alt+Shift+F10

Choose this command to select the desired run/debug configuration, and then launch it.

Debug...

Alt+Shift+F9

Choose this command to select the desired run/debug configuration, and then launch it in debugging mode.

Attach to Process

Choose this command to attach to a Python script. For more information, refer to Attach to process.

Edit Configurations...

Choose this command to change run/debug configuration.

Show Running List

Choose this command to display a popup that lists all currently running/debugging applications. For more information, refer to View running processes.

Import Tests from File

Choose this command to import test results from a file.

Stop

Control+F2

Choose this command to terminate execution of a run/debug configuration. This command is duplicated with Stop icon in the toolboxes of the Run and Debug tool windows.

Stepping Commands

These commands become enabled with the debugger session on. For more information, refer to Step through the program and Debug tool window reference.

Pause Program

Choose this command to pause output of the current run or debug session. This command is duplicated with Pause icon in the toolboxes of the Run and Debug tool windows.

This action is not available for Run/Debug Configuration: Attach to Node.js/Chrome.

Resume Program

F9

Choose this command to resume the debugger session with the selected run/debug configuration. This command is duplicated with Resume program icon in the toolbox of the Debug tool windows.

Evaluate Expression

Alt+F8

Choose this command to evaluate expression during the debug session.

Quick Evaluate Expression

Control+Alt+F8

Choose this command to perform quick evaluation of an expression in the editor during the debug session.

Show Execution Point

Alt+F10

Choose this command to show execution point during during the debug session.

Toggle Line Breakpoint

Control+F8

Choose this command to turn on or off a line breakpoint. For more information, refer to Set line breakpoints.

Toggle Temporary Line Breakpoint

Control+Alt+Shift+F8

Choose this command to turn on or off a temporary line breakpoint. For more information, refer to Set line breakpoints.

View Breakpoints...

Control+Shift+F8

Choose this command to show all available breakpoints and change them in the Breakpoints dialog.

Tools

Note that composition of the menu Tools depends on the enabled plugins and external tools.

Menu item

Keyboard shortcut

Description

Tasks and Contexts

Point to this node to reveal the sub-menu of commands related to tasks and contexts management.

Save File as Template

Choose this command to save the current file as a template file.

IDE Scripting Console

Choose this command to launch the interactive scripting console.

Analyze Stack trace...

Choose this command to analyze external stack trace.

Capture Memory Snapshot

Choose this command to get the memory state of the profiled application.

Python Console

Choose this command to launch the Python interactive console.

Create setup.py / Run setup.py

Use these commands to create and run setup.py.

Show Code Coverage Data

Control+Alt+F6

Choose this command to view coverage results. For more information, refer to Code coverage.

Vim Emulator

Enable this option to enable or disable Vim emulation. This command only appears when Vim plugin is installed and enabled. For more information, refer to Configuring PyCharm to work as a Vim editor.

Reconfigure Vim Keymap

This command is only visible, when Vim Emulator is checked. Choose it to select a different base keymap for the Vim emulator.

Deployment

Point to this node to reveal the sub-menu of deployment-related commands. For more information, refer to Deploy.

Open terminal

Choose this command to run the Terminal emulator.

Start SSH Session

Choose this command to launch a terminal on a remote SSH server. For more information, refer to Run SSH terminal.

HTTP Client

Point to this node to reveal the sub-menu of commands related to composing and running requests to a RESTful web service. For more information, refer to HTTP Client.

Vagrant

Point to this node to reveal the sub-menu of standard Vagrant actions. For more information, refer to Vagrant: Working with Reproducible Development Environments, and Configuring PyCharm to work on a VM.

VCS

Note that the VCS menu contains different commands, depending on the enabled version control system. The following table shows the menu commands available when no version control integration is enabled.

Menu item

Keyboard shortcut

Description

Local History

Point to this node to reveal the list of commands related to Local History.

Enable Version Control Integration...

Choose this command to associate a project root with one of the supported version control systems.

VCS Operations Popup

Alt+`

Choose this command to invoke the popup list of the most popular VCS actions.

Apply Patch...

Choose this command to apply a patch.

Checkout from Version Control

Point to this node to reveal the sub-menu of the checkout commands, specific for the supported version control systems. With no version control integration enabled, it is possible to check out from SVN, Mercurial, Git, and GitHub.

Import into Version Control

Point to this node to reveal the sub-menu of the import commands, specific for the supported version control systems. With no version control integration enabled, it is possible to import to SVN, Mercurial, Git, and GitHub.

Browse VCS Repository

Point to this node to reveal the sub-menu of the browse commands, specific for the supported version control systems. With no version control integration enabled, it is possible to browse Subversion and Git repositories that are not associated with the currently opened project.

  • Browse Git Repository Log: choose this option to view the log for a local Git repository that is associated with another project. When you select the relevant repository in the Select Path dialog, PyCharm adds a new Log tab to the Version Control tool window and shows the log for the selected repository. The name of the project associated with the selected repository is displayed in the tab title, when you hover over the dialog, the full path to the repository is shown in a tooltip.

  • Browse Subversion Repository: when you choose this option PyCharm opens the SVN Repositories tool window where you can view, add, and edit location of SVN repositories.

It is important to note that with VCS integration enabled, the composition of the VCS menu is different.

Window

Menu item

Keyboard shortcut

Description

Layouts

Choose this command to save the current tool window arrangement as a layout and switch between created layouts.

Active Tool Window

Choose this command to reveal the sub-menu of commands, related to the active tool window. For more information, refer to Tool windows, Arrange tool windows, Tool window view modes.

Editor Tabs

Choose this command to reveal the sub-menu of commands, related to the editor tabs. For more information, refer to Editor tabs.

Note that these commands can also be found from the context menu of an editor tab.

Background Tasks

Choose this command to reveal the sub-menu of commands, related to performing tasks in the background. For more information, refer to Background tasks.

Next Project Window / Previous Project Window

Control+Alt+] Control+Alt+[

Choose this command to switch between currently opened projects.

<project>

Select project to be shown in the active window.

Help

Menu item

Keyboard shortcut

Description

Find Action

Control+Shift+A

Choose this command to invoke an action by its name.

Fill Answer Placeholders

Choose this command to get the correct answer.

Lean more about PyCharm Edu Edition

Choose this command to show the Quick Start Guide.

Keymap Reference

Choose this command to see the PyCharm shortcuts map in PDF format.

Demos and Screencasts

Choose this command to see the PyCharm demo videos and screencasts on YouTube.

Help

Choose this command to visit PyCharm online Help topics.

Tip of the Day

Choose this command to show an arbitrary tip.

For more information, refer to Using Tips of the Day.

Productivity Guide

Choose this command to show productivity guide.

Submit Feedback

Choose this command to report your overall impression of PyCharm to the support service.

For more information, refer to Reporting Issues and Sharing Your Feedback.

Show Log in Explorer/Finder

Choose this command to find PyCharm's log.

For more information, refer to Reporting Issues and Sharing Your Feedback.

Edit Custom Properties

Choose this command to open the custom file idea.properties, located under the user home. If this file does not exist, PyCharm suggests to create it.

For more information, refer to Advanced configuration.

Edit Custom VM Options

Choose this command to open the custom file .vmoptions, located under the user home. If this file does not exist, PyCharm suggests to create it.

For more information, refer toAdvanced configuration.

Debug Log Settings

Choose this command to change logging level for a category. Choosing this command leads to opening the Custom Debug Log Configuration dialog, where you have to type the log categories names, separated with new lines.

For more information, refer to Reporting Issues and Sharing Your Feedback.

Developer Community

Choose this command to open the PyCharm community page.

Register...

Choose this command to register PyCharm.

Check for Updates...

Choose this command to obtain information about the current version, and the availability of newer versions of PyCharm. For more information, refer to Update PyCharm.

This command in available on Windows/Linux. On macOS it appears on the PyCharm menu.

About

Choose this command to obtain information about the current version of PyCharm, current build, and so on. Press Escape to close the popup window.

This command in available on Windows/Linux. On macOS it appears on the PyCharm menu.

Last modified: 11 January 2024